Utiliser Gentoo et Calculate Linux

Installer Steam sur Calculate Linux

Cet article a été mis à jour, vous consultez ici une archive de cet article!
Table des matières

steam_logo







Introduction





Ici, on va voir comment installer steam sur Calculate Linux, et le faire fonctionner.





Installer Steam







Depuis les dépôts Calculate







On vérifie les paquets à installer :



Code BASH :
emerge -pv steam-launcher




On se rend compte que le paquet est archtildé. On le renseigne dans /etc/portage/package.keywords/custom



Code BASH :
ARCH=$(portageq envvar ARCH)
echo "games-util/steam-launcher ~$ARCH" >> /etc/portage/package.keywords/custom 
 




On installe ensuite steam



Code BASH :
emerge -qv steam-launcher






Méthode depuis le dépôts "Steam Overlay"







Ajouter le dépôt





On ajoute dans un premier temps le dépôt layman steam en root :



Code BASH :
 layman -a steam-overlay




Ensuite on met bien à jour les overlay :



Code BASH :
 layman -S




On vérifie ensuite que l'overlay est bien installé :



Code BASH :
layman -l
 
 * bumblebee                 [Git] (git://github.com/Bumblebee-Project/bumblebee-gentoo  )
 * calculate                 [Git] (git://git.calculate.ru/calculate/overlay.git  )
 * steam-overlay          [Git] (git://github.com/anyc/steam-overlay.git )






L'installation





On vérifie les paquets à installer :



Code BASH :
emerge -pv steam-runtime-bin steam-launcher steam-meta




On se rend compte que plusieurs paquets sont archtildés. On les renseigne dans /etc/portage/package.keywords/custom



Code BASH :
echo "app-emulation/steam-runtime-bin" >> /etc/portage/package.keywords/custom 
echo "games-util/steam-games-meta" >> /etc/portage/package.keywords/custom 
echo "games-util/steam-launcher" >> /etc/portage/package.keywords/custom 
echo "games-util/steam-meta" >> /etc/portage/package.keywords/custom 
echo "games-util/steam-client-meta" >> /etc/portage/package.keywords/custom 




Si on est en 64bits, il faut s'assurer d'installer flashplayer en 32bits :



Code BASH :
echo "www-plugins/adobe-flash abi_x86_32" >>  /etc/portage/package.use/custom 




On installe ensuite steam



Code BASH :
emerge -qv steam-runtime-bin steam-launcher steam-meta






Problèmes connus





Le paquet zenity peut échouer à l'installation. la cause : XML-Parser non détecté par le logiciel. Il suffit de désinstaller et réinstaller le paquet :



Code BASH :
emerge -C dev-perl/XML-Parser &&  emerge -q dev-perl/XML-Parser








Steam et Optimus





Si vous êtes comme moi, avec une carte Optimus, suivez dans un premier temps ceci : Cartes Optimus : Installer Bumblebee sous Calculate



Démasquer primus :



Code BASH :
echo "x11-misc/primus **" >> /etc/portage/package.keywords/custom 




Puis installer primus :



Code BASH :
emerge -qv x11-misc/primus






Pour chaque jeu, éditer dans les propriétés les options du lancement en mettant :



Code BASH :
primusrun %command%




steam_primusrun