Routeurs et protocoles de routage

Introduction







Configuration de routes statiques et route statique par défaut




Configuration d'une route statique



Configuration d'une route statique :

Code BASH :
Router(config)# ip route network-address subnet-mask {ip-address-next-hop | exit-interface }


Configuration de la route par défaut :

Code BASH :
Router(config)# ip route 0.0.0.0 0.0.0.0 [exit-interface | ip-address-next-hop ]



Commandes de visualisation et de dépannage pour le routage, valable pour tous les protocoles de routage



Code BASH :
Router# ping ip-address


Code BASH :
Router# traceroute ip-address


Code BASH :
Router# show ip route


Code BASH :
Router# show ip interface brief


Code BASH :
Router# show running-config


Code BASH :
Router# show cdp neighbors detail


Code BASH :
Router# debug ip routing


Code BASH :
Router# undebug ip routing


Code BASH :
Router# undebug all



Routage Dynamique




RIPv2




Configuration de RIPv2



Code BASH :
Router(config)# router rip


Code BASH :
Router(config-router)# version 2


Code BASH :
Router(config-router)# network directly-connected-classful-address


Code BASH :
Router(config-router)# passive-interface interface-type interface-number


Code BASH :
Router(config-router)# no auto-summary



Redistribution de route statique et propagation de la route par défaut



Distribution de routes statiques :

Code BASH :
Router(config-router)# redistribute static


Redistribuer la route par défaut :

Code BASH :
Router(config-router)# default-information originate



Dépannage de RIP



Code BASH :
Router# show ip route


Code BASH :
Router# show ip rip database


Code BASH :
Router# show ip protocols


Code BASH :
Router# debug ip rip



EIGRP




Configuration d'EIGRP



Code BASH :
Router(config)# router eigrp autonomous-system


Code BASH :
Router(config-router)# network network-address [wildcard-mask ]


Code BASH :
Router(config-router)# passive-interface interface-type interface-number


Code BASH :
Router(config-router)# no auto-summary



Propagation de la route par défaut et résumé de réseaux



Distribution de routes statiques :

Code BASH :
Router(config-router)# redistribute static


Résumé de réseaux (à appliquer sur l'interface qui a envoyer les mises à jour) :

Code BASH :
Router(config-if)# ip summary-address eigrp as-number network-address subnet-mask



Visualisation et dépannage d'EIGRP



Code BASH :
Router# show ip eigrp neighbors


Code BASH :
Router# show ip eigrp topology [network | all-links]


Code BASH :
Router# show ip route


Code BASH :
Router# show ip interface brief


Code BASH :
Router# show interface interface-type interface-number


Code BASH :
Router# show ip protocols


Code BASH :
Router# debug eigrp fsm




OSPF




Configuration d'OSPF



Code BASH :
Router(config)# router ospf process-id


Code BASH :
Router(config-router)# network network-address wildcard-mask area area-id


Code BASH :
Router(config-router)# passive-interface interface-type interface-number



Propagation de la route par défaut



Code BASH :
Router(config)# ip route 0.0.0.0 0.0.0.0 [exit-interface | ip-address ]


Code BASH :
Router(config-router)# default-information originate


Modifier les priorités et hello-interval



Changer la priorité d'une interface :

Code BASH :
Router(cconfig-if)# ip ospf priority number 


Changer le hello interval (Attention, changer sur les deux routeurs) :

Code BASH :
Router(config-if)# ip ospf hello-interval seconds



Visualisation et dépannage d'OSPF



Code BASH :
Router# show ip route


Code BASH :
Router# show ip interface brief


Code BASH :
Router# show ip ospf [interface interface-type interface-number ]


Code BASH :
Router# show ip ospf neighbor


Code BASH :
Router# show interface interface-type interface-number


Code BASH :
Router# show ip protocols
Cette page a été vue 8075 fois