News - Logiciels Libres

Gentoo : Erreur PERL lors de la mise à jour

Par , le dans Logiciels Libres - 3 Commentaires
Gentoo : Erreur PERL lors de la mise à jour
Bonjour à tous,

Si vous utilisez Gentoo ou Calculate Linux, vous avez peut être une erreur lors de la mise à jour avec PERL (Mise à jour de 5.22 vers 5.24).

Ce billet est écrit pour la mise à jour de la mi Avril 2017.

Code BASH :
gentoo ~ # emerge -avuDN --with-bdeps=y @world
 
 * IMPORTANT: 1 news items need reading for repository 'gentoo'.
 * Use eselect news read to view new items.
 
 
These are the packages that would be merged, in order:
 
Calculating dependencies... done!
[ebuild     U  ] sys-apps/opentmpfiles-0.1.3::gentoo [0.1.2::gentoo] USE="(-selinux)" 6 KiB
[ebuild     U  ] sys-libs/timezone-data-2017a::gentoo [2016h::gentoo] USE="nls -leaps_timezone" 523 KiB
[ebuild  N     ] app-portage/elt-patches-20170317::gentoo  23 KiB
[ebuild     U  ] app-admin/eselect-1.4.8::gentoo [1.4.5::gentoo] USE="-doc -emacs -vim-syntax" 173 KiB
[ebuild     U  ] sys-devel/gettext-0.19.8.1::gentoo [0.19.7::gentoo] USE="acl cxx ncurses nls openmp -cvs -doc -emacs -git -java -static-libs" ABI_X86="(64) -32 (-x32)" 19243 KiB
[ebuild     U  ] sys-apps/diffutils-3.5::gentoo [3.3::gentoo] USE="nls -static" 1330 KiB
[ebuild     U  ] dev-libs/libgpg-error-1.27-r1::gentoo [1.24::gentoo] USE="nls -common-lisp -static-libs" ABI_X86="(64) -32 (-x32)" 795 KiB
[ebuild  NS    ] sys-devel/gcc-5.4.0-r3:5.4.0::gentoo [4.9.4:4.9.4::gentoo] USE="cxx fortran (multilib) nls nptl openmp sanitize vtv (-altivec) (-awt) -cilk -debug -doc (-fixed-point) -gcj -go -graphite (-hardened) (-jit) (-libssp) -mpx -nopie -nossp -objc -objc++ -objc-gc -regression-test -vanilla" 93466 KiB
[ebuild     U  ] dev-lang/perl-5.24.1-r1:0/5.24::gentoo [5.22.3_rc4:0/5.22::gentoo] USE="berkdb gdbm -debug -doc -ithreads" 11414 KiB
[ebuild     U  ] virtual/perl-Data-Dumper-2.160.0-r1::gentoo [2.158.0-r1::gentoo] 0 KiB
[ebuild     U  ] virtual/perl-Test-Harness-3.360.100_rc::gentoo [3.350.100_rc::gentoo] 0 KiB
[ebuild     U  ] virtual/perl-ExtUtils-MakeMaker-7.100.200_rc::gentoo [7.40.200_rc::gentoo] 0 KiB
[ebuild     U  ] app-admin/perl-cleaner-2.25::gentoo [2.20::gentoo] 8 KiB
[ebuild     U  ] virtual/perl-File-Spec-3.630.100_rc::gentoo [3.560.200_rc::gentoo] 0 KiB
[ebuild     U  ] virtual/perl-CPAN-Meta-YAML-0.18.0-r1::gentoo [0.12.0-r3::gentoo] 0 KiB
[ebuild     U  ] virtual/perl-Parse-CPAN-Meta-1.441.700.100_rc::gentoo [1.441.400.100_rc::gentoo] 0 KiB
[ebuild     U  ] virtual/perl-Perl-OSType-1.9.0-r1::gentoo [1.8.0-r1::gentoo] 0 KiB
[ebuild     U  ] virtual/perl-Module-Metadata-1.0.31-r1::gentoo [1.0.26-r1::gentoo] 0 KiB
[ebuild     U  ] virtual/perl-Getopt-Long-2.480.0-r1::gentoo [2.450.0-r1::gentoo] 0 KiB
[ebuild     U  ] virtual/perl-ExtUtils-ParseXS-3.310.0-r1::gentoo [3.280.0-r1::gentoo] 0 KiB
[ebuild     U  ] virtual/perl-ExtUtils-CBuilder-0.280.225-r1::gentoo [0.280.221-r1::gentoo] 0 KiB
[ebuild     U  ] virtual/perl-version-0.991.600-r1::gentoo [0.990.900-r4::gentoo] 0 KiB
[ebuild  NS    ] sys-kernel/gentoo-sources-4.9.16:4.9.16::gentoo [4.4.39:4.4.39::gentoo, 4.9.6-r1:4.9.6-r1::gentoo] USE="-build -experimental -symlink" 394 KiB
[ebuild     U  ] virtual/perl-CPAN-Meta-2.150.5-r1::gentoo [2.150.1-r1::gentoo] 0 KiB
[ebuild     U  ] dev-libs/libtasn1-4.10-r1:0/6::gentoo [4.10:0/6::gentoo] USE="-doc -static-libs -valgrind" ABI_X86="(64) -32 (-x32)" 0 KiB
[ebuild     U  ] dev-libs/libgcrypt-1.7.6:0/20::gentoo [1.7.3:0/20::gentoo] USE="-doc -static-libs" ABI_X86="(64) -32 (-x32)" 2830 KiB
[ebuild   R    ] sys-apps/util-linux-2.28.2::gentoo  USE="cramfs ncurses nls pam readline suid unicode -build -caps -fdformat -kill -python (-selinux) -slang -static-libs -systemd {-test} -tty-helpers -udev" ABI_X86="(64) -32 (-x32)" PYTHON_SINGLE_TARGET="python3_4* -python2_7* (-python3_5)" PYTHON_TARGETS="python2_7 python3_4 (-python3_5)" 0 KiB
[ebuild     U  ] sys-apps/openrc-0.24.2::gentoo [0.23.2::gentoo] USE="ncurses netifrc pam unicode -audit -debug -newnet (-prefix) (-selinux) -static-libs (-tools%)" 208 KiB
[ebuild     U  ] dev-libs/libpcre-8.40-r1:3::gentoo [8.39:3::gentoo] USE="bzip2 cxx jit readline recursion-limit (unicode) zlib -libedit -pcre16 -pcre32 -static-libs" ABI_X86="(64) -32 (-x32)" 1524 KiB
[ebuild     U  ] app-admin/rsyslog-8.24.0-r2::gentoo [8.19.0::gentoo] USE="gcrypt ssl uuid -dbi -debug -doc -elasticsearch -grok -jemalloc -kafka -kerberos (-libressl) -mongodb -mysql -normalize -omhttpfs -omudpspoof -postgres -rabbitmq -redis -relp -rfc3195 -rfc5424hmac -snmp -systemd {-test} -usertools -zeromq" 2319 KiB
[ebuild     U  ] app-text/po4a-0.47-r1::gentoo [0.45-r3::gentoo] USE="{-test}" LINGUAS="fr -af -ca -cs -da -de -eo -es -et -eu -hr -id -it -ja -kn -ko -nb -nl -pl -pt -pt_BR -ru -sl -sv -uk -vi -zh_CN -zh_HK" 2334 KiB
[ebuild     U  ] dev-libs/glib-2.50.3-r1:2::gentoo [2.48.2:2::gentoo] USE="mime xattr -dbus -debug (-fam) (-selinux) -static-libs -systemtap {-test} -utils" ABI_X86="(64) -32 (-x32)" PYTHON_TARGETS="python2_7" 7412 KiB
 
Total: 32 packages (28 upgrades, 1 new, 2 in new slots, 1 reinstall), Size of downloads: 143994 KiB
 
!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:
 
dev-lang/perl:0
 
  (dev-lang/perl-5.24.1-r1:0/5.24::gentoo, ebuild scheduled for merge) pulled in by
    =dev-lang/perl-5.24.1* required by (virtual/perl-Test-Harness-3.360.100_rc:0/0::gentoo, ebuild scheduled for merge)
    ^              ^^^^^^^                                                                                                                                                    
    (and 16 more with the same problem)
 
  (dev-lang/perl-5.22.3_rc4:0/5.22::gentoo, installed) pulled in by
    dev-lang/perl:0/5.22= required by (virtual/perl-JSON-PP-2.273.0.100_rc-r1:0/0::gentoo, installed)
                 ^^^^^^^^                                                                                                                
    (and 16 more with the same problem)
 
NOTE: Use the '--verbose-conflicts' option to display parents omitted above
 
It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously.  If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously. You may want to try a larger value of
the --backtrack option, such as --backtrack=30, in order to see if
that will solve this conflict automatically.
 
For more information, see MASKED PACKAGES section in the emerge man
page or refer to the Gentoo Handbook.


Je vais vous montrer comment régler ce problème.

On va afficher les détails avec --verbose-conflicts :

Code BASH :
emerge -avuDN --with-bdeps=y @world --verbose-conflicts


Code TEXT :
dev-lang/perl:0
 
  (dev-lang/perl-5.24.1-r1:0/5.24::gentoo, ebuild scheduled for merge) pulled in by
    =dev-lang/perl-5.24.1* required by (virtual/perl-JSON-PP-2.273.0.100_rc-r1:0/0::gentoo, installed)
    ^              ^^^^^^^                                                                                                                                   
    =dev-lang/perl-5.24* required by (virtual/perl-ExtUtils-Install-2.40.0-r2:0/0::gentoo, installed)
    ^              ^^^^^                                                                                                                                    
    =dev-lang/perl-5.24* required by (virtual/perl-Text-ParseWords-3.300.0-r2:0/0::gentoo, ebuild scheduled for merge)
    ^              ^^^^^                                                                                                                                                     
    =dev-lang/perl-5.24* required by (virtual/perl-CPAN-Meta-2.150.5-r1:0/0::gentoo, ebuild scheduled for merge)
    ^              ^^^^^                                                                                                                                               
    =dev-lang/perl-5.24* required by (virtual/perl-Module-Metadata-1.0.31-r1:0/0::gentoo, ebuild scheduled for merge)
    ^              ^^^^^                                                                                                                                                    
    =dev-lang/perl-5.24.1* required by (virtual/perl-File-Spec-3.630.100_rc:0/0::gentoo, ebuild scheduled for merge)
    ^              ^^^^^^^                                                                                                                                                 
    =dev-lang/perl-5.24* required by (virtual/perl-ExtUtils-CBuilder-0.280.225-r1:0/0::gentoo, ebuild scheduled for merge)
    ^              ^^^^^                                                                                                                                                         
    =dev-lang/perl-5.24.1* required by (virtual/perl-ExtUtils-MakeMaker-7.100.200_rc:0/0::gentoo, ebuild scheduled for merge)
    ^              ^^^^^^^                                                                                                                                                          
    =dev-lang/perl-5.24* required by (virtual/perl-ExtUtils-Manifest-1.700.0-r3:0/0::gentoo, installed)
    ^              ^^^^^                                                                                                                                      
    =dev-lang/perl-5.24.1* required by (virtual/perl-Test-Harness-3.360.100_rc:0/0::gentoo, ebuild scheduled for merge)
    ^              ^^^^^^^                                                                                                                                                    
    =dev-lang/perl-5.24* required by (virtual/perl-version-0.991.600-r1:0/0::gentoo, ebuild scheduled for merge)
    ^              ^^^^^                                                                                                                                               
    =dev-lang/perl-5.24* required by (virtual/perl-Perl-OSType-1.9.0-r1:0/0::gentoo, ebuild scheduled for merge)
    ^              ^^^^^                                                                                                                                               
    =dev-lang/perl-5.24.1* required by (virtual/perl-Parse-CPAN-Meta-1.441.700.100_rc:0/0::gentoo, ebuild scheduled for merge)
    ^              ^^^^^^^                                                                                                                                                           
    =dev-lang/perl-5.24* required by (virtual/perl-Getopt-Long-2.480.0-r1:0/0::gentoo, ebuild scheduled for merge)
    ^              ^^^^^                                                                                                                                                 
    =dev-lang/perl-5.24* required by (virtual/perl-Data-Dumper-2.160.0-r1:0/0::gentoo, ebuild scheduled for merge)
    ^              ^^^^^                                                                                                                                                 
    =dev-lang/perl-5.24* required by (virtual/perl-CPAN-Meta-YAML-0.18.0-r1:0/0::gentoo, ebuild scheduled for merge)
    ^              ^^^^^                                                                                                                                                   
    =dev-lang/perl-5.24* required by (virtual/perl-ExtUtils-ParseXS-3.310.0-r1:0/0::gentoo, ebuild scheduled for merge)
    ^              ^^^^^                                                                                                                                                      
 
  (dev-lang/perl-5.22.3_rc4:0/5.22::gentoo, installed) pulled in by
    dev-lang/perl:0/5.22=[-build(-)] required by (dev-perl/SGMLSpm-1.03-r7:0/0::gentoo, installed)
                 ^^^^^^^^                                                                                                             
    dev-lang/perl:0/5.22= required by (dev-perl/Module-Build-0.421.600:0/0::gentoo, installed)
                 ^^^^^^^^                                                                                                         
    dev-lang/perl:0/5.22=[-build(-)] required by (dev-perl/libintl-perl-1.240.0:0/0::gentoo, installed)
                 ^^^^^^^^                                                                                                                  
    dev-lang/perl:0/5.22=[-build(-)] required by (perl-core/File-Temp-0.230.400-r1:0/0::gentoo, installed)
                 ^^^^^^^^                                                                                                                     
    dev-lang/perl:0/5.22=[-build(-)] required by (dev-perl/TermReadKey-2.330.0:0/0::gentoo, installed)
                 ^^^^^^^^                                                                                                                 
    dev-lang/perl:0/5.22= required by (virtual/perl-JSON-PP-2.273.0.100_rc-r1:0/0::gentoo, installed)
                 ^^^^^^^^                                                                                                                
    dev-lang/perl:0/5.22=[-build(-)] required by (dev-perl/Text-WrapI18N-0.60.0-r1:0/0::gentoo, installed)
                 ^^^^^^^^                                                                                                                     
    dev-lang/perl:0/5.22=[-build(-)] required by (dev-perl/Text-Unidecode-1.270.0:0/0::gentoo, installed)
                 ^^^^^^^^                                                                                                                    
    dev-lang/perl:0/5.22= required by (virtual/perl-ExtUtils-Manifest-1.700.0-r3:0/0::gentoo, installed)
                 ^^^^^^^^                                                                                                                   
    dev-lang/perl:0/5.22=[-build(-)] required by (dev-perl/Text-CharWidth-0.40.0-r1:0/0::gentoo, installed)
                 ^^^^^^^^                                                                                                                      
    dev-lang/perl:0/5.22= required by (sys-apps/texinfo-6.1:0/0::gentoo, installed)
                 ^^^^^^^^                                                                                              
    dev-lang/perl:0/5.22=[-build(-)] required by (dev-perl/Locale-gettext-1.50.0-r1:0/0::gentoo, installed)
                 ^^^^^^^^                                                                                                                      
    dev-lang/perl:0/5.22= required by (virtual/perl-File-Temp-0.230.400-r5:0/0::gentoo, installed)
                 ^^^^^^^^                                                                                                             
    dev-lang/perl:0/5.22=[-build(-)] required by (dev-perl/XML-Parser-2.440.0:0/0::gentoo, installed)
                 ^^^^^^^^                                                                                                                
    dev-lang/perl:0/5.22=[-build(-)] required by (dev-perl/Unicode-EastAsianWidth-1.330.0-r1:0/0::gentoo, installed)
                 ^^^^^^^^                                                                                                                               
    dev-lang/perl:0/5.22= required by (virtual/perl-ExtUtils-Install-2.40.0-r2:0/0::gentoo, installed)
                 ^^^^^^^^    


On remarque que des paquets pour la version 5.24 sont proposés pour la mise à jour (en vert dans votre console) et d'autres qui sont déjà installés (en bleu dans votre console).

Désinstaller ceux qui sont notés installés :

Code BASH :
emerge -C virtual/perl-ExtUtils-Manifest virtual/perl-ExtUtils-Install virtual/perl-JSON-PP


Relancer la mise à jour, et ça va passer sans encombres :)

Code BASH :
emerge -avuDN --with-bdeps=y @world


Les paquets désinstallés manuellement sont repoussés lors de la mise à jour :

Code TEXT :
Calculating dependencies... done!
[ebuild     U  ] sys-apps/opentmpfiles-0.1.3::gentoo [0.1.2::gentoo] USE="(-selinux)" 6 KiB
[ebuild     U  ] sys-libs/timezone-data-2017a::gentoo [2016h::gentoo] USE="nls -leaps_timezone" 523 KiB
[ebuild  N     ] app-portage/elt-patches-20170317::gentoo  23 KiB
[ebuild     U  ] app-admin/eselect-1.4.8::gentoo [1.4.5::gentoo] USE="-doc -emacs -vim-syntax" 173 KiB
[ebuild     U  ] sys-devel/gettext-0.19.8.1::gentoo [0.19.7::gentoo] USE="acl cxx ncurses nls openmp -cvs -doc -emacs -git -java -static-libs" ABI_X86="(64) -32 (-x32)" 19243 KiB
[ebuild     U  ] sys-apps/diffutils-3.5::gentoo [3.3::gentoo] USE="nls -static" 1330 KiB
[ebuild     U  ] dev-libs/libgpg-error-1.27-r1::gentoo [1.24::gentoo] USE="nls -common-lisp -static-libs" ABI_X86="(64) -32 (-x32)" 795 KiB
[ebuild  NS    ] sys-devel/gcc-5.4.0-r3:5.4.0::gentoo [4.9.4:4.9.4::gentoo] USE="cxx fortran (multilib) nls nptl openmp sanitize vtv (-altivec) (-awt) -cilk -debug -doc (-fixed-point) -gcj -go -graphite (-hardened) (-jit) (-libssp) -mpx -nopie -nossp -objc -objc++ -objc-gc -regression-test -vanilla" 93466 KiB
[ebuild  r  U  ] dev-lang/perl-5.24.1-r1:0/5.24::gentoo [5.22.3_rc4:0/5.22::gentoo] USE="berkdb gdbm -debug -doc -ithreads" 11414 KiB
[ebuild     U  ] virtual/perl-ExtUtils-MakeMaker-7.100.200_rc::gentoo [7.40.200_rc::gentoo] 0 KiB
[ebuild  rR    ] dev-perl/Locale-gettext-1.50.0-r1::gentoo  0 KiB
[ebuild     U  ] virtual/perl-File-Spec-3.630.100_rc::gentoo [3.560.200_rc::gentoo] 0 KiB
[ebuild     U  ] virtual/perl-Test-Harness-3.360.100_rc::gentoo [3.350.100_rc::gentoo] 0 KiB
[ebuild     U  ] virtual/perl-Data-Dumper-2.160.0-r1::gentoo [2.158.0-r1::gentoo] 0 KiB
[ebuild     U  ] virtual/perl-Parse-CPAN-Meta-1.441.700.100_rc::gentoo [1.441.400.100_rc::gentoo] 0 KiB
[ebuild     U  ] virtual/perl-CPAN-Meta-YAML-0.18.0-r1::gentoo [0.12.0-r3::gentoo] 0 KiB
[ebuild  rR    ] dev-perl/SGMLSpm-1.03-r7::gentoo  0 KiB
[ebuild  rR    ] dev-perl/Text-CharWidth-0.40.0-r1::gentoo  0 KiB
[ebuild  rR    ] dev-perl/libintl-perl-1.240.0::gentoo  0 KiB
[ebuild  rR    ] dev-perl/XML-Parser-2.440.0::gentoo  0 KiB
[ebuild  rR    ] perl-core/File-Temp-0.230.400-r1::gentoo  0 KiB
[ebuild     U  ] app-admin/perl-cleaner-2.25::gentoo [2.20::gentoo] 8 KiB
[ebuild  N     ] virtual/perl-Text-ParseWords-3.300.0-r2::gentoo  0 KiB
[ebuild     U  ] virtual/perl-Perl-OSType-1.9.0-r1::gentoo [1.8.0-r1::gentoo] 0 KiB
[ebuild     U  ] virtual/perl-Module-Metadata-1.0.31-r1::gentoo [1.0.26-r1::gentoo] 0 KiB
[ebuild     U  ] virtual/perl-Getopt-Long-2.480.0-r1::gentoo [2.450.0-r1::gentoo] 0 KiB
[ebuild     U  ] virtual/perl-ExtUtils-ParseXS-3.310.0-r1::gentoo [3.280.0-r1::gentoo] 0 KiB
[ebuild  N     ] virtual/perl-ExtUtils-Manifest-1.700.0-r3::gentoo  0 KiB
[ebuild  N     ] virtual/perl-ExtUtils-Install-2.40.0-r2::gentoo  0 KiB
[ebuild     U  ] virtual/perl-ExtUtils-CBuilder-0.280.225-r1::gentoo [0.280.221-r1::gentoo] 0 KiB
[ebuild  N     ] virtual/perl-JSON-PP-2.273.0.100_rc-r1::gentoo  0 KiB
[ebuild     U  ] virtual/perl-version-0.991.600-r1::gentoo [0.990.900-r4::gentoo] 0 KiB
[ebuild  NS    ] sys-kernel/gentoo-sources-4.9.16:4.9.16::gentoo [4.4.39:4.4.39::gentoo, 4.9.6-r1:4.9.6-r1::gentoo] USE="-build -experimental -symlink" 394 KiB
[ebuild  rR    ] virtual/perl-File-Temp-0.230.400-r5::gentoo  0 KiB
[ebuild  rR    ] dev-perl/Unicode-EastAsianWidth-1.330.0-r1::gentoo  0 KiB
[ebuild  rR    ] dev-perl/TermReadKey-2.330.0::gentoo  0 KiB
[ebuild  rR    ] dev-perl/Text-WrapI18N-0.60.0-r1::gentoo  0 KiB
[ebuild  rR    ] dev-perl/Text-Unidecode-1.270.0::gentoo  0 KiB
[ebuild     U  ] virtual/perl-CPAN-Meta-2.150.5-r1::gentoo [2.150.1-r1::gentoo] 0 KiB
[ebuild  rR    ] dev-perl/Module-Build-0.421.600::gentoo  USE="{-test}" 0 KiB
[ebuild  rR    ] sys-apps/texinfo-6.1::gentoo  USE="nls -static" 0 KiB
[ebuild     U  ] dev-libs/libtasn1-4.10-r1:0/6::gentoo [4.10:0/6::gentoo] USE="-doc -static-libs -valgrind" ABI_X86="(64) -32 (-x32)" 0 KiB
[ebuild     U  ] dev-libs/libgcrypt-1.7.6:0/20::gentoo [1.7.3:0/20::gentoo] USE="-doc -static-libs" ABI_X86="(64) -32 (-x32)" 2830 KiB
[ebuild  r  U  ] dev-libs/nettle-3.3-r1:0/6.1::gentoo [3.2-r1:0/6::gentoo] USE="gmp -doc (-neon) -static-libs {-test}" ABI_X86="(64) -32 (-x32)" CPU_FLAGS_X86="-aes" 1844 KiB
[ebuild   R    ] sys-apps/util-linux-2.28.2::gentoo  USE="cramfs ncurses nls pam readline suid unicode -build -caps -fdformat -kill -python (-selinux) -slang -static-libs -systemd {-test} -tty-helpers -udev" ABI_X86="(64) -32 (-x32)" PYTHON_SINGLE_TARGET="python3_4* -python2_7* (-python3_5)" PYTHON_TARGETS="python2_7 python3_4 (-python3_5)" 0 KiB
[ebuild     U  ] sys-apps/openrc-0.24.2::gentoo [0.23.2::gentoo] USE="ncurses netifrc pam unicode -audit -debug -newnet (-prefix) (-selinux) -static-libs (-tools%)" 208 KiB
[ebuild  rR    ] net-libs/gnutls-3.3.26::gentoo  USE="crywrap cxx nls openssl zlib -dane -doc -examples -guile -pkcs11 -static-libs {-test}" ABI_X86="(64) -32 (-x32)" LINGUAS="fr -cs -de -en -fi -it -ms -nl -pl -sv -uk -vi -zh_CN" 0 KiB
[ebuild     U  ] dev-libs/libpcre-8.40-r1:3::gentoo [8.39:3::gentoo] USE="bzip2 cxx jit readline recursion-limit (unicode) zlib -libedit -pcre16 -pcre32 -static-libs" ABI_X86="(64) -32 (-x32)" 1524 KiB
[ebuild     U  ] app-admin/rsyslog-8.24.0-r2::gentoo [8.19.0::gentoo] USE="gcrypt ssl uuid -dbi -debug -doc -elasticsearch -grok -jemalloc -kafka -kerberos (-libressl) -mongodb -mysql -normalize -omhttpfs -omudpspoof -postgres -rabbitmq -redis -relp -rfc3195 -rfc5424hmac -snmp -systemd {-test} -usertools -zeromq" 2319 KiB
[ebuild     U  ] app-text/po4a-0.47-r1::gentoo [0.45-r3::gentoo] USE="{-test}" LINGUAS="fr -af -ca -cs -da -de -eo -es -et -eu -hr -id -it -ja -kn -ko -nb -nl -pl -pt -pt_BR -ru -sl -sv -uk -vi -zh_CN -zh_HK" 2334 KiB
[ebuild     U  ] dev-libs/glib-2.50.3-r1:2::gentoo [2.48.2:2::gentoo] USE="mime xattr -dbus -debug (-fam) (-selinux) -static-libs -systemtap {-test} -utils" ABI_X86="(64) -32 (-x32)" PYTHON_TARGETS="python2_7" 7412 KiB
 
Total: 51 packages (29 upgrades, 5 new, 2 in new slots, 15 reinstalls), Size of downloads: 145837 KiB
 
The following packages are causing rebuilds:
 
  (dev-libs/nettle-3.3-r1:0/6.1::gentoo, ebuild scheduled for merge) causes rebuilds for:
    (net-libs/gnutls-3.3.26:0/0::gentoo, ebuild scheduled for merge)
  (dev-lang/perl-5.24.1-r1:0/5.24::gentoo, ebuild scheduled for merge) causes rebuilds for:
    (dev-perl/Text-CharWidth-0.40.0-r1:0/0::gentoo, ebuild scheduled for merge)
    (virtual/perl-JSON-PP-2.273.0.100_rc-r1:0/0::gentoo, ebuild scheduled for merge)
    (virtual/perl-Parse-CPAN-Meta-1.441.700.100_rc:0/0::gentoo, ebuild scheduled for merge)
    (virtual/perl-ExtUtils-ParseXS-3.310.0-r1:0/0::gentoo, ebuild scheduled for merge)
    (virtual/perl-ExtUtils-MakeMaker-7.100.200_rc:0/0::gentoo, ebuild scheduled for merge)
    (virtual/perl-ExtUtils-Manifest-1.700.0-r3:0/0::gentoo, ebuild scheduled for merge)
    (virtual/perl-CPAN-Meta-YAML-0.18.0-r1:0/0::gentoo, ebuild scheduled for merge)
    (app-text/po4a-0.47-r1:0/0::gentoo, ebuild scheduled for merge)
    (dev-perl/Module-Build-0.421.600:0/0::gentoo, ebuild scheduled for merge)
    (virtual/perl-CPAN-Meta-2.150.5-r1:0/0::gentoo, ebuild scheduled for merge)
    (dev-perl/SGMLSpm-1.03-r7:0/0::gentoo, ebuild scheduled for merge)
    (virtual/perl-File-Spec-3.630.100_rc:0/0::gentoo, ebuild scheduled for merge)
    (dev-perl/libintl-perl-1.240.0:0/0::gentoo, ebuild scheduled for merge)
    (perl-core/File-Temp-0.230.400-r1:0/0::gentoo, ebuild scheduled for merge)
    (dev-perl/TermReadKey-2.330.0:0/0::gentoo, ebuild scheduled for merge)
    (dev-perl/Text-Unidecode-1.270.0:0/0::gentoo, ebuild scheduled for merge)
    (virtual/perl-Test-Harness-3.360.100_rc:0/0::gentoo, ebuild scheduled for merge)
    (virtual/perl-ExtUtils-CBuilder-0.280.225-r1:0/0::gentoo, ebuild scheduled for merge)
    (dev-perl/Unicode-EastAsianWidth-1.330.0-r1:0/0::gentoo, ebuild scheduled for merge)
    (virtual/perl-File-Temp-0.230.400-r5:0/0::gentoo, ebuild scheduled for merge)
    (dev-perl/Locale-gettext-1.50.0-r1:0/0::gentoo, ebuild scheduled for merge)
    (virtual/perl-version-0.991.600-r1:0/0::gentoo, ebuild scheduled for merge)
    (virtual/perl-Perl-OSType-1.9.0-r1:0/0::gentoo, ebuild scheduled for merge)
    (dev-perl/Text-WrapI18N-0.60.0-r1:0/0::gentoo, ebuild scheduled for merge)
    (virtual/perl-Getopt-Long-2.480.0-r1:0/0::gentoo, ebuild scheduled for merge)
    (dev-perl/XML-Parser-2.440.0:0/0::gentoo, ebuild scheduled for merge)
    (sys-apps/texinfo-6.1:0/0::gentoo, ebuild scheduled for merge)
    (virtual/perl-Data-Dumper-2.160.0-r1:0/0::gentoo, ebuild scheduled for merge)
    (virtual/perl-ExtUtils-Install-2.40.0-r2:0/0::gentoo, ebuild scheduled for merge)
    (virtual/perl-Text-ParseWords-3.300.0-r2:0/0::gentoo, ebuild scheduled for merge)
    (virtual/perl-Module-Metadata-1.0.31-r1:0/0::gentoo, ebuild scheduled for merge)
 
Would you like to merge these packages? [Yes/No]


Et voilà :)