News - Logiciels Libres

Gentoo/Calculate : symbol lookup error après la mise à jour

Par , le dans Logiciels Libres - 2 Commentaires
Gentoo/Calculate : symbol lookup error après la mise à jour
Bonjour à tous,

Certains ont eu des soucis après la récente mise à jour de Calculate. C'était aussi mon cas, 2 applications ne se lançaient plus correctement : Chromium et Clémentine

Code BASH :
chromium-browser: symbol lookup error: chromium-browser: undefined symbol: _ZN3re23RE27ReplaceEPNSt7__cxx1112basic_stringIcSt11char_traitsIcESaIcEEERKS0_RKNS_11StringPieceE


Code BASH :
clementine: symbol lookup error: clementine: undefined symbol: _ZN6google8protobuf8internal13empty_string_B5cxx11E
 


Ce qui se passe c'est que Calculate et Gentoo sont passées récemment à GCC 5.4.

En mettant à jour son système, les dépendances ne sont pas réinstallées forcément si elles ne changent pas de version. Pourtant, les binaires chez calculate ont été régénérés. Du coup vous avez des programmes avec des bibliothèques (libraries) qui sont encore en GCC 4.9.

Pour remédier à ce souci, vous pouvez forcer la recompilation (ou le retéléchargement des binaires) via la commande :

Code BASH :
revdep-rebuild --library 'libstdc++.so.6' -- --exclude gcc


Chez moi, ça a concerné 276 paquets.

Citation:
dev-qt/qt3support:4 media-libs/chromaprint:0/1 dev-qt/qtsingleapplication:0 dev-qt/qtwebchannel:5/5.7 media-libs/libvisio:0 media-libs/opencv:0/3.1 dev-libs/crypto++:0/5.6 media-gfx/graphite2:0 net-libs/webkit-gtk:2 dev-libs/jsoncpp:0 dev-qt/qtcore:5/5.7 media-plugins/frei0r-plugins:0 kde-frameworks/ki18n:5/5.33 app-text/libwpg:0.3 net-analyzer/nmap:0 media-libs/libmediainfo:0 dev-util/cmake:0 net-ftp/filezilla:0 app-emulation/virtualbox:0 dev-libs/qjson:0 media-gfx/ufraw:0 dev-qt/qtgui:4 x11-misc/qt5ct:0 media-libs/ilmbase:0/11 media-libs/x265:0/102 dev-cpp/pangomm:1.4 www-plugins/chrome-binary-plugins:stable media-sound/clementine:0 sys-devel/llvm:0/3.9.1 dev-qt/qtscript:5/5.7 net-libs/webkit-gtk:4/37 kde-frameworks/kfilemetadata:5/5.33 kde-frameworks/knewstuff:5/5.33 dev-util/cppunit:0 x11-wm/fluxbox:0 app-crypt/gpgme:1/11 dev-qt/qtsvg:5/5.7 dev-python/subunit:0 games-arcade/blobby:0 media-libs/phonon:0 dev-util/patchelf:0 kde-frameworks/knotifyconfig:5/5.33 dev-libs/libixion:0/0.11 media-sound/id3v2:0 dev-cpp/libcmis:0.5 sys-apps/smartmontools:0 app-emulation/virtualbox-extpack-oracle:0 dev-qt/linguist-tools:5/5.7 media-libs/lensfun:0 media-sound/pulseaudio:0 media-libs/id3lib:0 media-libs/libmygpo-qt:0 dev-java/icedtea-web:0 app-office/libreoffice:0 kde-frameworks/attica:5/5.33 dev-libs/tinyxml2:0/2 sys-libs/ncurses:0/6 dev-util/ragel:0 dev-lang/spidermonkey:0/mozjs185 kde-frameworks/kded:5/5.33 media-libs/libvpx:0/3 dev-cpp/tbb:0 net-libs/gnutls:0 dev-libs/libsigc++:2 dev-qt/qtdeclarative:5/5.7 kde-frameworks/kconfig:5/5.33 x11-libs/vte:2.91 kde-frameworks/sonnet:5/5.33 dev-libs/liborcus:0/0.11 dev-db/mariadb:0/18 dev-libs/icu:0/58.2 media-video/simplescreenrecorder:0 sys-libs/db:5.3 media-libs/exempi:2 dev-qt/qtconcurrent:5/5.7 media-libs/vigra:0 dev-qt/qtwebkit:4 net-print/cups:0 media-plugins/gst-plugins-mplex:1.0 dev-qt/qtwidgets:5/5.7 media-gfx/hugin:0 app-text/opensp:0 media-libs/mesa:0 dev-libs/elfutils:0 dev-qt/qtsql:4 kde-frameworks/kpackage:5/5.33 dev-libs/tinyxml:0 app-portage/eix:0 dev-qt/qtwebkit:5/5.7 app-text/libmwaw:0 dev-qt/qtdbus:4 dev-libs/libcdio:0/15 dev-libs/librevenge:0 app-text/libodfgen:0 dev-qt/qtsql:5/5.7 dev-libs/boost:0/1.62.0 net-libs/zeromq:0/5 app-text/qpdf:0/13 net-misc/netkit-telnetd:0 app-text/libwps:0 sys-block/gparted:0 media-libs/libzen:0 dev-cpp/gtest:0 kde-frameworks/kdbusaddons:5/5.33 kde-frameworks/kdoctools:5/5.33 app-text/enchant:0 dev-cpp/atkmm:0 dev-qt/designer:5/5.7 games-emulation/dosbox:0 media-sound/mumble:0 media-libs/webrtc-audio-processing:0 dev-cpp/cairomm:0 media-libs/smpeg:0 kde-frameworks/kdnssd:5/5.33 dev-qt/qtwebengine:5/5.7 www-client/firefox:0 mail-mta/nullmailer:0 media-libs/libopenshot:0 sci-libs/flann:0 sys-devel/gettext:0 dev-qt/qtquickcontrols:5/5.7 dev-libs/leveldb:0 media-sound/mixxx:0 dev-qt/qtmultimedia:5/5.7 sys-apps/groff:0 media-libs/tiff:0 games-emulation/vbam:0 media-video/smplayer:0 dev-qt/qt-creator:0 dev-qt/qthelp:5/5.7 app-text/rarian:0 media-video/ffmpegthumbnailer:0 media-gfx/enblend:0 sys-auth/polkit-qt:0 x11-libs/wxGTK:2.8 media-libs/audiofile:0/1 dev-util/google-perftools:0/4 kde-frameworks/kcoreaddons:5/5.33 kde-frameworks/knotifications:5/5.33 sci-libs/hdf5:0/1.8.18 media-sound/pavucontrol:0 app-text/mythes:0 kde-apps/kdenlive:5 dev-qt/qtnetwork:5/5.7 kde-frameworks/kguiaddons:5/5.33 app-text/libmspub:0 media-libs/glu:0 dev-libs/gmp:0/10.4 dev-libs/liblinear:0/3 dev-qt/qttest:5/5.7 media-video/mjpegtools:1 dev-qt/qtxmlpatterns:4 kde-frameworks/kcodecs:5/5.33 dev-libs/protobuf:0/9 dev-qt/qtchooser:0 dev-qt/qtcore:4 kde-frameworks/kinit:5/5.33 dev-qt/qtwebsockets:5/5.7 media-libs/rubberband:0 dev-lang/swig:0 dev-util/ninja:0 dev-cpp/gtkglextmm:1.0 net-print/cups-filters:0 dev-python/PyQt5:0 kde-frameworks/kauth:5/5.33 dev-cpp/glibmm:2 kde-frameworks/kdeclarative:5/5.33 kde-frameworks/kcompletion:5/5.33 dev-qt/qtbluetooth:5/5.7 kde-frameworks/kxmlgui:5/5.33 kde-plasma/polkit-kde-agent:5 sys-apps/gptfdisk:0 media-libs/libpagemaker:0 media-libs/portaudio:0 sys-block/thin-provisioning-tools:0 kde-frameworks/karchive:5/5.33 media-libs/openexr:0/21 dev-qt/qtgui:5/5.7 kde-frameworks/kglobalaccel:5 dev-cpp/gtkmm:2.4 media-video/alexandra:0 dev-qt/qtxml:5/5.7 app-arch/p7zip:0 www-client/opera:0 media-sound/easytag:0 kde-frameworks/kio:5/5.33 dev-libs/botan:0 dev-python/shiboken:0 kde-frameworks/kwallet:5/5.33 net-libs/libproxy:0 dev-qt/qttest:4 media-gfx/exiv2:0/14 app-admin/conky:0 media-libs/libmp4v2:0 media-libs/ladspa-sdk:0 app-text/hunspell:0/1.6 kde-frameworks/kservice:5/5.33 dev-qt/qtsvg:4 kde-frameworks/kwidgetsaddons:5/5.33 media-libs/taglib:0 dev-libs/libdbusmenu-qt:0 media-libs/mlt:0 dev-util/re2c:0 app-text/poppler:0/62 x11-misc/primus:0 dev-python/pyside:0 media-video/movit:0 dev-cpp/gmock:0 app-text/djvu:0 media-libs/gegl:0 kde-frameworks/kcrash:5/5.33 kde-frameworks/kwindowsystem:5/5.33 media-libs/libopenshot-audio:0 media-gfx/imagemagick:0/6.9.7.4 media-libs/libopenraw:0 media-video/obs-studio:0 app-arch/unrar:0 kde-frameworks/kiconthemes:5/5.33 net-libs/nodejs:0 sys-fs/simple-mtpfs:0 dev-libs/zthread:0 media-sound/audacity:0 kde-frameworks/solid:5/5.33 app-text/libetonyek:0 media-libs/libcdr:0 media-libs/libfreehand:0 dev-qt/qtprintsupport:5/5.7 net-p2p/transmission:0 dev-qt/qtxmlpatterns:5/5.7 media-plugins/live:0/7 media-libs/vamp-plugin-sdk:0 media-libs/phonon-gstreamer:0 mate-extra/mate-system-monitor:0 app-arch/snappy:0 kde-frameworks/kcmutils:5/5.33 dev-cpp/gtkmm:3.0 dev-qt/qtopengl:5/5.7 app-text/libebook:0 kde-frameworks/kjobwidgets:5/5.33 app-text/libabw:0 mail-client/thunderbird:0 media-libs/flac:0 dev-qt/qtdbus:5/5.7 media-libs/libsoundtouch:0 dev-libs/double-conversion:0/1 kde-apps/krdc:5 dev-libs/re2:0/0.2016.05.01 dev-qt/qtscript:4 app-text/libwpd:0.10 kde-frameworks/kitemviews:5/5.33 dev-qt/qtopengl:4 kde-frameworks/kbookmarks:5/5.33 dev-libs/libpcre:3 dev-util/gperf:0 kde-frameworks/ktextwidgets:5/5.33 app-text/openjade:0 sys-power/powertop:0 media-plugins/gst-plugins-taglib:1.0 kde-frameworks/kconfigwidgets:5/5.33 x11-libs/wxGTK:3.0 www-plugins/adobe-flash:22 dev-cpp/clucene:1 dev-qt/qtlockedfile:0 app-pda/libplist:0/3 www-client/chromium:0


Vérifiez bien d'avoir synchronisé vos dépôts si ça fait longtemps que vous avez fait la partie 1 des mises à jour :

Code BASH :
eix-sync


Sur une distribution classique (RPM/DEB, etc...) les paquets sont recompilés et portent une révision de plus, donc ils sont proposés nativement en mise à jour. Ce qui n'est pas le cas de la distribution «from source».

Voilà :)

J'espère que ça a pu vous sauver.