News - Logiciels Libres

Calculate Linux : Corriger l'erreur mise à jour @__auto_slot_operator_replace_installed__

| | Logiciels Libres | 1 Commentaire | 655
Calculate Linux : Corriger l'erreur mise à jour @__auto_slot_operator_replace_installed__
Bonjour à tous,

On m'a signalé sur le canal d'entraide Telegram de Calculate FR un problème lors de la mise à jour d'une fresh install de Calculate Linux Desktop GNOME.

L'image la plus récente était celle du 16 Juin 2021.. Pourtant, je n'ai pas eu de soucis sur mon PC Fixe.
A noter que je viens actuellement de mettre à jour une VM CLDX, même erreur.

Je vous mets les dernières lignes de la console :

Code TEXT :
    (media-gfx/nomacs-3.16.224-r2:0/0::gentoo, binary scheduled for merge)
  (dev-libs/crypto++-8.5.0:0/8.5::gentoo, binary scheduled for merge) causes rebuilds for:
    (media-sound/clementine-1.4.0_rc1:0/0::gentoo, binary scheduled for merge)
  (dev-libs/protobuf-3.17.3:0/28::gentoo, binary scheduled for merge) causes rebuilds for:
    (media-sound/mixxx-2.2.4:0/0::gentoo, ebuild scheduled for merge)
    (media-sound/clementine-1.4.0_rc1:0/0::gentoo, binary scheduled for merge)
The following keyword changes are necessary to proceed:
 (see "package.accept_keywords" in the portage(5) man page for more details)
# required by @__auto_slot_operator_replace_installed__ (argument)
=dev-lang/perl-5.30.3-r1 ~amd64
 * Emerge a échoué
 * Mise à jour échouée


On constate un problème avec PERL. Cependant, le coupable ... n'est pas PERL (ni un des nombreux modules virtual/perl* ou dev-perl/*).

Après avoir buté une petite heure sur le problème, il s'agit d'une version ancienne de portage (3.0.18), qui contient des informations erronées avec la structure de paquets disponibles aujourd'hui.
Pour ne plus avoir le problème, il faut disposer de la version 3.0.20. Cette version a été stabilisée le 17 Juin 2021.

Si on lit attentivement les notes de version, on verra qu'il y a eu une inclusion du support d'EAPI8, ce qui nous pose problème ici :

Code TEXT :
News (mainly features/major bug fixes)
portage-3.0.21
--------------
* EAPI 8 fixups.
portage-3.0.20
--------------
* Finalize EAPI 8.
portage-3.0.19
--------------
* Enable EAPI 8.
portage-3.0.18
--------------
* profile-repo-deps is supported in layout.conf profile-formats.


L'opération de résolution consiste donc à un upgrade manuel de portage en premier lieu (ce qu'on fait habituellement avec Gentoo) :

Code BASH :
emerge -1 sys-apps/portage


Code :
>>> Emerging binary (1 of 1) sys-apps/portage-3.0.20-r6::gentoo
>>> Installing (1 of 1) sys-apps/portage-3.0.20-r6::gentoo


Si vous avez une erreur, désinstallez gentoolkit
Code BASH :
emerge -C app-portage/gentoolkit

Vous pouvez le réinstaller après avoir mis à jour portage.


Ensuite, mettez à jour votre Calculate :

Code BASH :
cl-update


Vous constaterez que votre système ce met à jour (ici sur ma VM CLDX) :

Code TEXT :
 * Xfce4 screenshooter application and panel plugin (U) xfce-extra/xfce4-screenshooter-1.9.9 (279 KiB)
 * Liste des paquets à supprimer
 * A somewhat comprehensive collection of Italian Linux man pages app-i18n/man-pages-it-5.06
 * A standalone utility to process systemd-style tmpfiles.d files sys-apps/opentmpfiles-0.2
 * 517 paquets à installer, 1619945 KiB à télécharger


Donc n'oubliez jamais : mettez à jour régulièrement votre système, surtout s'il est rolling release !
De mon côté, je vais essayer de générer plus souvent des images pour CLDGA :)


Je vous ai d'ailleurs mis à disposition une image en date du 28 Juillet 2021 ... aujourd'hui quoi :) : http://cldga.linuxtricks.fr