News - Logiciels Libres

Installer un kernel LTS supporté ou le dernier sur CentOS 6

Par , le dans Logiciels Libres - 2 Commentaires
Installer un kernel LTS supporté ou le dernier sur CentOS 6
Bonjour à tous,

voici un article lié à une vidéo, histoire d'avoir une petite trace écrite de ce qui a été mis en oeuvre.

Le but est d'installer un noyau plus récent sur CentOS 6, supporté, avec un dépôt fiable. (Actuellement 2.6.32)
Je rappelle, CentOS est sorti le 10 juillet 2011 et est supporté jusqu'au 30 novembre 2020, soit encore 2 bonnes années.

La montée en version du noyau est expliquée ici à titre d'exemple et d'intérêt.

Dans le monde professionnel (que je connais bien), je n'installe que des CentOS 7 maintenant. CentOS 7 possède un noyau LTS (3.10) mais qui n'est plus supporté par l'équipe du noyau Linux. Sachez que RedHat backporte les correctifs de sécurité. Donc il n'y a pas à craindre quoi que ce soit. Je reste sur les serveurs de mon entreprise avec les composants officiels CentOS, c'est beaucoup plus sûr.

Néanmoins, si vous souhaitez tenter l'expérience, ou que vous utilisez une station de travail avec CentOS, vous pouvez avoir besoin d'un noyau plus récent. J'avais utilisé il y a un peu plus de 5 ans cette méthode pour installer un noyau plus récent sur le eeePC d'un copain, qui avait des problèmes avec la gestion de son matériel (touches de fonction, Wi-Fi).

Dans un premier temps, il faut installer CentOS (hé oui, étonnant !)

Assurez-vous d'avoir un système à jour

Code BASH :
yum update


Ensuite, dans mon cas, j'ai installé le dépôt ELRepo pour CentOS 6 :

Code BASH :
yum install http://www.elrepo.org/elrepo-release-6-8.el6.elrepo.noarch.rpm


Le dépôt ELRepo contient des noyaux (dans un dépôt séparé), des pilotes et plein de modules.

Le dépôt des noyaux n'est pas activé par défaut, placez la ligne enabled à 1 dans la section [elrepo-kernel]

Code BASH :
vi /etc/yum.repos.d/elrepo.repo


Une fois activé, refaites un petit :

Code BASH :
yum update


Avec un

Code BASH :
yum search kernel-


on obtiens ceci :

Code TEXT :
kernel-lt.x86_64 : The Linux kernel. (The core of any Linux-based operating system.)
kernel-lt-devel.x86_64 : Development package for building kernel modules to match the kernel.
kernel-lt-doc.noarch : Various bits of documentation found in the kernel sources.
kernel-lt-headers.x86_64 : Header files of the Linux kernel for use by glibc.
kernel-ml.x86_64 : The Linux kernel. (The core of any Linux-based operating system.)
kernel-ml-devel.x86_64 : Development package for building kernel modules to match the kernel.
kernel-ml-doc.noarch : Various bits of documentation found in the kernel sources.
kernel-ml-headers.x86_64 : Header files of the Linux kernel for use by glibc.


Le kernel-lt correspond à un LTS supporté (au moment où je rédige cet article : 4.4.140)
Le kernel-ml correspond au Main Line (au moment où je rédige cet article, c'est le dernier, le 4.17.6)

Je privilégie toujours le LTS, donc dans ma démo, je prends le kernel-lt avec les headers + devel) :

Code BASH :
yum install kernel-lt{,-devel,-headers}


En redémarrant, le GRUB (Legacy - 0.97) démarre toujours par défaut sur le noyau 2.6.32.

Il suffit d'éditer le /boot/grub/menu.lst

Code BASH :
vi /boot/grub/menu.lst


Et placer la ligne default à 1 (1er choix du GRUB).

Un reboot et on est sur le 4.4.140 sans rien faire ;)

Voyez en vidéo la démo :

N'hésitez pas à sélectionner la qualité HD en 720p ou 1080p !



:magic: