<!DOCTYPE html>
<html lang="fr" prefix="og: http://ogp.me/ns#">
<head>
<title>Mon avis sur les SNAPS de Canonical - Logiciels Libres - News</title>
<meta charset="UTF-8" />
<meta name="description" content="Bonjour à tous,
je n'écris pas souvent. Cependant, j'aimerais de manière écrite faire un récap de ma pensée sur les SNAP de Canonical.
je vous préviens, ça va être long, mais je vous fais une analyse détaillée de ma pensée..." />
<meta name="generator" content="PHPBoost" />
<link rel="canonical" href="http://www.linuxtricks.fr/news/10-logiciels-libres/464-mon-avis-sur-les-snaps-de-canonical/" />
<meta name="viewport" content="width=device-width, initial-scale=1.0">
<meta property="og:site_name" content="Linuxtricks.fr" />
<meta property="og:locale" content="fr" />
<meta property="og:title" content="Mon avis sur les SNAPS de Canonical" />
<meta property="og:type" content="website" />
<meta property="og:description" content="Bonjour à tous,
je n'écris pas souvent. Cependant, j'aimerais de manière écrite faire un récap de ma pensée sur les SNAP de Canonical.
je vous préviens, ça va être long, mais je vous fais une analyse détaillée de ma pensée..." />
<meta property="og:url" content="http://www.linuxtricks.fr/news/10-logiciels-libres/464-mon-avis-sur-les-snaps-de-canonical/" />
<meta property="og:image" content="http://www.linuxtricks.fr/news/news.png" />
<link rel="stylesheet" href="/templates/default/theme/default.css" type="text/css" media="screen, print" />
<link rel="stylesheet" href="/kernel/lib/css/font-awesome/css/font-awesome.css" />
<link rel="stylesheet" href="/kernel/lib/css/font-awesome-animation/css/font-awesome-animation.css" />
<link rel="stylesheet" href="/kernel/lib/js/lightcase/css/lightcase.css" />
<link rel="stylesheet" href="/templates/linuxtricks/theme/design.css" type="text/css" media="screen" />
<link rel="stylesheet" href="/templates/linuxtricks/theme/content.css" type="text/css" media="screen, print" />
<link rel="stylesheet" href="/templates/linuxtricks/theme/table.css" type="text/css" media="screen, print" />
<link rel="stylesheet" href="/templates/linuxtricks/theme/form.css" type="text/css" media="screen, print" />
<link rel="stylesheet" href="/templates/linuxtricks/theme/global.css" type="text/css" media="screen, print" />
<link rel="stylesheet" href="/templates/linuxtricks/theme/cssmenu.css" type="text/css" media="screen" />
<link rel="stylesheet" href="/templates/linuxtricks/modules/connect/connect_mini.css" type="text/css" media="screen, print" /><link rel="stylesheet" href="/online/templates/online.css" type="text/css" media="screen, print" /><link rel="stylesheet" href="/poll/templates/poll_mini.css" type="text/css" media="screen, print" /><link rel="stylesheet" href="/search/templates/search_mini.css" type="text/css" media="screen, print" /><link rel="stylesheet" href="/BBCode/templates/bbcode.css" type="text/css" media="screen, print" /><link rel="stylesheet" href="/ThemesSwitcher/templates/themeswitcher.css" type="text/css" media="screen, print" /><link rel="stylesheet" href="/ReCaptcha/templates/ReCaptcha.css" type="text/css" media="screen, print" /><link rel="stylesheet" href="/SocialNetworks/templates/SocialNetworks.css" type="text/css" media="screen, print" /><link rel="stylesheet" href="/user/templates/user.css" type="text/css" media="screen, print" /><link rel="stylesheet" href="/user/templates/upload.css" type="text/css" media="screen, print" /><link rel="stylesheet" href="/news/templates/news.css" type="text/css" media="screen, print" />
<link rel="shortcut icon" href="/lt-favicon-2015.ico" type="image/vnd.microsoft.icon" />


</head>
<body itemscope="itemscope" itemtype="http://schema.org/WebPage">
<header id="header">
<div id="top-header">
<div id="site-infos">
<div id="site-logo" ></div>
<div id="site-name-container">
<a id="site-name" href="/">Linuxtricks.fr</a>
<span id="site-slogan">Site mémo et blogue d'Adrien.D</span>
</div>
</div>
<div id="top-header-content">
<div role="search" id="module-mini-search" class="float-right">
<form role="search" action="/search/search.php#results" onsubmit="return check_search_mini_form_post();" method="post">
<div id="mini-search-form" class="input-element-button">
<input type="search" id="TxTMiniSearched" title="Votre recherche" name="q" value="" placeholder="Recherche..." aria-labelledby="SearchButton">
<input type="hidden" id="search-token" name="token" value="3e50b316b8e33a57">
<button id="SearchButton" class="submit" type="submit" name="search_submit"><i class="fa fa-search" aria-hidden="true"></i><span class="sr-only">Rechercher</span></button>
</div>
</form>
</div>

</div>
</div>
<div id="sub-header">
<div id="sub-header-content">
 
 
<nav aria-label="Linuxtricks" id="cssmenu-1764" class="cssmenu cssmenu-horizontal cssmenu-with-submenu">
<a href="/" title="Linuxtricks" class="cssmenu-img cssmenu-img-level-0">
</a>
<ul class="level-0"> 
<li>
<a href="/" title="Lien vers la page Accueil" class="cssmenu-title"><img src="/adrien/images/accueil_12.png" alt="" height="12" width="12" /> Accueil</a>
</li>
 
 
<li class="has-sub" >
<a href="/news" title="Lien vers la page Blogue" class="cssmenu-title"><img src="/adrien/images/blogue_12.png" alt="" height="12" width="12" /> Blogue</a>
 
<ul class="level-1"> 
<li>
<a href="/news/" title="Lien vers la page Tout le blogue" class="cssmenu-title"><img src="/adrien/images/blogue_12.png" alt="" height="12" width="12" /> Tout le blogue</a>
</li>
 
<li>
<a href="/news/10-logiciels-libres/" title="Lien vers la page Logiciels libres" class="cssmenu-title"><img src="/adrien/images/blogue_12.png" alt="" height="12" width="12" /> Logiciels libres</a>
</li>
 
<li>
<a href="/news/12-actus-linuxtricks/" title="Lien vers la page Actus Linuxtricks" class="cssmenu-title"><img src="/adrien/images/blogue_12.png" alt="" height="12" width="12" /> Actus Linuxtricks</a>
</li>
 
<li>
<a href="/news/11-le-sac-de-chips/" title="Lien vers la page Le sac de chips" class="cssmenu-title"><img src="/adrien/images/blogue_12.png" alt="" height="12" width="12" /> Le sac de chips</a>
</li>
</ul>
</li>
 
 
<li class="has-sub" >
<a href="/wiki" title="Lien vers la page Wiki" class="cssmenu-title"><img src="/adrien/images/wiki_12.png" alt="" height="12" width="12" /> Wiki</a>
 
<ul class="level-1"> 
<li>
<a href="/wiki/cisco" title="Lien vers la page Cisco" class="cssmenu-title"><img src="/adrien/images/cisco_12.png" alt="" height="12" width="12" /> Cisco</a>
</li>
 
<li>
<a href="/wiki/console" title="Lien vers la page Console" class="cssmenu-title"><img src="/adrien/images/console_12.png" alt="" height="12" width="12" /> Console</a>
</li>
 
<li>
<a href="/wiki/environnements-de-bureau" title="Lien vers la page Env. de bureau" class="cssmenu-title"><img src="/adrien/images/environnements-bureau_12.png" alt="" height="12" width="12" /> Env. de bureau</a>
</li>
 
<li>
<a href="/wiki/generalites-systeme-linux" title="Lien vers la page Généralités Linux" class="cssmenu-title"><img src="/adrien/images/generalites-linux_12.png" alt="" height="12" width="12" /> Généralités Linux</a>
</li>
 
<li>
<a href="/wiki/logiciels" title="Lien vers la page Logiciels" class="cssmenu-title"><img src="/adrien/images/logiciels_12.png" alt="" height="12" width="12" /> Logiciels</a>
</li>
 
<li>
<a href="/wiki/programmation" title="Lien vers la page Scripts et Programmation" class="cssmenu-title"><img src="/adrien/images/programmation_12.png" alt="" height="12" width="12" /> Scripts et Programmation</a>
</li>
 
<li>
<a href="/wiki/services" title="Lien vers la page Services et Serveurs" class="cssmenu-title"><img src="/adrien/images/services_12.png" alt="" height="12" width="12" /> Services et Serveurs</a>
</li>
 
<li>
<a href="/wiki/utiliser-gentoo-et-calculate-linux" title="Lien vers la page Calculate / Gentoo" class="cssmenu-title"><img src="/adrien/images/utiliser-calculate_12.png" alt="" height="12" width="12" /> Calculate / Gentoo</a>
</li>
 
<li>
<a href="/wiki/utiliser-fedora-et-centos" title="Lien vers la page Fedora/CentOS" class="cssmenu-title"><img src="/adrien/images/utiliser-centos_12.png" alt="" height="12" width="12" /> Fedora/CentOS</a>
</li>
 
<li>
<a href="/wiki/utiliser-debian-et-ses-outils" title="Lien vers la page Debian" class="cssmenu-title"><img src="/adrien/images/utiliser-debian_12.png" alt="" height="12" width="12" /> Debian</a>
</li>
 
<li>
<a href="/wiki/autres-distribs-linux" title="Lien vers la page Autres distribs" class="cssmenu-title"><img src="/adrien/images/autres-linux_12.png" alt="" height="12" width="12" /> Autres distribs</a>
</li>
 
<li>
<a href="/wiki/hors-linux" title="Lien vers la page Hors Linux" class="cssmenu-title"><img src="/adrien/images/hors-linux_12.png" alt="" height="12" width="12" /> Hors Linux</a>
</li>
 
<li>
<a href="/wiki/bac-a-sable" title="Lien vers la page Bac à sable" class="cssmenu-title"><img src="/adrien/images/bac-a-sable_12.png" alt="" height="12" width="12" /> Bac à sable</a>
</li>
 
<li>
<a href="/wiki/en-cours-de-redaction" title="Lien vers la page En rédaction" class="cssmenu-title"><img src="/adrien/images/en-cours-de-redaction_12.png" alt="" height="12" width="12" /> En rédaction</a>
</li>
 
<li>
<a href="/wiki/archives" title="Lien vers la page Archives" class="cssmenu-title"><img src="/adrien/images/archives_12.png" alt="" height="12" width="12" /> Archives</a>
</li>
</ul>
</li>
 
 
<li class="has-sub" >
<a href="/wiki/conferences-et-ateliers" title="Lien vers la page COAGUL" class="cssmenu-title"><img src="/adrien/images/articles_12.png" alt="" height="12" width="12" /> COAGUL</a>
 
<ul class="level-1"> 
<li>
<a href="http://coagul.org/" title="Lien vers la page Site coagul.org" class="cssmenu-title"><img src="/adrien/images/web_12.png" alt="" height="12" width="12" /> Site coagul.org</a>
</li>
 
<li>
<a href="/wiki/dijon-pub-referencement-participatif-de-la-publicite" title="Lien vers la page Audit participatif pub" class="cssmenu-title"><img src="/adrien/images/articles_12.png" alt="" height="12" width="12" /> Audit participatif pub</a>
</li>
 
<li>
<a href="/wiki/conference-coagul-initiation-a-la-mise-en-paquet-rpm" title="Lien vers la page Conférence  création RPM" class="cssmenu-title"><img src="/adrien/images/articles_12.png" alt="" height="12" width="12" /> Conférence  création RPM</a>
</li>
 
<li>
<a href="/wiki/atelier-coagul-decouverte-du-cms-phpboost-version-4-1" title="Lien vers la page Atelier Découverte PHPBoost" class="cssmenu-title"><img src="/adrien/images/articles_12.png" alt="" height="12" width="12" /> Atelier Découverte PHPBoost</a>
</li>
 
<li>
<a href="/wiki/atelier-coagul-introduction-aux-conteneurs-lxc-et-proxmoxve-3-4" title="Lien vers la page Atelier Conteneurs (LXC et ProxMox)" class="cssmenu-title"><img src="/adrien/images/articles_12.png" alt="" height="12" width="12" /> Atelier Conteneurs (LXC et ProxMox)</a>
</li>
 
<li>
<a href="/wiki/mise-en-place-de-son-cloud-personnel-avec-owncloud" title="Lien vers la page Atelier Owncloud" class="cssmenu-title"><img src="/adrien/images/articles_12.png" alt="" height="12" width="12" /> Atelier Owncloud</a>
</li>
 
<li>
<a href="/wiki/atelier-coagul-installer-linux-sur-son-pc-avec-linux-mint" title="Lien vers la page Atelier Débutant Installation Linux Mint - 2016" class="cssmenu-title"><img src="/adrien/images/articles_12.png" alt="" height="12" width="12" /> Atelier Débutant Installation Linux Mint - 2016</a>
</li>
 
<li>
<a href="/wiki/atelier-coagul-installation-de-linux-mint-a-cote-de-windows-10-2019" title="Lien vers la page Atelier Débutant Installation Linux Mint - 2019" class="cssmenu-title"><img src="/adrien/images/articles_12.png" alt="" height="12" width="12" /> Atelier Débutant Installation Linux Mint - 2019</a>
</li>
 
<li>
<a href="/wiki/table-ronde-astuces-et-bonnes-pratiques-de-l-utilisation-d-internet" title="Lien vers la page Table ronde : Utiliser Internet" class="cssmenu-title"><img src="/adrien/images/articles_12.png" alt="" height="12" width="12" /> Table ronde : Utiliser Internet</a>
</li>
 
<li>
<a href="http://marjo21.linuxtricks.fr/" title="Lien vers la page marjo21 - Collecteur de liens" class="cssmenu-title"><img src="/adrien/images/marjo21_12.png" alt="" height="12" width="12" /> marjo21 - Collecteur de liens</a>
</li>
</ul>
</li>
 
 
<li class="has-sub" >
<span class="cssmenu-title"><img src="/adrien/images/a-propos_12.png" alt="" height="12" width="12" />A propos</span>
 
<ul class="level-1"> 
<li>
<a href="/pages/contact" title="Lien vers la page Contact" class="cssmenu-title"><img src="/adrien/images/contact_12.png" alt="" height="12" width="12" /> Contact</a>
</li>
 
 
<li class="has-sub" >
<span class="cssmenu-title"><img src="/adrien/images/flux_12.png" alt="" height="12" width="12" />RSS</span>
 
<ul class="level-2"> 
<li>
<a href="/syndication/rss/wiki" title="Lien vers la page Wiki" class="cssmenu-title"><img src="/adrien/images/flux_12.png" alt="" height="12" width="12" /> Wiki</a>
</li>
 
<li>
<a href="/syndication/rss/news" title="Lien vers la page Blogue" class="cssmenu-title"><img src="/adrien/images/flux_12.png" alt="" height="12" width="12" /> Blogue</a>
</li>
 
<li>
<a href="/user/messages/comments" title="Lien vers la page Commentaires" class="cssmenu-title"><img src="/adrien/images/flux_12.png" alt="" height="12" width="12" /> Commentaires</a>
</li>
</ul>
</li>
 
<li>
<a href="http://miroir.linuxtricks.fr/" title="Lien vers la page Miroir Calculate Linux" class="cssmenu-title"><img src="/adrien/images/utiliser-calculate_12.png" alt="" height="12" width="12" /> Miroir Calculate Linux</a>
</li>
 
 
<li class="has-sub" >
<span class="cssmenu-title"><img src="/adrien/images/web_12.png" alt="" height="12" width="12" />Liens utiles</span>
 
<ul class="level-2"> 
<li>
<a href="http://linuxfr.org/" title="Lien vers la page Linuxfr.org" class="cssmenu-title"><img src="/adrien/images/web_12.png" alt="" height="12" width="12" /> Linuxfr.org</a>
</li>
 
<li>
<a href="https://www.journalduhacker.net/" title="Lien vers la page Le journal du hacker" class="cssmenu-title"><img src="/adrien/images/web_12.png" alt="" height="12" width="12" /> Le journal du hacker</a>
</li>
 
<li>
<a href="http://www.mageialinux-online.org/" title="Lien vers la page MageiaLinux-Online (MLO)" class="cssmenu-title"><img src="/adrien/images/web_12.png" alt="" height="12" width="12" /> MageiaLinux-Online (MLO)</a>
</li>
 
<li>
<a href="http://www.calculate-linux.org/en" title="Lien vers la page CalculateLinux" class="cssmenu-title"><img src="/adrien/images/web_12.png" alt="" height="12" width="12" /> CalculateLinux</a>
</li>
 
<li>
<a href="http://pkgs.org/" title="Lien vers la page pkgs.org" class="cssmenu-title"><img src="/adrien/images/web_12.png" alt="" height="12" width="12" /> pkgs.org</a>
</li>
 
<li>
<a href="http://gpo.zugaina.org/Overlays/" title="Lien vers la page Overlays Gentoo" class="cssmenu-title"><img src="/adrien/images/web_12.png" alt="" height="12" width="12" /> Overlays Gentoo</a>
</li>
 
<li>
<a href="https://www.kernel.org/" title="Lien vers la page kernel.org" class="cssmenu-title"><img src="/adrien/images/web_12.png" alt="" height="12" width="12" /> kernel.org</a>
</li>
 
<li>
<a href="http://distrowatch.com/" title="Lien vers la page Distrowatch" class="cssmenu-title"><img src="/adrien/images/web_12.png" alt="" height="12" width="12" /> Distrowatch</a>
</li>
 
<li>
<a href="ftp://www.mirrorservice.org/sites/" title="Lien vers la page Mirror Service" class="cssmenu-title"><img src="/adrien/images/web_12.png" alt="" height="12" width="12" /> Mirror Service</a>
</li>
 
<li>
<a href="http://www.cert.ssi.gouv.fr/site/" title="Lien vers la page CERT-FR" class="cssmenu-title"><img src="/adrien/images/web_12.png" alt="" height="12" width="12" /> CERT-FR</a>
</li>
 
<li>
<a href="https://www.cnil.fr/" title="Lien vers la page CNIL" class="cssmenu-title"><img src="/adrien/images/web_12.png" alt="" height="12" width="12" /> CNIL</a>
</li>
 
<li>
<a href="https://www.legifrance.gouv.fr/affichTexte.do?cidTexte=LEGITEXT000006068624&dateTexte=vig" title="Lien vers la page Loi n° 78-17 du 6 janvier 1978" class="cssmenu-title"><img src="/adrien/images/web_12.png" alt="" height="12" width="12" /> Loi n° 78-17 du 6 janvier 1978</a>
</li>
</ul>
</li>
 
<li>
<a href="/poll/" title="Lien vers la page Sondages" class="cssmenu-title"><img src="/adrien/images/sondage_12.png" alt="" height="12" width="12" /> Sondages</a>
</li>
 
<li>
<a href="https://twitter.com/search?f=tweets&vertical=default&q=linuxtricks.fr&src=typd" title="Lien vers la page On tweet Linuxtricks" class="cssmenu-title"><img src="/adrien/images/tweet_12.png" alt="" height="12" width="12" /> On tweet Linuxtricks</a>
</li>
 
<li>
<a href="https://github.com/aaaaadrien" title="Lien vers la page Mon Github" class="cssmenu-title"><img src="/adrien/images/web_12.png" alt="" height="12" width="12" /> Mon Github</a>
</li>
 
<li>
<a href="https://www.youtube.com/channel/UCDKPGD9T00eS_l--D_DRTUQ/videos?sub_confirmation=1" title="Lien vers la page Ma chaine Youtube" class="cssmenu-title"><img src="/adrien/images/web_12.png" alt="" height="12" width="12" /> Ma chaine Youtube</a>
</li>
</ul>
</li>
</ul>
</nav>
</div>
<div class="spacer"></div>
</div>
<div class="spacer"></div>
</header>
<div id="global">
<div id="visit-counter" class="hidden-small-screens">
<div class="visit-counter-total">
<span class="text-strong">Visiteurs : </span>
2983450
</div>
<div class="visit-counter-today">
<span class="text-strong">Aujourd'hui : </span>
3120
</div>
</div>
<div id="main" class="" role="main">
<div id="main-content" itemprop="mainContentOfPage">


<nav id="breadcrumb" itemprop="breadcrumb">
    <ol itemscope itemtype="http://schema.org/BreadcrumbList">
<li itemprop="itemListElement" itemscope itemtype="http://data-vocabulary.org/ListItem">
           <a href="/" itemprop="item">
                <span itemprop="name">Accueil</span>
                <meta itemprop="position" content="1" />
            </a>
</li>
        
<li itemprop="itemListElement" itemscope itemtype="http://data-vocabulary.org/ListItem" >
          <a href="/news/" itemprop="item">
            <span itemprop="name">News</span>
            <meta itemprop="position" content="" />
          </a>
        </li>
        
<li itemprop="itemListElement" itemscope itemtype="http://data-vocabulary.org/ListItem" >
          <a href="/news/10-logiciels-libres/" itemprop="item">
            <span itemprop="name">Logiciels Libres</span>
            <meta itemprop="position" content="" />
          </a>
        </li>
        
<li itemprop="itemListElement" itemscope itemtype="http://data-vocabulary.org/ListItem"  class="current" >
          <a href="/news/10-logiciels-libres/464-mon-avis-sur-les-snaps-de-canonical/" itemprop="item">
            <span itemprop="name">Mon avis sur les SNAPS de Canonical</span>
            <meta itemprop="position" content="" />
          </a>
        </li>
        
    </ol>
</nav>
<section id="module-news">
<header>
<div class="cat-actions">
<a href="/syndication/rss/news/10" aria-label="Syndication"><i class="fa fa-syndication" aria-hidden="true" title="Syndication"></i></a> News - Logiciels Libres
</div>
<h1><span itemprop="name">Mon avis sur les SNAPS de Canonical</span></h1>
</header>
<div itemscope="itemscope" itemtype="http://schema.org/CreativeWork" id="article-news-464" class="article-news new-content">
<div class="actions">
</div>
<div class="more">
<span class="more-element more-element-author">
<i class="fa fa-user-o" aria-hidden="true"></i>
<a itemprop="author" rel="author" class="admin" href="/user/profile/1" >Adrien.D</a>
 |
</span>
<span class="more-element more-element-date">
<i class="fa fa-calendar" aria-hidden="true"></i> <time datetime="2020-04-24T22:21:00+02:00" itemprop="datePublished">24/04/2020</time>
</span> |
<span class="more-element more-element-category">
<i class="fa fa-folder-o" aria-hidden="true"></i> <a itemprop="about" href="/news/10-logiciels-libres/">Logiciels Libres</a>
</span>
 | <span class="more-element more-element-comments"><i class="fa fa-comments-o" aria-hidden="true"></i> <a href="#comments-list" title="Lien vers les commentaires">14  Commentaires</a></span>
 | <span title="1729 vues" class="more-element more-element-view"><i class="fa fa-eye" aria-hidden="true"></i> 1729</span>
</div>
<meta itemprop="url" content="/news/10-logiciels-libres/464-mon-avis-sur-les-snaps-de-canonical/">
<meta itemprop="description" content="Bonjour à tous,&lt;br/&gt;
&lt;br/&gt;
je n'écris pas souvent. Cependant, j'aimerais de manière écrite faire un récap de ma pensée sur les SNAP de Canonical.&lt;br/&gt;
&lt;br/&gt;
je vous préviens, ça va être long, mais je vous fais une analyse détaillée de ma pensée..." />
<meta itemprop="discussionUrl" content="/news/10-logiciels-libres/464-mon-avis-sur-les-snaps-de-canonical/#comments-list">
<meta itemprop="interactionCount" content="14 UserComments">
<div class="content">
<img itemprop="thumbnailUrl" src="/news/news.png" alt="Mon avis sur les SNAPS de Canonical" title="Mon avis sur les SNAPS de Canonical" class="thumbnail-item" />
<div itemprop="text">Bonjour à tous,<br />
<br />
je n'écris pas souvent. Cependant, j'aimerais de manière écrite faire un récap de ma pensée sur les SNAP de Canonical.<br />
<br />
je vous préviens, <strong>ça va être long</strong>, mais je vous fais une analyse détaillée de ma pensée !<br />
<br />
Je n'aborderai pas de comparatifs poussés avec Flatpak et Appimage, mais uniquement les SNAPS par rapport aux Deb (ici je parlerai d'Ubuntu, seule distribution où j'ai pu tester les SNAPS de manière autonome).<br />
<br />
Je fais juste un petit rappel sur les formats dits universels qui existent actuellement :<br />
<br />
<strong>Snap</strong> : l&#8217;application est en mode bac à sable (isolée du kernel) via AppArmor. Utilisable en environnement serveur et internet des objets. Le logiciel ne peut utiliser que les bibliothèques incluses dans son package.<br />
<br />
<strong>Flatpak</strong> : l&#8217;application est en mode bac à sable. Il utilise des éléments d&#8217;une session graphique pour fonctionner (donc pas sur un serveur). Les Flatpaks peuvent tous deux utiliser des bibliothèques incluses dans le package et des bibliothèques partagées provenant d&#8217;un autre Flatpak.<br />
<br />
<strong>Appimage</strong> : Les programmes AppImage ne sont pas en mode bac à sable et ne nécessitent pas de droits root pour s'exécuter. Appimage offre donc moins de sécurité. Le logiciel ne peut utiliser que les bibliothèques incluses dans son package.<br />
<br />
Le site <a href="https://snapcraft.io/store">https://snapcraft.io/store</a> centralise les SNAPS.<br />
<br />
<br />
<strong>D'abord, côté poids.</strong><br />
<br />
Je vais simplifier l'exemple :<br />
<br />
Avec les DEB, on a par exemple Firefox = 50Mo, Thunderbird = 50Mo, les bibliothèques communes aux deux (GTK, etc etc) 100Mo.<br />
Quand Firefox dispose d'un fix de sécurité, une nouvelle version de Firefox est publiée, on télécharge 50Mo.<br />
Avec les SNAPS, vous l'avez compris, dans le SNAP, on a l'application et les libs. Donc Firefox = 150Mo, Thunderbird 150Mo.<br />
Quand Firefox dispose d'un fix de sécurité, une nouvelle version de Firefox est publiée, on télécharge 150Mo.  (3 fois plus).<br />
<br />
Pour les petites connexions ADSL, ça peut être plus long, évidemment.<br />
<br />
<br />
<strong>Sur la place sur le disque : </strong><br />
<br />
Je reprends mon exemple Firefox, Thunderbird, Libs du dessus.<br />
DEB = 50+50+100 = 200<br />
SNAP = 150+150 = 300<br />
<br />
Ça prend plus de place.<br />
Après, les HDD de 1To c'est monnaie courante, et les SSD 500Go ne sont plus très cher (ça dépend vos ressources mais SSD Crucial BX500 480 Go = 84&#8364;, compte 56&#8364; pour le 240Go). Ça peut juste être problématique sur des mini PC avec de la mémoire eMMC).<br />
<br />
Avec 45 applications installées (voir vidéo en dessous) on a pour les SNAPS 9.5Go pris sur le disque. Avec les DEB, 8.3 Go. Cela ne représente que (ou cela représente quand même !!!!) 1.2Go de différence.<br />
<br />
<br />
<strong>Concernant la mémoire : </strong><br />
<br />
Toujours sur le comparatif avec les 45 SNAPS / 45 DEBS :<br />
Sur la machine avec les 45 SNAPS on a 880Mo de RAM.<br />
Sur la machine avec les 45 DEBS on a 720Mo de RAM.<br />
<br />
Il semble donc que les SNAPS soient impactant sur la RAM (pas de beaucoup). Cela peut se traduire notamment par le démon <strong>snapd</strong> démarré en plus.<br />
<br />
Concluez ce que vous voulez, je n'ai pas trop d'avis sur les 150Mo. Surtout qu'après avoir lancé sur les 2 machines les mêmes applications, puis refermées, on consomme plus des 2 côtés, mais toujours avec cet écart de 150Mo. (avec des PC actuellement de 4Go au moins, ça va)<br />
<br />
<br />
<strong>Concernant les /dev/loop : </strong><br />
<br />
Chaque SNAP installé vient «pourrir» la commande df d'un média /dev/loop qui pointe sur /snap/nomdusnap/numero.<br />
C'est déroutant, car cela pollue l'affichage d'une commande système traditionnelle.<br />
Après, cela semble «logique» puisque les SNAPS sont dans un système de fichiers en lecture seule (comme quand vous montez avec «mount» une ISO dans un dossier de votre arborescence locale.<br />
<br />
<br />
<strong>Concernant le temps de démarrage : </strong><br />
<br />
Par rapport aux DEB, tous les logiciels sont 1 à 5 secondes plus lents à lancer (effet Sandbox, effet conteneur, effet AppArmor?). A l'exception d'Audacity sur les logiciels testés.<br />
Ce n'est pas un drame mais la lenteur peut paraître déroutante quand on a l'habitude du clic et paf c'est lancé.<br />
<br />
<br />
<strong>Concernant les thèmes : </strong><br />
<br />
Même si on entend que le thème système est mieux géré avec Flatpak, sur Ubuntu et SNAP, c'est assez différent :<br />
J'ai activé le thème Dark sur la Ubuntu (vous verrez dans la vidéo), et lancé divers logiciels. les résultats sont différents :<br />
- Firefox, en GTK3 =&gt; Prend le thème de Ubuntu en SNAP / Prend le thème Ubuntu en DEB<br />
- VLC, en Qt5 =&gt; Ne prend pas le thème de Ubuntu en SNAP / Ne prend pas le thème de Ubuntu en DEB<br />
- SweetHome3D, en Java =&gt; Prend le thème traditionnel Java (bleuté dégradé) en SNAP / Essaie d'avoir le thème Ubuntu en DEB mais souffre de bugs d'affichages (inutilisable)<br />
- KdenLive, en Qt5 =&gt; Prend le thème natif Breeze de KDE en SNAP / Prend le thème moche Qt d'Ubuntu en DEB (Breeze semble pas installé par dépendances).<br />
- Filezilla, en wxwidgets =&gt; Prend le thème de Ubuntu en SNAP / Prend le thème Ubuntu en DEB<br />
- LibreOffice, en GTK3 =&gt; Prend le thème de Ubuntu en SNAP / Prend le thème Ubuntu en DEB<br />
<br />
On constate donc qu'avec les SNAPS, les apps GTK3 prennent le thème du système. Avec un thème inexistant (Breeze, Java), les applications ont un thème et une apparence fonctionnelle. Avantage au SNAP pour ce coup. Certes, ce n'est pas cohérent, mais c'est fonctionnel dans tous les cas !<br />
Là où KdenLive est un peu dégueulasse en DEB si on ne va pas installer le thème breeze en plus à la main, et où SweetHome3D est inutilisable...<br />
<br />
<br />
<strong>Côté traduction : </strong><br />
<br />
Et bien je reprends les mêmes applications que le test du thème, mais je vais me focaliser sur les traductions !<br />
- Firefox =&gt; Français en SNAP / Français en DEB<br />
- VLC=&gt; Français en SNAP / Français en DEB<br />
- SweetHome3D =&gt; Français en SNAP / Français en DEB<br />
- KdenLive =&gt; Français en SNAP / Français en DEB<br />
- Filezilla =&gt; Français en SNAP / Français en DEB<br />
- LibreOffice =&gt; Français en SNAP / Français en DEB<br />
<br />
J'ai testé en plus (avant le changement de thème) du précédent paragraphe :<br />
- Clémentine : Français en SNAP / Français en DEB<br />
- Audacity : Anglais en SNAP / Français en DEB<br />
<br />
Sur les applications testées, il y a juste un loupé sur Audacity niveau traduction, du coup, le SNAP détecte bien la langue du système de manière globale.<br />
<br />
<br />
<strong>Concernant la "sandbox" et les permissions :</strong><br />
<br />
J'ai testé sur Chromium (à 18:25 de la vidéo) le réglage des permissions sur un SNAP.<br />
J'ai effectué les choses en graphique (sans doute possible en ligne de commande, mais je ne suis pas un expert SNAP).<br />
Pour Chromium, il est possible de régler les permissions d'accès au micro, au son, à la camera, à l'impression, au dossier utilisateur et bien plus (liste affichée à 19:08).<br />
J'ai testé, ça fonctionne bien.<br />
Personnellement, je n'en vois pas l'intérêt sur un PC qu'on utilise tous les jours mais la fonction est là et semble répondre aux attentes. Je pense que l'utilité est plus là pour l'IoT ou pourquoi pas les serveurs. (Un peu similaire aux booléens SELinux ?)<br />
<br />
<br />
<strong>Et enfin Snap sur serveur</strong><br />
<br />
Comparé aux Flatpaks, SNAP permet d'installer des applis non graphiques. J'ai testé avec postgresql10 sur Ubuntu 20.04 LTS, ça marche.<br />
Pour le coup, comme indiqué dans la vidéo, je ne vois pas l'intérêt du SNAP ici pour les permissions, mais pour autre chose : La possibilité d'installer une version spécifique d'un composant serveur (base de données, etc etc). C'est une manière de reproduire ce que Fedora propose (Et RHEL8 / CentOS8) avec les modules de dnf. Installer la version de son choix d'un moteur de base de données.<br />
<br />
<strong>Avantage du snap sur une Ubuntu graphique alors ?</strong><br />
<br />
Je pense que le SNAP peut être intéressant dans certains cas.<br />
Ubuntu LTS, comme son nom l'indique, est Long Term Support. Donc prochaine LTS 2022.<br />
Si on fait une comparaison avec Ubuntu 18.04 qui date d'il y a 2 ans :<br />
- Ubuntu 18.04 à la sortie : LibreOffice 6.0.3<br />
- Ubuntu 18.04.4 aujourd'hui : LibreOffice 6.0.7<br />
- Ubuntu 20.04 aujourd&#8217;hui : LibreOffice 6.4.2<br />
Cependant :<br />
- Ubuntu 18.04 à la sortie : Firefox 59<br />
- Ubuntu 18.04.4 aujourd'hui : Firefox 75<br />
- Ubuntu 20.04 aujourd&#8217;hui : Firefox 75<br />
<br />
On conclus que  :<br />
- Sur une LTS Ubuntu, les logiciels stratégiques exposés (Firefox, OpenSSH, Kernel) disposent soit de nouvelles versions, soit de patchs de sécurité rétroportés.<br />
- Sur une LTS Ubuntu, les logiciels d'utilisation ne sont pas mis à jour et ne disposent donc pas de nouvelles fonctionnalités (LibreOffice reste en branche 6.0)<br />
<br />
Le SNAP pour le coup, va permettre de garder une base système "deb" stable, et de disposer d'applications d'utilisation plus récentes pour bénéficier de nouvelles fonctionalités.<br />
Ça va éviter d'ajouter un "PPA" (dépôt additionnel) qui risque de poser des problèmes lors de mises à jour/mises à niveau, car les PPA contiennent des DEB, et utilisent les dépendances du système. Là en cas de mise à jour, le SNAP se cassera tout seul au pire, et n'aura pas d'impact sur la stabilité du système.<br />
<br />
<br />
<strong>Si je reviens vite fait sur une éventuelle Ubuntu Server</strong> (y a des gens qui utilisent Ubuntu Server ?) le problème de logiciel récent n'est pas intéressant car :<br />
- On ne va s'intéresser qu'aux fix de sécurité<br />
- On va préférer garder une même version d'un moteur de base de données, d'un langage de programmation, afin de ne pas requalifier l'applicatif à cause d'une mise à jour.<br />
<br />
<strong>Et en conclusion ?</strong><br />
En conclusion, les SNAPS ne sont pas une mauvaise chose.<br />
<br />
Ce que je reproche, c'est <span style="text-decoration: underline;">l'imposition</span> du format aux traditionnels DEB. (Ou pire Chromium Browser qui est un deb vide virtuel qui force l'install du snap)<br />
Il aurait été préférable de garder le DEB et en cas d'appli non dispo ou d'une volonté de l'utilisateur à avoir une version plus récente d'un logiciel, d'aller faire la démarche manuellement.<br />
<br />
Sur le serveur, je n'utilise que CentOS pour le travail, le SNAP permet en gros (à voir sur l'utilisation) de reproduire les modules de RHEL8/CentOS8 et les SCL de RHEL7/RHEL6. Cela peut être utile, à voir.<br />
<br />
Concernant la mémoire et le disque, mon PC dispose de 16Go de RAM et 512Go SSD, et j'ai la fibre, donc au pire je m'en fiche mais.... Ceux qui ont de l'ADSL c'est plus long. Un PC standard aujourd'hui, c'est 4Go mini, 256SSD ou un HDD de 500Go donc ça passe. Sur des configs plus basses, les gens n'iront pas vers Ubuntu mais vers des Debian Xfce, qui seront plus légères et qui n'ont pas de SNAP (A voir avec Xubuntu).<br />
<br />
Concernant pour terminer le lancement des SNAPS, c'est un peu plus long que les DEB (de quelques secondes), sauf pour Audacity. mais comme disait un certain Sipo sur Twitter, ça ne fait pas refroidir le café ! Mais personnellement, j'aime bien que le système soit réactif, je clic, ça s'ouvre.<br />
<br />
Globalement, ça marche et bien.<br />
<br />
<br />
<strong>Et vous, que pensez-vous des SNAPS ?</strong><br />
<br />
<br />
La vidéo du comparatif DEB/SNAPS (aller à 13 minutes) :<br />
<br />
<p style="text-align: center;">N'hésitez pas à sélectionner la qualité HD en 720p ou 1080p !<br />
<a href="https://www.youtube.com/watch?v=_xxnpvYgONQ" target="_blank"><img src="https://i.ytimg.com/vi/_xxnpvYgONQ/maxresdefault.jpg" /></a>
</p></div>
</div>
<aside>
<div id="more-element-sharing-container" class="more-element more-element-sharing">
<div class="sharing-button">
<a href="#" aria-label="Menu réseaux sociaux" onclick="open_submenu('more-element-sharing-container');return false;"><i class="fa fa-share-alt" aria-hidden="true" title="Menu réseaux sociaux"></i></a>
</div>
<ul class="sharing-elements-list">
<li class="sharing-element sharing-element-facebook">
<a href="http://www.facebook.com/share.php?u=https%3A%2F%2Fwww.linuxtricks.fr%2Fnews%2F10-logiciels-libres%2F464-mon-avis-sur-les-snaps-de-canonical%2F" title="Partager sur Facebook" class="facebook"  onclick="javascript:window.open(this.href, '', 'menubar=no,toolbar=no,resizable=yes,scrollbars=yes,height=500,width=700');return false;" ><i class="fab fa-fw fa-facebook-f" aria-hidden="true"></i>
<span class="sr-only">Partager sur Facebook</span></a>
</li>
<li class="sharing-element sharing-element-twitter">
<a href="https://twitter.com/share?url=https%3A%2F%2Fwww.linuxtricks.fr%2Fnews%2F10-logiciels-libres%2F464-mon-avis-sur-les-snaps-de-canonical%2F&text=Mon%20avis%20sur%20les%20SNAPS%20de%20Canonical" title="Partager sur Twitter" class="twitter"  onclick="javascript:window.open(this.href, '', 'menubar=no,toolbar=no,resizable=yes,scrollbars=yes,height=500,width=700');return false;" ><i class="fab fa-fw fa-twitter" aria-hidden="true"></i>
<span class="sr-only">Partager sur Twitter</span></a>
</li>
<li class="sharing-element sharing-element-mail">
<a href="mailto:?subject=Mon%20avis%20sur%20les%20SNAPS%20de%20Canonical&body=https%3A%2F%2Fwww.linuxtricks.fr%2Fnews%2F10-logiciels-libres%2F464-mon-avis-sur-les-snaps-de-canonical%2F" title="Partager par Email" class="mail" ><i class="fa fa-fw fa-envelope" aria-hidden="true"></i><span class="sr-only">Partager par email</span>
<span class="sr-only">Partager par Email</span></a>
</li>
<li class="sharing-element sharing-element-print">
<a href="#" title="Version imprimable" class="print"  onclick="javascript:window.print()" ><i class="fa fa-fw fa-print" aria-hidden="true"></i><span class="sr-only">Imprimer</span>
<span class="sr-only">Version imprimable</span></a>
</li>
</ul>
</div>

<div id="news-tags-container">
<span class="news-tags-title"><i class="fa fa-tags" aria-hidden="true"></i> Mots clés</span> :
<a itemprop="keywords" rel="tag" href="/news/tag/ubuntu/" class="news-tags-item">Ubuntu</a>, 
<a itemprop="keywords" rel="tag" href="/news/tag/snap/" class="news-tags-item">snap</a>
</div>
<div id="news-suggested-container">
<span class="news-suggested-title"><i class="fa fa-lightbulb-o"></i> Suggestions :</span>
<ul>
<li><a href="/news/10-logiciels-libres/373-upgrade-de-ubuntu-17-04-a-17-10-avec-ppa-et-logiciels-divers/" class="news-suggested-item">Upgrade de Ubuntu 17.04 à 17.10 avec PPA et logiciels divers</a></li>
<li><a href="/news/10-logiciels-libres/398-il-y-a-des-choses-tres-etranges-dans-ubuntu-18-04/" class="news-suggested-item">Il y a des choses très étranges dans Ubuntu 18.04 ...</a></li>
<li><a href="/news/10-logiciels-libres/142-ubuntuqt-une-version-non-officielle-de-ubuntu-avec-lxqt/" class="news-suggested-item">UbuntuQT : Une version non officielle de Ubuntu avec LXQT</a></li>
<li><a href="/news/10-logiciels-libres/457-gentoo-c-est-bien-mais-je-reviens-sous-calculate-linux-billet-long-de-leexperience-gentoo/" class="news-suggested-item">Gentoo c'est bien, mais je reviens sous Calculate Linux (Billet long de l’expérience Gentoo)</a></li>
<li><a href="/news/10-logiciels-libres/291-ubuntu-4-10-retour-dans-le-passe/" class="news-suggested-item">Ubuntu 4.10 : Retour dans le passé</a></li>
<li><a href="/news/10-logiciels-libres/259-avant-premiere-theme-calculate-linux-17/" class="news-suggested-item">Avant première : Thème Calculate Linux 17</a></li>
<li><a href="/news/10-logiciels-libres/194-firefox-que-donne-test-pilot-pour-tester-de-nouvelles-futures-fonctionnalites/" class="news-suggested-item">Firefox : Que donne «Test Pilot» pour tester de nouvelles (futures) fonctionnalités ?</a></li>
<li><a href="/news/11-le-sac-de-chips/374-operations-inutiles-donc-indispensables-saturer-son-systeme-cpu-ram-disque-reseau/" class="news-suggested-item">Opérations inutiles donc indispensables : Saturer son système (CPU, RAM, Disque, Réseau)</a></li>
<li><a href="/news/10-logiciels-libres/330-coup-de-tonnerre-ubuntu-arrete-le-developpement-de-unity/" class="news-suggested-item">Coup de tonnerre ! Ubuntu arrête le développement de Unity !</a></li>
<li><a href="/news/10-logiciels-libres/201-reponse-a-la-video-du-pingouin-francais-les-problemes-sous-linux/" class="news-suggested-item">Réponse à la vidéo du pingouin français : Les problèmes sous Linux</a></li>
</ul>
</div>
<hr class="news-separator">
<div class="navigation-link">
<span class="navigation-link-previous">
<a href="/news/10-logiciels-libres/463-deepin-20-beta-est-la/"><i class="fa fa-arrow-circle-left" aria-hidden="true"></i>Deepin 20 Beta est là</a>
</span>
<div class="spacer"></div>
</div>

<section id="comments-list">
<header>
<h2>Commentaires</h2>
</header>
<div class="content">
<div id="comment-form">
 
  
<form id="comments" action="/news/10-logiciels-libres/464-mon-avis-sur-les-snaps-de-canonical/#comments-list" method="post" onsubmit="return HTMLForms.get('comments').validate();" class="fieldset-content">
<p class="required-fields-text">Les champs marqués * sont obligatoires !</p>
<fieldset id="comments_add_comment">
<legend>Ajouter un commentaire</legend>
<div class="fieldset-inset">
<div id="comments_name_field" class="form-element">
<label for="comments_name">
Nom
</label>
<div id="onblurContainerResponsecomments_name" class="form-field form-field-text picture-status-constraint">
<input type="text" size="30" maxlength="25" name="comments_name" id="comments_name" value="Visiteur"
class=""     />
<span class="text-status-constraint" style="display: none;" id="onblurMessageResponsecomments_name"></span>
</div>
</div>
<div id="comments_message_field" class="form-element-textarea editor-bbcode">
<label for="comments_message">
Message
</label>
<div id="loading-preview-comments_message" class="loading-preview-container" style="display: none;">
<div class="loading-preview">
<i class="fa fa-spinner fa-2x fa-spin"></i>
</div>
</div>
<div id="xmlhttprequest-previewcomments_message" class="xmlhttprequest-preview" style="display: none;"></div>
<div id="bbcode-expanded" class="bbcode expand bkgd-color-op10 bdr-color-op20">
<div class="bbcode-containers">
<ul id="bbcode-container-smileys" class="bbcode-container dlt-color-op20-after">
<li class="bbcode-elements bkgd-color-op20-hover">
<a href="" onclick="bb_display_block('1', 'comments_message');return false;" onmouseover="bb_hide_block('1', 'comments_message', 1);" onmouseout="bb_hide_block('1', 'comments_message', 0);" class="bbcode-hover" aria-label="Smileys">
<i class="fa fa-fw bbcode-icon-smileys" aria-hidden="true" title="Smileys"></i>
</a>
<div id="bb-block1comments_message" class="bbcode-block-container arrow-submenu-color" style="display: none;">
<ul class="bbcode-block block-submenu-color bbcode-block-smileys" onmouseover="bb_hide_block('1', 'comments_message', 1);" onmouseout="bb_hide_block('1', 'comments_message', 0);">
<li>
<a href="" onclick="insertbbcode(':hurt3:', 'smile', 'comments_message');bb_hide_block('1', 'comments_message', 0);return false;" class="bbcode-hover" aria-label=":hurt3:">
<img src="/images/smileys/91.gif" alt=":hurt3:" aria-hidden="true" title=":hurt3:" class="smiley" />
</a>
</li>
<li>
<a href="" onclick="insertbbcode(':hello:', 'smile', 'comments_message');bb_hide_block('1', 'comments_message', 0);return false;" class="bbcode-hover" aria-label=":hello:">
<img src="/images/smileys/48.gif" alt=":hello:" aria-hidden="true" title=":hello:" class="smiley" />
</a>
</li>
<li>
<a href="" onclick="insertbbcode(':boulet:', 'smile', 'comments_message');bb_hide_block('1', 'comments_message', 0);return false;" class="bbcode-hover" aria-label=":boulet:">
<img src="/images/smileys/158.gif" alt=":boulet:" aria-hidden="true" title=":boulet:" class="smiley" />
</a>
</li>
<li>
<a href="" onclick="insertbbcode(':mrgreene:', 'smile', 'comments_message');bb_hide_block('1', 'comments_message', 0);return false;" class="bbcode-hover" aria-label=":mrgreene:">
<img src="/images/smileys/14.gif" alt=":mrgreene:" aria-hidden="true" title=":mrgreene:" class="smiley" />
</a>
</li>
<li>
<a href="" onclick="insertbbcode(':siffle:', 'smile', 'comments_message');bb_hide_block('1', 'comments_message', 0);return false;" class="bbcode-hover" aria-label=":siffle:">
<img src="/images/smileys/44.gif" alt=":siffle:" aria-hidden="true" title=":siffle:" class="smiley" />
</a>
</li>
<li>
<a href="" onclick="insertbbcode(':magic:', 'smile', 'comments_message');bb_hide_block('1', 'comments_message', 0);return false;" class="bbcode-hover" aria-label=":magic:">
<img src="/images/smileys/64.gif" alt=":magic:" aria-hidden="true" title=":magic:" class="smiley" />
</a>
</li>
<li>
<a href="" onclick="insertbbcode(':contrac:', 'smile', 'comments_message');bb_hide_block('1', 'comments_message', 0);return false;" class="bbcode-hover" aria-label=":contrac:">
<img src="/images/smileys/80.gif" alt=":contrac:" aria-hidden="true" title=":contrac:" class="smiley" />
</a>
</li>
<li>
<a href="" onclick="insertbbcode(':happy1:', 'smile', 'comments_message');bb_hide_block('1', 'comments_message', 0);return false;" class="bbcode-hover" aria-label=":happy1:">
<img src="/images/smileys/75.gif" alt=":happy1:" aria-hidden="true" title=":happy1:" class="smiley" />
</a>
</li>
<li>
<a href="" onclick="insertbbcode(':gene:', 'smile', 'comments_message');bb_hide_block('1', 'comments_message', 0);return false;" class="bbcode-hover" aria-label=":gene:">
<img src="/images/smileys/12.gif" alt=":gene:" aria-hidden="true" title=":gene:" class="smiley" />
</a>
</li>
<li>
<a href="" onclick="insertbbcode(':silence:', 'smile', 'comments_message');bb_hide_block('1', 'comments_message', 0);return false;" class="bbcode-hover" aria-label=":silence:">
<img src="/images/smileys/121.gif" alt=":silence:" aria-hidden="true" title=":silence:" class="smiley" />
</a>
</li>
<li>
<a href="" onclick="insertbbcode(':?:', 'smile', 'comments_message');bb_hide_block('1', 'comments_message', 0);return false;" class="bbcode-hover" aria-label=":?:">
<img src="/images/smileys/142.gif" alt=":?:" aria-hidden="true" title=":?:" class="smiley" />
</a>
</li>
<li>
<a href="" onclick="insertbbcode(':langue2:', 'smile', 'comments_message');bb_hide_block('1', 'comments_message', 0);return false;" class="bbcode-hover" aria-label=":langue2:">
<img src="/images/smileys/46.gif" alt=":langue2:" aria-hidden="true" title=":langue2:" class="smiley" />
</a>
</li>
<li>
<a href="" onclick="insertbbcode(':ange:', 'smile', 'comments_message');bb_hide_block('1', 'comments_message', 0);return false;" class="bbcode-hover" aria-label=":ange:">
<img src="/images/smileys/36.gif" alt=":ange:" aria-hidden="true" title=":ange:" class="smiley" />
</a>
</li>
<li>
<a href="" onclick="insertbbcode(':désolé1:', 'smile', 'comments_message');bb_hide_block('1', 'comments_message', 0);return false;" class="bbcode-hover" aria-label=":désolé1:">
<img src="/images/smileys/106.gif" alt=":désolé1:" aria-hidden="true" title=":désolé1:" class="smiley" />
</a>
</li>
<li>
<a href="" onclick="insertbbcode(':intello:', 'smile', 'comments_message');bb_hide_block('1', 'comments_message', 0);return false;" class="bbcode-hover" aria-label=":intello:">
<img src="/images/smileys/42.gif" alt=":intello:" aria-hidden="true" title=":intello:" class="smiley" />
</a>
</li>
<li>
<a href="" onclick="insertbbcode(':winner:', 'smile', 'comments_message');bb_hide_block('1', 'comments_message', 0);return false;" class="bbcode-hover" aria-label=":winner:">
<img src="/images/smileys/136.gif" alt=":winner:" aria-hidden="true" title=":winner:" class="smiley" />
</a>
</li>
<li>
<a href="" onclick="insertbbcode(':hehe:', 'smile', 'comments_message');bb_hide_block('1', 'comments_message', 0);return false;" class="bbcode-hover" aria-label=":hehe:">
<img src="/images/smileys/4.gif" alt=":hehe:" aria-hidden="true" title=":hehe:" class="smiley" />
</a>
</li>
<li>
<a href="" onclick="insertbbcode(':)', 'smile', 'comments_message');bb_hide_block('1', 'comments_message', 0);return false;" class="bbcode-hover" aria-label=":)">
<img src="/images/smileys/1.gif" alt=":)" aria-hidden="true" title=":)" class="smiley" />
</a>
</li>
<li>
<a href="" onclick="insertbbcode(':D', 'smile', 'comments_message');bb_hide_block('1', 'comments_message', 0);return false;" class="bbcode-hover" aria-label=":D">
<img src="/images/smileys/2.gif" alt=":D" aria-hidden="true" title=":D" class="smiley" />
</a>
</li>
<li>
<a href="" onclick="insertbbcode(';)', 'smile', 'comments_message');bb_hide_block('1', 'comments_message', 0);return false;" class="bbcode-hover" aria-label=";)">
<img src="/images/smileys/6.gif" alt=";)" aria-hidden="true" title=";)" class="smiley" />
</a>
</li>
<li>
<a href="" onclick="insertbbcode(':jemerend:', 'smile', 'comments_message');bb_hide_block('1', 'comments_message', 0);return false;" class="bbcode-hover" aria-label=":jemerend:">
<img src="/images/smileys/155.gif" alt=":jemerend:" aria-hidden="true" title=":jemerend:" class="smiley" />
</a>
</li>
<li>
<a href="" onclick="insertbbcode(':diable:', 'smile', 'comments_message');bb_hide_block('1', 'comments_message', 0);return false;" class="bbcode-hover" aria-label=":diable:">
<img src="/images/smileys/37.gif" alt=":diable:" aria-hidden="true" title=":diable:" class="smiley" />
</a>
</li>
<li>
<a href="" onclick="insertbbcode(':baille:', 'smile', 'comments_message');bb_hide_block('1', 'comments_message', 0);return false;" class="bbcode-hover" aria-label=":baille:">
<img src="/images/smileys/132.gif" alt=":baille:" aria-hidden="true" title=":baille:" class="smiley" />
</a>
</li>
<li>
<a href="" onclick="insertbbcode(':langue1:', 'smile', 'comments_message');bb_hide_block('1', 'comments_message', 0);return false;" class="bbcode-hover" aria-label=":langue1:">
<img src="/images/smileys/153.gif" alt=":langue1:" aria-hidden="true" title=":langue1:" class="smiley" />
</a>
</li>
<li>
<a href="" onclick="insertbbcode(':fatigué:', 'smile', 'comments_message');bb_hide_block('1', 'comments_message', 0);return false;" class="bbcode-hover" aria-label=":fatigué:">
<img src="/images/smileys/100.gif" alt=":fatigué:" aria-hidden="true" title=":fatigué:" class="smiley" />
</a>
</li>
<li>
<a href="" onclick="insertbbcode(':P', 'smile', 'comments_message');bb_hide_block('1', 'comments_message', 0);return false;" class="bbcode-hover" aria-label=":P">
<img src="/images/smileys/10.gif" alt=":P" aria-hidden="true" title=":P" class="smiley" />
</a>
</li>
<li>
<a href="" onclick="insertbbcode(':pascontent2:', 'smile', 'comments_message');bb_hide_block('1', 'comments_message', 0);return false;" class="bbcode-hover" aria-label=":pascontent2:">
<img src="/images/smileys/82.gif" alt=":pascontent2:" aria-hidden="true" title=":pascontent2:" class="smiley" />
</a>
</li>
<li>
<a href="" onclick="insertbbcode(':cbon:', 'smile', 'comments_message');bb_hide_block('1', 'comments_message', 0);return false;" class="bbcode-hover" aria-label=":cbon:">
<img src="/images/smileys/32.gif" alt=":cbon:" aria-hidden="true" title=":cbon:" class="smiley" />
</a>
</li>
<li>
<a href="" onclick="insertbbcode(':pascontent1:', 'smile', 'comments_message');bb_hide_block('1', 'comments_message', 0);return false;" class="bbcode-hover" aria-label=":pascontent1:">
<img src="/images/smileys/83.gif" alt=":pascontent1:" aria-hidden="true" title=":pascontent1:" class="smiley" />
</a>
</li>
<li>
<a href="" onclick="insertbbcode(':modo:', 'smile', 'comments_message');bb_hide_block('1', 'comments_message', 0);return false;" class="bbcode-hover" aria-label=":modo:">
<img src="/images/smileys/108.gif" alt=":modo:" aria-hidden="true" title=":modo:" class="smiley" />
</a>
</li>
<li>
<a href="" onclick="insertbbcode(':winner3:', 'smile', 'comments_message');bb_hide_block('1', 'comments_message', 0);return false;" class="bbcode-hover" aria-label=":winner3:">
<img src="/images/smileys/129.gif" alt=":winner3:" aria-hidden="true" title=":winner3:" class="smiley" />
</a>
</li>
<li>
<a href="" onclick="insertbbcode(':mdr1:', 'smile', 'comments_message');bb_hide_block('1', 'comments_message', 0);return false;" class="bbcode-hover" aria-label=":mdr1:">
<img src="/images/smileys/154.gif" alt=":mdr1:" aria-hidden="true" title=":mdr1:" class="smiley" />
</a>
</li>
<li>
<a href="" onclick="insertbbcode(':pendu:', 'smile', 'comments_message');bb_hide_block('1', 'comments_message', 0);return false;" class="bbcode-hover" aria-label=":pendu:">
<img src="/images/smileys/122.gif" alt=":pendu:" aria-hidden="true" title=":pendu:" class="smiley" />
</a>
</li>
<li>
<a href="" onclick="insertbbcode(':triste1:', 'smile', 'comments_message');bb_hide_block('1', 'comments_message', 0);return false;" class="bbcode-hover" aria-label=":triste1:">
<img src="/images/smileys/144.gif" alt=":triste1:" aria-hidden="true" title=":triste1:" class="smiley" />
</a>
</li>
<li>
<a href="" onclick="insertbbcode(':pleur2:', 'smile', 'comments_message');bb_hide_block('1', 'comments_message', 0);return false;" class="bbcode-hover" aria-label=":pleur2:">
<img src="/images/smileys/103.gif" alt=":pleur2:" aria-hidden="true" title=":pleur2:" class="smiley" />
</a>
</li>
<li>
<a href="" onclick="insertbbcode(':pasdrole:', 'smile', 'comments_message');bb_hide_block('1', 'comments_message', 0);return false;" class="bbcode-hover" aria-label=":pasdrole:">
<img src="/images/smileys/124.gif" alt=":pasdrole:" aria-hidden="true" title=":pasdrole:" class="smiley" />
</a>
</li>
<li>
<a href="" onclick="insertbbcode(':amoureux:', 'smile', 'comments_message');bb_hide_block('1', 'comments_message', 0);return false;" class="bbcode-hover" aria-label=":amoureux:">
<img src="/images/smileys/33.gif" alt=":amoureux:" aria-hidden="true" title=":amoureux:" class="smiley" />
</a>
</li>
<li>
<a href="" onclick="insertbbcode(';-)', 'smile', 'comments_message');bb_hide_block('1', 'comments_message', 0);return false;" class="bbcode-hover" aria-label=";-)">
<img src="/images/smileys/38.gif" alt=";-)" aria-hidden="true" title=";-)" class="smiley" />
</a>
</li>
<li>
<a href="" onclick="insertbbcode(':mdr2:', 'smile', 'comments_message');bb_hide_block('1', 'comments_message', 0);return false;" class="bbcode-hover" aria-label=":mdr2:">
<img src="/images/smileys/152.gif" alt=":mdr2:" aria-hidden="true" title=":mdr2:" class="smiley" />
</a>
</li>
<li>
<a href="" onclick="insertbbcode(':fouet1:', 'smile', 'comments_message');bb_hide_block('1', 'comments_message', 0);return false;" class="bbcode-hover" aria-label=":fouet1:">
<img src="/images/smileys/130.gif" alt=":fouet1:" aria-hidden="true" title=":fouet1:" class="smiley" />
</a>
</li>
<li>
<a href="" onclick="insertbbcode(':malin:', 'smile', 'comments_message');bb_hide_block('1', 'comments_message', 0);return false;" class="bbcode-hover" aria-label=":malin:">
<img src="/images/smileys/141.gif" alt=":malin:" aria-hidden="true" title=":malin:" class="smiley" />
</a>
</li>
<li>
<a href="" onclick="insertbbcode(':mafia:', 'smile', 'comments_message');bb_hide_block('1', 'comments_message', 0);return false;" class="bbcode-hover" aria-label=":mafia:">
<img src="/images/smileys/150.gif" alt=":mafia:" aria-hidden="true" title=":mafia:" class="smiley" />
</a>
</li>
<li>
<a href="" onclick="insertbbcode('::d', 'smile', 'comments_message');bb_hide_block('1', 'comments_message', 0);return false;" class="bbcode-hover" aria-label="::d">
<img src="/images/smileys/3.gif" alt="::d" aria-hidden="true" title="::d" class="smiley" />
</a>
</li>
<li>
<a href="" onclick="insertbbcode(':nono:', 'smile', 'comments_message');bb_hide_block('1', 'comments_message', 0);return false;" class="bbcode-hover" aria-label=":nono:">
<img src="/images/smileys/84.gif" alt=":nono:" aria-hidden="true" title=":nono:" class="smiley" />
</a>
</li>
<li>
<a href="" onclick="insertbbcode(':atomique:', 'smile', 'comments_message');bb_hide_block('1', 'comments_message', 0);return false;" class="bbcode-hover" aria-label=":atomique:">
<img src="/images/smileys/138.gif" alt=":atomique:" aria-hidden="true" title=":atomique:" class="smiley" />
</a>
</li>
<li>
<a href="" onclick="insertbbcode(':roi1:', 'smile', 'comments_message');bb_hide_block('1', 'comments_message', 0);return false;" class="bbcode-hover" aria-label=":roi1:">
<img src="/images/smileys/105.gif" alt=":roi1:" aria-hidden="true" title=":roi1:" class="smiley" />
</a>
</li>
<li>
<a href="" onclick="insertbbcode(':super:', 'smile', 'comments_message');bb_hide_block('1', 'comments_message', 0);return false;" class="bbcode-hover" aria-label=":super:">
<img src="/images/smileys/35.gif" alt=":super:" aria-hidden="true" title=":super:" class="smiley" />
</a>
</li>
<li>
<a href="" onclick="insertbbcode(':anniv:', 'smile', 'comments_message');bb_hide_block('1', 'comments_message', 0);return false;" class="bbcode-hover" aria-label=":anniv:">
<img src="/images/smileys/143.gif" alt=":anniv:" aria-hidden="true" title=":anniv:" class="smiley" />
</a>
</li>
<li>
<a href="" onclick="insertbbcode(':]', 'smile', 'comments_message');bb_hide_block('1', 'comments_message', 0);return false;" class="bbcode-hover" aria-label=":]">
<img src="/images/smileys/8.gif" alt=":]" aria-hidden="true" title=":]" class="smiley" />
</a>
</li>
<li>
<a href="" onclick="insertbbcode(':langue4:', 'smile', 'comments_message');bb_hide_block('1', 'comments_message', 0);return false;" class="bbcode-hover" aria-label=":langue4:">
<img src="/images/smileys/131.gif" alt=":langue4:" aria-hidden="true" title=":langue4:" class="smiley" />
</a>
</li>
<li>
<a href="" onclick="insertbbcode(':hihi:', 'smile', 'comments_message');bb_hide_block('1', 'comments_message', 0);return false;" class="bbcode-hover" aria-label=":hihi:">
<img src="/images/smileys/125.gif" alt=":hihi:" aria-hidden="true" title=":hihi:" class="smiley" />
</a>
</li>
<li>
<a href="" onclick="insertbbcode(':merci:', 'smile', 'comments_message');bb_hide_block('1', 'comments_message', 0);return false;" class="bbcode-hover" aria-label=":merci:">
<img src="/images/smileys/73.gif" alt=":merci:" aria-hidden="true" title=":merci:" class="smiley" />
</a>
</li>
<li>
<a href="" onclick="insertbbcode(':taré1:', 'smile', 'comments_message');bb_hide_block('1', 'comments_message', 0);return false;" class="bbcode-hover" aria-label=":taré1:">
<img src="/images/smileys/126.gif" alt=":taré1:" aria-hidden="true" title=":taré1:" class="smiley" />
</a>
</li>
<li>
<a href="" onclick="insertbbcode(':winner1:', 'smile', 'comments_message');bb_hide_block('1', 'comments_message', 0);return false;" class="bbcode-hover" aria-label=":winner1:">
<img src="/images/smileys/127.gif" alt=":winner1:" aria-hidden="true" title=":winner1:" class="smiley" />
</a>
</li>
<li>
<a href="" onclick="insertbbcode(':malade:', 'smile', 'comments_message');bb_hide_block('1', 'comments_message', 0);return false;" class="bbcode-hover" aria-label=":malade:">
<img src="/images/smileys/139.gif" alt=":malade:" aria-hidden="true" title=":malade:" class="smiley" />
</a>
</li>
<li>
<a href="" onclick="insertbbcode(':ghee:', 'smile', 'comments_message');bb_hide_block('1', 'comments_message', 0);return false;" class="bbcode-hover" aria-label=":ghee:">
<img src="/images/smileys/5.gif" alt=":ghee:" aria-hidden="true" title=":ghee:" class="smiley" />
</a>
</li>
<li>
<a href="" onclick="insertbbcode(':pleur4:', 'smile', 'comments_message');bb_hide_block('1', 'comments_message', 0);return false;" class="bbcode-hover" aria-label=":pleur4:">
<img src="/images/smileys/102.gif" alt=":pleur4:" aria-hidden="true" title=":pleur4:" class="smiley" />
</a>
</li>
<li>
<a href="" onclick="insertbbcode(':winner2:', 'smile', 'comments_message');bb_hide_block('1', 'comments_message', 0);return false;" class="bbcode-hover" aria-label=":winner2:">
<img src="/images/smileys/128.gif" alt=":winner2:" aria-hidden="true" title=":winner2:" class="smiley" />
</a>
</li>
<li>
<a href="" onclick="insertbbcode(':peur1:', 'smile', 'comments_message');bb_hide_block('1', 'comments_message', 0);return false;" class="bbcode-hover" aria-label=":peur1:">
<img src="/images/smileys/107.gif" alt=":peur1:" aria-hidden="true" title=":peur1:" class="smiley" />
</a>
</li>
<li>
<a href="" onclick="insertbbcode(':blub:', 'smile', 'comments_message');bb_hide_block('1', 'comments_message', 0);return false;" class="bbcode-hover" aria-label=":blub:">
<img src="/images/smileys/63.gif" alt=":blub:" aria-hidden="true" title=":blub:" class="smiley" />
</a>
</li>
<li>
<a href="" onclick="insertbbcode(':lock:', 'smile', 'comments_message');bb_hide_block('1', 'comments_message', 0);return false;" class="bbcode-hover" aria-label=":lock:">
<img src="/images/smileys/164.gif" alt=":lock:" aria-hidden="true" title=":lock:" class="smiley" />
</a>
</li>
<li>
<a href="" onclick="insertbbcode(':gene2l:', 'smile', 'comments_message');bb_hide_block('1', 'comments_message', 0);return false;" class="bbcode-hover" aria-label=":gene2l:">
<img src="/images/smileys/67.gif" alt=":gene2l:" aria-hidden="true" title=":gene2l:" class="smiley" />
</a>
</li>
<li>
<a href="" onclick="insertbbcode(':gene5:', 'smile', 'comments_message');bb_hide_block('1', 'comments_message', 0);return false;" class="bbcode-hover" aria-label=":gene5:">
<img src="/images/smileys/68.gif" alt=":gene5:" aria-hidden="true" title=":gene5:" class="smiley" />
</a>
</li>
<li>
<a href="" onclick="insertbbcode(':faché3:', 'smile', 'comments_message');bb_hide_block('1', 'comments_message', 0);return false;" class="bbcode-hover" aria-label=":faché3:">
<img src="/images/smileys/94.gif" alt=":faché3:" aria-hidden="true" title=":faché3:" class="smiley" />
</a>
</li>
<li>
<a href="" onclick="insertbbcode(':sms:', 'smile', 'comments_message');bb_hide_block('1', 'comments_message', 0);return false;" class="bbcode-hover" aria-label=":sms:">
<img src="/images/smileys/7.gif" alt=":sms:" aria-hidden="true" title=":sms:" class="smiley" />
</a>
</li>
<li>
<a href="" onclick="insertbbcode(':pika:', 'smile', 'comments_message');bb_hide_block('1', 'comments_message', 0);return false;" class="bbcode-hover" aria-label=":pika:">
<img src="/images/smileys/pikachu-pika.gif" alt=":pika:" aria-hidden="true" title=":pika:" class="smiley" />
</a>
</li>
</ul>
</div>
</li>
</ul>
<ul id="bbcode-container-fonts" class="bbcode-container dlt-color-op20-after">
<li class="bbcode-elements bkgd-color-op20-hover">
<a href="" onclick="insertbbcode('[b]', '[/b]', 'comments_message');return false;" aria-label="Texte en gras : [b]texte[/b]">
<i class="fa fa-fw bbcode-icon-bold" aria-hidden="true" title="Texte en gras : [b]texte[/b]"></i>
</a>
</li>
<li class="bbcode-elements bkgd-color-op20-hover">
<a href="" onclick="insertbbcode('[i]', '[/i]', 'comments_message');return false;" aria-label="Texte en italique : [i]texte[/i]">
<i class="fa fa-fw bbcode-icon-italic" aria-hidden="true" title="Texte en italique : [i]texte[/i]"></i>
</a>
</li>
<li class="bbcode-elements bkgd-color-op20-hover">
<a href="" onclick="insertbbcode('[u]', '[/u]', 'comments_message');return false;" aria-label="Texte souligné : [u]texte[/u]">
<i class="fa fa-fw bbcode-icon-underline" aria-hidden="true" title="Texte souligné : [u]texte[/u]"></i>
</a>
</li>
<li class="bbcode-elements bkgd-color-op20-hover">
<a href="" onclick="insertbbcode('[s]', '[/s]', 'comments_message');return false;" aria-label="Texte barré : [s]texte[/s]">
<i class="fa fa-fw bbcode-icon-strike" aria-hidden="true" title="Texte barré : [s]texte[/s]"></i>
</a>
</li>
<li class="bbcode-elements bkgd-color-op20-hover">
<a href="" onclick="bbcode_color('5', 'comments_message', 'color');bb_display_block('5', 'comments_message');return false;" onmouseout="bb_hide_block('5', 'comments_message', 0);" aria-label="Couleur du texte : [color=X]texte de couleur X[/color]" class="">
<i class="fa fa-fw bbcode-icon-color" aria-hidden="true" title="Couleur du texte : [color=X]texte de couleur X[/color]"></i>
</a>
<div id="bb-block5comments_message" class="bbcode-block-container arrow-submenu-color color-picker" style="display: none;">
<div id="bb-colorcomments_message" class="bbcode-block" onmouseover="bb_hide_block('5', 'comments_message', 1);" onmouseout="bb_hide_block('5', 'comments_message', 0);">
</div>
</div>
</li>
<li class="bbcode-elements bkgd-color-op20-hover">
<a href="" onclick="bb_display_block('6', 'comments_message');return false;" onmouseout="bb_hide_block('6', 'comments_message', 0);" class="bbcode-hover" aria-label="Taille du texte (X entre 0 - 49) : [size=X]texte de taille X[/size]">
<i class="fa fa-fw bbcode-icon-size" aria-hidden="true" title="Taille du texte (X entre 0 - 49) : [size=X]texte de taille X[/size]"></i>
</a>
<div id="bb-block6comments_message" class="bbcode-block-container arrow-submenu-color" style="display: none;">
<ul class="bbcode-block block-submenu-color bbcode-block-list bkgd-color-op20-hover bbcode-block-size" onmouseover="bb_hide_block('6', 'comments_message', 1);" onmouseout="bb_hide_block('6', 'comments_message', 0);">
<li><a href="" onclick="insertbbcode('[size=5]', '[/size]', 'comments_message');bb_hide_block('6', 'comments_message', 0);return false;" title="Taille de police 05"> 05 </a></li>
<li><a href="" onclick="insertbbcode('[size=10]', '[/size]', 'comments_message');bb_hide_block('6', 'comments_message', 0);return false;" title="Taille de police 10"> 10 </a></li>
<li><a href="" onclick="insertbbcode('[size=15]', '[/size]', 'comments_message');bb_hide_block('6', 'comments_message', 0);return false;" title="Taille de police 15"> 15 </a></li>
<li><a href="" onclick="insertbbcode('[size=20]', '[/size]', 'comments_message');bb_hide_block('6', 'comments_message', 0);return false;" title="Taille de police 20"> 20 </a></li>
<li><a href="" onclick="insertbbcode('[size=25]', '[/size]', 'comments_message');bb_hide_block('6', 'comments_message', 0);return false;" title="Taille de police 25"> 25 </a></li>
<li><a href="" onclick="insertbbcode('[size=30]', '[/size]', 'comments_message');bb_hide_block('6', 'comments_message', 0);return false;" title="Taille de police 30"> 30 </a></li>
<li><a href="" onclick="insertbbcode('[size=35]', '[/size]', 'comments_message');bb_hide_block('6', 'comments_message', 0);return false;" title="Taille de police 35"> 35 </a></li>
<li><a href="" onclick="insertbbcode('[size=40]', '[/size]', 'comments_message');bb_hide_block('6', 'comments_message', 0);return false;" title="Taille de police 40"> 40 </a></li>
<li><a href="" onclick="insertbbcode('[size=45]', '[/size]', 'comments_message');bb_hide_block('6', 'comments_message', 0);return false;" title="Taille de police 45"> 45 </a></li>
</ul>
</div>
</li>
<li class="bbcode-elements bkgd-color-op20-hover">
<a href="" onclick="bb_display_block('10', 'comments_message');return false;" onmouseout="bb_hide_block('10', 'comments_message', 0);" class="bbcode-hover" aria-label="Police : [font=X]texte en police X[/font]">
<i class="fa fa-fw bbcode-icon-font" aria-hidden="true" title="Police : [font=X]texte en police X[/font]"></i>
</a>
<div id="bb-block10comments_message" class="bbcode-block-container arrow-submenu-color" style="display: none;">
<ul class="bbcode-block block-submenu-color bbcode-block-list bkgd-color-op20-hover bbcode-block-fonts" onmouseover="bb_hide_block('10', 'comments_message', 1);" onmouseout="bb_hide_block('10', 'comments_message', 0);">
<li><a href="" onclick="insertbbcode('[font=andale mono]', '[/font]', 'comments_message');bb_hide_block('10', 'comments_message', 0);return false;" title="Police Andale Mono"> <span style="font-family: andale mono;">Andale Mono</span> </a></li>
<li><a href="" onclick="insertbbcode('[font=arial]', '[/font]', 'comments_message');bb_hide_block('10', 'comments_message', 0);return false;" title="Police Arial"> <span style="font-family: arial;">Arial</span> </a></li>
<li><a href="" onclick="insertbbcode('[font=arial black]', '[/font]', 'comments_message');bb_hide_block('10', 'comments_message', 0);return false;" title="Police Arial Black"> <span style="font-family: arial black;">Arial Black</span> </a></li>
<li><a href="" onclick="insertbbcode('[font=book antiqua]', '[/font]', 'comments_message');bb_hide_block('10', 'comments_message', 0);return false;" title="Police Book Antiqua"> <span style="font-family: book antiqua;">Book Antiqua</span> </a></li>
<li><a href="" onclick="insertbbcode('[font=comic sans ms]', '[/font]', 'comments_message');bb_hide_block('10', 'comments_message', 0);return false;" title="Police Comic Sans MS"> <span style="font-family: comic sans ms;">Comic Sans MS</span> </a></li>
<li><a href="" onclick="insertbbcode('[font=courier new]', '[/font]', 'comments_message');bb_hide_block('10', 'comments_message', 0);return false;" title="Police Courier New"> <span style="font-family: courier new;">Courier New</span> </a></li>
<li><a href="" onclick="insertbbcode('[font=georgia]', '[/font]', 'comments_message');bb_hide_block('10', 'comments_message', 0);return false;" title="Police Georgia"> <span style="font-family: georgia;">Georgia</span> </a></li>
<li><a href="" onclick="insertbbcode('[font=helvetica]', '[/font]', 'comments_message');bb_hide_block('10', 'comments_message', 0);return false;" title="Police Helvetica"> <span style="font-family: helvetica;">Helvetica</span> </a></li>
<li><a href="" onclick="insertbbcode('[font=impact]', '[/font]', 'comments_message');bb_hide_block('10', 'comments_message', 0);return false;" title="Police Impact"> <span style="font-family: impact;">Impact</span> </a></li>
<li><a href="" onclick="insertbbcode('[font=symbol]', '[/font]', 'comments_message');bb_hide_block('10', 'comments_message', 0);return false;" title="Police Symbol"> <span style="font-family: symbol;">Symbol</span> </a></li>
<li><a href="" onclick="insertbbcode('[font=tahoma]', '[/font]', 'comments_message');bb_hide_block('10', 'comments_message', 0);return false;" title="Police Tahoma"> <span style="font-family: tahoma;">Tahoma</span> </a></li>
<li><a href="" onclick="insertbbcode('[font=terminal]', '[/font]', 'comments_message');bb_hide_block('10', 'comments_message', 0);return false;" title="Police Terminal"> <span style="font-family: terminal;">Terminal</span> </a></li>
<li><a href="" onclick="insertbbcode('[font=times new roman]', '[/font]', 'comments_message');bb_hide_block('10', 'comments_message', 0);return false;" title="Police Times New Roman"> <span style="font-family: times new roman;">Times New Roman</span> </a></li>
<li><a href="" onclick="insertbbcode('[font=trebuchet ms]', '[/font]', 'comments_message');bb_hide_block('10', 'comments_message', 0);return false;" title="Police Trebuchet MS"> <span style="font-family: trebuchet ms;">Trebuchet MS</span> </a></li>
<li><a href="" onclick="insertbbcode('[font=verdana]', '[/font]', 'comments_message');bb_hide_block('10', 'comments_message', 0);return false;" title="Police Verdana"> <span style="font-family: verdana;">Verdana</span> </a></li>
<li><a href="" onclick="insertbbcode('[font=webdings]', '[/font]', 'comments_message');bb_hide_block('10', 'comments_message', 0);return false;" title="Police Webdings"> Webdings </a></li>
<li><a href="" onclick="insertbbcode('[font=wingdings]', '[/font]', 'comments_message');bb_hide_block('10', 'comments_message', 0);return false;" title="Police Wingdings"> Wingdings </a></li>
</ul>
</div>
</li>
</ul>
<ul id="bbcode-container-titles" class="bbcode-container dlt-color-op20-after">
<li class="bbcode-elements bkgd-color-op20-hover">
<a href="" onclick="bb_display_block('2', 'comments_message');return false;" onmouseout="bb_hide_block('2', 'comments_message', 0);" class="bbcode-hover" aria-label="Titre [title=x]texte[/title]">
<i class="fa fa-fw bbcode-icon-title" aria-hidden="true" title="Titre [title=x]texte[/title]"></i>
</a>
<div id="bb-block2comments_message" class="bbcode-block-container arrow-submenu-color" style="display: none;">
<ul class="bbcode-block block-submenu-color bbcode-block-list bkgd-color-op20-hover bbcode-block-title" onmouseover="bb_hide_block('2', 'comments_message', 1);" onmouseout="bb_hide_block('2', 'comments_message', 0);">
<li><a href="" onclick="insertbbcode('[title=1]', '[/title]', 'comments_message');bb_hide_block('2', 'comments_message', 0);return false;" title="Titre 1"> Titre 1 </a></li>
<li><a href="" onclick="insertbbcode('[title=2]', '[/title]', 'comments_message');bb_hide_block('2', 'comments_message', 0);return false;" title="Titre 2"> Titre 2 </a></li>
<li><a href="" onclick="insertbbcode('[title=3]', '[/title]', 'comments_message');bb_hide_block('2', 'comments_message', 0);return false;" title="Titre 3"> Titre 3 </a></li>
<li><a href="" onclick="insertbbcode('[title=4]', '[/title]', 'comments_message');bb_hide_block('2', 'comments_message', 0);return false;" title="Titre 4"> Titre 4 </a></li>
<li><a href="" onclick="insertbbcode('[title=5]', '[/title]', 'comments_message');bb_hide_block('2', 'comments_message', 0);return false;" title="Titre 5"> Titre 5 </a></li>
</ul>
</div>
</li>
<li class="bbcode-elements bkgd-color-op20-hover">
<a href="" onclick="bb_display_block('9', 'comments_message');return false;" onmouseout="bb_hide_block('9', 'comments_message', 0);" class="bbcode-hover" aria-label="Liste [list][*]texte1[*]texte2[/list]">
<i class="fa fa-fw bbcode-icon-list" aria-hidden="true" title="Liste [list][*]texte1[*]texte2[/list]"></i>
</a>
<div id="bb-block9comments_message" class="bbcode-block-container arrow-submenu-color" style="display: none;">
<div class="bbcode-block block-submenu-color bbcode-block-ul" onmouseover="bb_hide_block('9', 'comments_message', 1);" onmouseout="bb_hide_block('9', 'comments_message', 0);">
<div class="form-element">
<label class="smaller" for="bb_listcomments_message">Nombre de lignes</label>
<div class="form-field">
<input id="bb_listcomments_message" class="field-smaller" size="3" type="text" name="bb_listcomments_message" maxlength="3" value="3">
</div>
</div>
<div class="form-element">
<label class="smaller" for="bb_ordered_listcomments_message">Liste ordonnée</label>
<div class="form-field">
<input id="bb_ordered_listcomments_message" type="checkbox" name="bb_ordered_listcomments_message" >
</div>
</div>
<div class="bbcode-form-element-text">
<a class="small" href="" onclick="bbcode_list('comments_message');bb_hide_block('9', 'comments_message', 0);return false;">
<i class="fa fa-fw bbcode-icon-list valign-middle" title="Liste [list][*]texte1[*]texte2[/list]"></i> Insérer la liste
</a>
</div>
</div>
</div>
</li>
</ul>
<ul id="bbcode-container-blocks" class="bbcode-container dlt-color-op20-after">
<li class="bbcode-elements bkgd-color-op20-hover">
<a href="" onclick="bb_display_block('3', 'comments_message');return false;" onmouseout="bb_hide_block('3', 'comments_message', 0);" class="bbcode-hover" aria-label="Conteneur">
<i class="fa fa-fw bbcode-icon-subtitle" aria-hidden="true" title="Conteneur"></i>
</a>
<div id="bb-block3comments_message" class="bbcode-block-container arrow-submenu-color" style="display: none;">
<ul class="bbcode-block block-submenu-color bbcode-block-list bkgd-color-op20-hover bbcode-block-block" onmouseover="bb_hide_block('3', 'comments_message', 1);" onmouseout="bb_hide_block('3', 'comments_message', 0);">
<li><a href="" onclick="insertbbcode('[p]', '[/p]', 'comments_message');bb_hide_block('3', 'comments_message', 0);return false;" title="Conteneur Paragraphe : [p]texte[/p]"> Paragraphe </a></li>
<li><a href="" onclick="insertbbcode('[container]', '[/container]', 'comments_message');bb_hide_block('3', 'comments_message', 0);return false;" title="Conteneur personnalisable : [container id=&quot;&quot; class=&quot;&quot; style=&quot;&quot;]contenu[/container]"> Conteneur </a></li>
<li><a href="" onclick="insertbbcode('[block]', '[/block]', 'comments_message');bb_hide_block('3', 'comments_message', 0);return false;" title="Conteneur Bloc : [block]texte[/block]"> Bloc </a></li>
<li><a href="" onclick="bbcode_fieldset('comments_message', 'Titre du bloc champs ?');return false;" title="Conteneur Bloc champs : [fieldset legend=&quot;titre&quot;]texte[/fieldset]"> Bloc champs </a></li>
<li><a href="" onclick="bbcode_abbr('comments_message', 'Définition de l\'abréviation ?');return false;" title="Conteneur Abréviation : [abbr=description]texte[/abbr]"> Abréviation </a></li>
</ul>
</div>
</li>
<li class="bbcode-elements bkgd-color-op20-hover">
<a href="" onclick="bbcode_quote('comments_message', 'Auteur de la citation (Optionnel)');return false;" aria-label="Faire une citation [quote=pseudo]texte[/quote]">
<i class="fa fa-fw bbcode-icon-quote" aria-hidden="true" title="Faire une citation [quote=pseudo]texte[/quote]"></i>
</a>
</li>
<li class="bbcode-elements bkgd-color-op20-hover">
<a href="" onclick="bb_display_block('11', 'comments_message');return false;" onmouseout="bb_hide_block('11', 'comments_message', 0);" class="bbcode-hover" aria-label="Texte Caché">
<i class="fa fa-fw bbcode-icon-hide" aria-hidden="true" title="Texte Caché"></i>
</a>
<div class="bbcode-block-container arrow-submenu-color" style="display: none;" id="bb-block11comments_message">
<ul class="bbcode-block block-submenu-color bbcode-block-list bkgd-color-op20-hover bbcode-block-hide" onmouseover="bb_hide_block('11', 'comments_message', 1);" onmouseout="bb_hide_block('11', 'comments_message', 0);">
<li><a href="" onclick="insertbbcode('[hide]', '[/hide]', 'comments_message');bb_hide_block('11', 'comments_message', 0);return false;" title="Cache le texte et l'affiche au clic [hide]text[/hide] "> Texte Caché </a></li>
<li><a href="" onclick="insertbbcode('[member]', '[/member]', 'comments_message');bb_hide_block('11', 'comments_message', 0);return false;" title="Cache le texte pour les visiteurs [member]text[/member]"> Membre </a></li>
<li><a href="" onclick="insertbbcode('[moderator]', '[/moderator]', 'comments_message');bb_hide_block('11', 'comments_message', 0);return false;" title="Cache le texte pour les membres [moderator]text[/moderator]  "> Modérateur </a></li>
</ul>
</div>
</li>
<li class="bbcode-elements bkgd-color-op20-hover">
<a href="" onclick="bb_display_block('4', 'comments_message');return false;" onmouseout="bb_hide_block('4', 'comments_message', 0);" class="bbcode-hover" aria-label="Style [style=x]texte[/style]">
<i class="fa fa-fw bbcode-icon-style" aria-hidden="true" title="Style [style=x]texte[/style]"></i>
</a>
<div class="bbcode-block-container arrow-submenu-color" style="display: none;" id="bb-block4comments_message">
<ul class="bbcode-block block-submenu-color bbcode-block-list bkgd-color-op20-hover bbcode-block-message" onmouseover="bb_hide_block('4', 'comments_message', 1);" onmouseout="bb_hide_block('4', 'comments_message', 0);">
<li><a href="" onclick="insertbbcode('[style=success]', '[/style]', 'comments_message');bb_hide_block('4', 'comments_message', 0);return false;" title="Style Succès"> Succès </a></li>
<li><a href="" onclick="insertbbcode('[style=question]', '[/style]', 'comments_message');bb_hide_block('4', 'comments_message', 0);return false;" title="Style Question"> Question </a></li>
<li><a href="" onclick="insertbbcode('[style=notice]', '[/style]', 'comments_message');bb_hide_block('4', 'comments_message', 0);return false;" title="Style Remarque"> Remarque </a></li>
<li><a href="" onclick="insertbbcode('[style=warning]', '[/style]', 'comments_message');bb_hide_block('4', 'comments_message', 0);return false;" title="Style Avertissements"> Avertissements </a></li>
<li><a href="" onclick="insertbbcode('[style=error]', '[/style]', 'comments_message');bb_hide_block('4', 'comments_message', 0);return false;" title="Style Erreur"> Erreur </a></li>
</ul>
</div>
</li>
</ul>
<ul id="bbcode-container-links" class="bbcode-container dlt-color-op20-after">
<li class="bbcode-elements bkgd-color-op20-hover">
<a href="" onclick="bbcode_url('comments_message', 'Adresse du lien ?');return false;" aria-label="Ajouter un lien : [url]lien[/url], ou [url=lien]nom du lien[/url]">
<i class="fa fa-fw bbcode-icon-url" aria-hidden="true" title="Ajouter un lien : [url]lien[/url], ou [url=lien]nom du lien[/url]"></i>
</a>
</li>
</ul>
<ul id="bbcode-container-pictures" class="bbcode-container dlt-color-op20-after">
<li class="bbcode-elements bkgd-color-op20-hover">
<a href="" onclick="insertbbcode('[img]', '[/img]', 'comments_message');return false;" aria-label="Ajouter une image : [img]url image[/img]">
<i class="fa fa-fw bbcode-icon-image" aria-hidden="true" title="Ajouter une image : [img]url image[/img]"></i>
</a>
</li>
<li class="bbcode-elements bkgd-color-op20-hover">
<a href="" onclick="bbcode_lightbox('comments_message', 'Adresse du lien ?');return false;" aria-label="Ajouter une image avec un effet lightbox : [lightbox=url image][img]url image réduite[/img][/lightbox]">
<i class="fa fa-fw bbcode-icon-lightbox" aria-hidden="true" title="Ajouter une image avec un effet lightbox : [lightbox=url image][img]url image réduite[/img][/lightbox]"></i>
</a>
</li>
</ul>
<span class="bbcode-backspace"></span>
<ul id="bbcode-container-fa" class="bbcode-container bbcode-container-more dlt-color-op20-after">
<li class="bbcode-elements bkgd-color-op20-hover">
<a href="" onclick="bb_display_block('12', 'comments_message');return false;" onmouseover="bb_hide_block('12', 'comments_message', 1);" onmouseout="bb_hide_block('12', 'comments_message', 0);" class="bbcode-hover" aria-label="Icône Font Awesome [fa]nom de l'icône[/fa]">
<i class="fab fa-fw bbcode-icon-fa" aria-hidden="true" title="Icône Font Awesome [fa]nom de l'icône[/fa]"></i>
</a>
<div id="bb-block12comments_message" class="bbcode-block-container arrow-submenu-color" style="display: none;">
<ul class="bbcode-block block-submenu-color bbcode-block-fa" onmouseover="bb_hide_block('12', 'comments_message', 1);" onmouseout="bb_hide_block('12', 'comments_message', 0);">
<li>
<a href="" onclick="insertbbcode('[fa]arrow-up[/fa]', '', 'comments_message');bb_hide_block('12', 'comments_message', 0);return false;" class="bbcode-hover" aria-label="arrow-up">
<i class="fa fa-arrow-up" aria-hidden="true" title="arrow-up"></i>
</a>
</li>
<li>
<a href="" onclick="insertbbcode('[fa]arrow-down[/fa]', '', 'comments_message');bb_hide_block('12', 'comments_message', 0);return false;" class="bbcode-hover" aria-label="arrow-down">
<i class="fa fa-arrow-down" aria-hidden="true" title="arrow-down"></i>
</a>
</li>
<li>
<a href="" onclick="insertbbcode('[fa]arrow-left[/fa]', '', 'comments_message');bb_hide_block('12', 'comments_message', 0);return false;" class="bbcode-hover" aria-label="arrow-left">
<i class="fa fa-arrow-left" aria-hidden="true" title="arrow-left"></i>
</a>
</li>
<li>
<a href="" onclick="insertbbcode('[fa]arrow-right[/fa]', '', 'comments_message');bb_hide_block('12', 'comments_message', 0);return false;" class="bbcode-hover" aria-label="arrow-right">
<i class="fa fa-arrow-right" aria-hidden="true" title="arrow-right"></i>
</a>
</li>
<li>
<a href="" onclick="insertbbcode('[fa]arrows-alt-h[/fa]', '', 'comments_message');bb_hide_block('12', 'comments_message', 0);return false;" class="bbcode-hover" aria-label="arrows-alt-h">
<i class="fa fa-arrows-alt-h" aria-hidden="true" title="arrows-alt-h"></i>
</a>
</li>
<li>
<a href="" onclick="insertbbcode('[fa]arrows-alt[/fa]', '', 'comments_message');bb_hide_block('12', 'comments_message', 0);return false;" class="bbcode-hover" aria-label="arrows-alt">
<i class="fa fa-arrows-alt" aria-hidden="true" title="arrows-alt"></i>
</a>
</li>
<li>
<a href="" onclick="insertbbcode('[fa]ban[/fa]', '', 'comments_message');bb_hide_block('12', 'comments_message', 0);return false;" class="bbcode-hover" aria-label="ban">
<i class="fa fa-ban" aria-hidden="true" title="ban"></i>
</a>
</li>
<li>
<a href="" onclick="insertbbcode('[fa]unban[/fa]', '', 'comments_message');bb_hide_block('12', 'comments_message', 0);return false;" class="bbcode-hover" aria-label="unban">
<i class="fa fa-unban" aria-hidden="true" title="unban"></i>
</a>
</li>
<li>
<a href="" onclick="insertbbcode('[fa]chart-bar[/fa]', '', 'comments_message');bb_hide_block('12', 'comments_message', 0);return false;" class="bbcode-hover" aria-label="chart-bar">
<i class="fa fa-chart-bar" aria-hidden="true" title="chart-bar"></i>
</a>
</li>
<li>
<a href="" onclick="insertbbcode('[fa]bars[/fa]', '', 'comments_message');bb_hide_block('12', 'comments_message', 0);return false;" class="bbcode-hover" aria-label="bars">
<i class="fa fa-bars" aria-hidden="true" title="bars"></i>
</a>
</li>
<li>
<a href="" onclick="insertbbcode('[fa]bell[/fa]', '', 'comments_message');bb_hide_block('12', 'comments_message', 0);return false;" class="bbcode-hover" aria-label="bell">
<i class="fa fa-bell" aria-hidden="true" title="bell"></i>
</a>
</li>
<li>
<a href="" onclick="insertbbcode('[fa]book[/fa]', '', 'comments_message');bb_hide_block('12', 'comments_message', 0);return false;" class="bbcode-hover" aria-label="book">
<i class="fa fa-book" aria-hidden="true" title="book"></i>
</a>
</li>
<li>
<a href="" onclick="insertbbcode('[fa]calendar-alt[/fa]', '', 'comments_message');bb_hide_block('12', 'comments_message', 0);return false;" class="bbcode-hover" aria-label="calendar-alt">
<i class="fa fa-calendar-alt" aria-hidden="true" title="calendar-alt"></i>
</a>
</li>
<li>
<a href="" onclick="insertbbcode('[fa]caret-left[/fa]', '', 'comments_message');bb_hide_block('12', 'comments_message', 0);return false;" class="bbcode-hover" aria-label="caret-left">
<i class="fa fa-caret-left" aria-hidden="true" title="caret-left"></i>
</a>
</li>
<li>
<a href="" onclick="insertbbcode('[fa]caret-right[/fa]', '', 'comments_message');bb_hide_block('12', 'comments_message', 0);return false;" class="bbcode-hover" aria-label="caret-right">
<i class="fa fa-caret-right" aria-hidden="true" title="caret-right"></i>
</a>
</li>
<li>
<a href="" onclick="insertbbcode('[fa=far]clipboard[/fa]', '', 'comments_message');bb_hide_block('12', 'comments_message', 0);return false;" class="bbcode-hover" aria-label="clipboard">
<i class="far fa-clipboard" aria-hidden="true" title="clipboard"></i>
</a>
</li>
<li>
<a href="" onclick="insertbbcode('[fa=far]clock[/fa]', '', 'comments_message');bb_hide_block('12', 'comments_message', 0);return false;" class="bbcode-hover" aria-label="clock">
<i class="far fa-clock" aria-hidden="true" title="clock"></i>
</a>
</li>
<li>
<a href="" onclick="insertbbcode('[fa]cloud-upload-alt[/fa]', '', 'comments_message');bb_hide_block('12', 'comments_message', 0);return false;" class="bbcode-hover" aria-label="cloud-upload-alt">
<i class="fa fa-cloud-upload-alt" aria-hidden="true" title="cloud-upload-alt"></i>
</a>
</li>
<li>
<a href="" onclick="insertbbcode('[fa]download[/fa]', '', 'comments_message');bb_hide_block('12', 'comments_message', 0);return false;" class="bbcode-hover" aria-label="download">
<i class="fa fa-download" aria-hidden="true" title="download"></i>
</a>
</li>
<li>
<a href="" onclick="insertbbcode('[fa]code[/fa]', '', 'comments_message');bb_hide_block('12', 'comments_message', 0);return false;" class="bbcode-hover" aria-label="code">
<i class="fa fa-code" aria-hidden="true" title="code"></i>
</a>
</li>
<li>
<a href="" onclick="insertbbcode('[fa]code-branch[/fa]', '', 'comments_message');bb_hide_block('12', 'comments_message', 0);return false;" class="bbcode-hover" aria-label="code-branch">
<i class="fa fa-code-branch" aria-hidden="true" title="code-branch"></i>
</a>
</li>
<li>
<a href="" onclick="insertbbcode('[fa]cog[/fa]', '', 'comments_message');bb_hide_block('12', 'comments_message', 0);return false;" class="bbcode-hover" aria-label="cog">
<i class="fa fa-cog" aria-hidden="true" title="cog"></i>
</a>
</li>
<li>
<a href="" onclick="insertbbcode('[fa]cogs[/fa]', '', 'comments_message');bb_hide_block('12', 'comments_message', 0);return false;" class="bbcode-hover" aria-label="cogs">
<i class="fa fa-cogs" aria-hidden="true" title="cogs"></i>
</a>
</li>
<li>
<a href="" onclick="insertbbcode('[fa]comment[/fa]', '', 'comments_message');bb_hide_block('12', 'comments_message', 0);return false;" class="bbcode-hover" aria-label="comment">
<i class="fa fa-comment" aria-hidden="true" title="comment"></i>
</a>
</li>
<li>
<a href="" onclick="insertbbcode('[fa=far]comment[/fa]', '', 'comments_message');bb_hide_block('12', 'comments_message', 0);return false;" class="bbcode-hover" aria-label="comment">
<i class="far fa-comment" aria-hidden="true" title="comment"></i>
</a>
</li>
<li>
<a href="" onclick="insertbbcode('[fa=far]comments[/fa]', '', 'comments_message');bb_hide_block('12', 'comments_message', 0);return false;" class="bbcode-hover" aria-label="comments">
<i class="far fa-comments" aria-hidden="true" title="comments"></i>
</a>
</li>
<li>
<a href="" onclick="insertbbcode('[fa]cube[/fa]', '', 'comments_message');bb_hide_block('12', 'comments_message', 0);return false;" class="bbcode-hover" aria-label="cube">
<i class="fa fa-cube" aria-hidden="true" title="cube"></i>
</a>
</li>
<li>
<a href="" onclick="insertbbcode('[fa]cubes[/fa]', '', 'comments_message');bb_hide_block('12', 'comments_message', 0);return false;" class="bbcode-hover" aria-label="cubes">
<i class="fa fa-cubes" aria-hidden="true" title="cubes"></i>
</a>
</li>
<li>
<a href="" onclick="insertbbcode('[fa]delete[/fa]', '', 'comments_message');bb_hide_block('12', 'comments_message', 0);return false;" class="bbcode-hover" aria-label="delete">
<i class="fa fa-delete" aria-hidden="true" title="delete"></i>
</a>
</li>
<li>
<a href="" onclick="insertbbcode('[fa]edit[/fa]', '', 'comments_message');bb_hide_block('12', 'comments_message', 0);return false;" class="bbcode-hover" aria-label="edit">
<i class="fa fa-edit" aria-hidden="true" title="edit"></i>
</a>
</li>
<li>
<a href="" onclick="insertbbcode('[fa]remove[/fa]', '', 'comments_message');bb_hide_block('12', 'comments_message', 0);return false;" class="bbcode-hover" aria-label="remove">
<i class="fa fa-remove" aria-hidden="true" title="remove"></i>
</a>
</li>
<li>
<a href="" onclick="insertbbcode('[fa]envelope[/fa]', '', 'comments_message');bb_hide_block('12', 'comments_message', 0);return false;" class="bbcode-hover" aria-label="envelope">
<i class="fa fa-envelope" aria-hidden="true" title="envelope"></i>
</a>
</li>
<li>
<a href="" onclick="insertbbcode('[fa=far]envelope[/fa]', '', 'comments_message');bb_hide_block('12', 'comments_message', 0);return false;" class="bbcode-hover" aria-label="envelope">
<i class="far fa-envelope" aria-hidden="true" title="envelope"></i>
</a>
</li>
<li>
<a href="" onclick="insertbbcode('[fa]eraser[/fa]', '', 'comments_message');bb_hide_block('12', 'comments_message', 0);return false;" class="bbcode-hover" aria-label="eraser">
<i class="fa fa-eraser" aria-hidden="true" title="eraser"></i>
</a>
</li>
<li>
<a href="" onclick="insertbbcode('[fa]check[/fa]', '', 'comments_message');bb_hide_block('12', 'comments_message', 0);return false;" class="bbcode-hover" aria-label="check">
<i class="fa fa-check" aria-hidden="true" title="check"></i>
</a>
</li>
<li>
<a href="" onclick="insertbbcode('[fa]success[/fa]', '', 'comments_message');bb_hide_block('12', 'comments_message', 0);return false;" class="bbcode-hover" aria-label="success">
<i class="fa fa-success" aria-hidden="true" title="success"></i>
</a>
</li>
<li>
<a href="" onclick="insertbbcode('[fa]error[/fa]', '', 'comments_message');bb_hide_block('12', 'comments_message', 0);return false;" class="bbcode-hover" aria-label="error">
<i class="fa fa-error" aria-hidden="true" title="error"></i>
</a>
</li>
<li>
<a href="" onclick="insertbbcode('[fa]warning[/fa]', '', 'comments_message');bb_hide_block('12', 'comments_message', 0);return false;" class="bbcode-hover" aria-label="warning">
<i class="fa fa-warning" aria-hidden="true" title="warning"></i>
</a>
</li>
<li>
<a href="" onclick="insertbbcode('[fa]question[/fa]', '', 'comments_message');bb_hide_block('12', 'comments_message', 0);return false;" class="bbcode-hover" aria-label="question">
<i class="fa fa-question" aria-hidden="true" title="question"></i>
</a>
</li>
<li>
<a href="" onclick="insertbbcode('[fa]forbidden[/fa]', '', 'comments_message');bb_hide_block('12', 'comments_message', 0);return false;" class="bbcode-hover" aria-label="forbidden">
<i class="fa fa-forbidden" aria-hidden="true" title="forbidden"></i>
</a>
</li>
<li>
<a href="" onclick="insertbbcode('[fa]info-circle[/fa]', '', 'comments_message');bb_hide_block('12', 'comments_message', 0);return false;" class="bbcode-hover" aria-label="info-circle">
<i class="fa fa-info-circle" aria-hidden="true" title="info-circle"></i>
</a>
</li>
<li>
<a href="" onclick="insertbbcode('[fa=far]eye[/fa]', '', 'comments_message');bb_hide_block('12', 'comments_message', 0);return false;" class="bbcode-hover" aria-label="eye">
<i class="far fa-eye" aria-hidden="true" title="eye"></i>
</a>
</li>
<li>
<a href="" onclick="insertbbcode('[fa]eye-slash[/fa]', '', 'comments_message');bb_hide_block('12', 'comments_message', 0);return false;" class="bbcode-hover" aria-label="eye-slash">
<i class="fa fa-eye-slash" aria-hidden="true" title="eye-slash"></i>
</a>
</li>
<li>
<a href="" onclick="insertbbcode('[fa=fab]facebook[/fa]', '', 'comments_message');bb_hide_block('12', 'comments_message', 0);return false;" class="bbcode-hover" aria-label="facebook">
<i class="fab fa-facebook" aria-hidden="true" title="facebook"></i>
</a>
</li>
<li>
<a href="" onclick="insertbbcode('[fa]fast-forward[/fa]', '', 'comments_message');bb_hide_block('12', 'comments_message', 0);return false;" class="bbcode-hover" aria-label="fast-forward">
<i class="fa fa-fast-forward" aria-hidden="true" title="fast-forward"></i>
</a>
</li>
<li>
<a href="" onclick="insertbbcode('[fa]filter[/fa]', '', 'comments_message');bb_hide_block('12', 'comments_message', 0);return false;" class="bbcode-hover" aria-label="filter">
<i class="fa fa-filter" aria-hidden="true" title="filter"></i>
</a>
</li>
<li>
<a href="" onclick="insertbbcode('[fa]flag[/fa]', '', 'comments_message');bb_hide_block('12', 'comments_message', 0);return false;" class="bbcode-hover" aria-label="flag">
<i class="fa fa-flag" aria-hidden="true" title="flag"></i>
</a>
</li>
<li>
<a href="" onclick="insertbbcode('[fa=fab]font-awesome-flag[/fa]', '', 'comments_message');bb_hide_block('12', 'comments_message', 0);return false;" class="bbcode-hover" aria-label="font-awesome-flag">
<i class="fab fa-font-awesome-flag" aria-hidden="true" title="font-awesome-flag"></i>
</a>
</li>
<li>
<a href="" onclick="insertbbcode('[fa]folder[/fa]', '', 'comments_message');bb_hide_block('12', 'comments_message', 0);return false;" class="bbcode-hover" aria-label="folder">
<i class="fa fa-folder" aria-hidden="true" title="folder"></i>
</a>
</li>
<li>
<a href="" onclick="insertbbcode('[fa]folder-open[/fa]', '', 'comments_message');bb_hide_block('12', 'comments_message', 0);return false;" class="bbcode-hover" aria-label="folder-open">
<i class="fa fa-folder-open" aria-hidden="true" title="folder-open"></i>
</a>
</li>
<li>
<a href="" onclick="insertbbcode('[fa]gavel[/fa]', '', 'comments_message');bb_hide_block('12', 'comments_message', 0);return false;" class="bbcode-hover" aria-label="gavel">
<i class="fa fa-gavel" aria-hidden="true" title="gavel"></i>
</a>
</li>
<li>
<a href="" onclick="insertbbcode('[fa]gears[/fa]', '', 'comments_message');bb_hide_block('12', 'comments_message', 0);return false;" class="bbcode-hover" aria-label="gears">
<i class="fa fa-gears" aria-hidden="true" title="gears"></i>
</a>
</li>
<li>
<a href="" onclick="insertbbcode('[fa]globe[/fa]', '', 'comments_message');bb_hide_block('12', 'comments_message', 0);return false;" class="bbcode-hover" aria-label="globe">
<i class="fa fa-globe" aria-hidden="true" title="globe"></i>
</a>
</li>
<li>
<a href="" onclick="insertbbcode('[fa=fab]google-plus-g[/fa]', '', 'comments_message');bb_hide_block('12', 'comments_message', 0);return false;" class="bbcode-hover" aria-label="google-plus-g">
<i class="fab fa-google-plus-g" aria-hidden="true" title="google-plus-g"></i>
</a>
</li>
<li>
<a href="" onclick="insertbbcode('[fa]hand-point-right[/fa]', '', 'comments_message');bb_hide_block('12', 'comments_message', 0);return false;" class="bbcode-hover" aria-label="hand-point-right">
<i class="fa fa-hand-point-right" aria-hidden="true" title="hand-point-right"></i>
</a>
</li>
<li>
<a href="" onclick="insertbbcode('[fa]heart[/fa]', '', 'comments_message');bb_hide_block('12', 'comments_message', 0);return false;" class="bbcode-hover" aria-label="heart">
<i class="fa fa-heart" aria-hidden="true" title="heart"></i>
</a>
</li>
<li>
<a href="" onclick="insertbbcode('[fa]home[/fa]', '', 'comments_message');bb_hide_block('12', 'comments_message', 0);return false;" class="bbcode-hover" aria-label="home">
<i class="fa fa-home" aria-hidden="true" title="home"></i>
</a>
</li>
<li>
<a href="" onclick="insertbbcode('[fa]key[/fa]', '', 'comments_message');bb_hide_block('12', 'comments_message', 0);return false;" class="bbcode-hover" aria-label="key">
<i class="fa fa-key" aria-hidden="true" title="key"></i>
</a>
</li>
<li>
<a href="" onclick="insertbbcode('[fa=far]lightbulb[/fa]', '', 'comments_message');bb_hide_block('12', 'comments_message', 0);return false;" class="bbcode-hover" aria-label="lightbulb">
<i class="far fa-lightbulb" aria-hidden="true" title="lightbulb"></i>
</a>
</li>
<li>
<a href="" onclick="insertbbcode('[fa]list-ul[/fa]', '', 'comments_message');bb_hide_block('12', 'comments_message', 0);return false;" class="bbcode-hover" aria-label="list-ul">
<i class="fa fa-list-ul" aria-hidden="true" title="list-ul"></i>
</a>
</li>
<li>
<a href="" onclick="insertbbcode('[fa]lock[/fa]', '', 'comments_message');bb_hide_block('12', 'comments_message', 0);return false;" class="bbcode-hover" aria-label="lock">
<i class="fa fa-lock" aria-hidden="true" title="lock"></i>
</a>
</li>
<li>
<a href="" onclick="insertbbcode('[fa]magic[/fa]', '', 'comments_message');bb_hide_block('12', 'comments_message', 0);return false;" class="bbcode-hover" aria-label="magic">
<i class="fa fa-magic" aria-hidden="true" title="magic"></i>
</a>
</li>
<li>
<a href="" onclick="insertbbcode('[fa]minus[/fa]', '', 'comments_message');bb_hide_block('12', 'comments_message', 0);return false;" class="bbcode-hover" aria-label="minus">
<i class="fa fa-minus" aria-hidden="true" title="minus"></i>
</a>
</li>
<li>
<a href="" onclick="insertbbcode('[fa]plus[/fa]', '', 'comments_message');bb_hide_block('12', 'comments_message', 0);return false;" class="bbcode-hover" aria-label="plus">
<i class="fa fa-plus" aria-hidden="true" title="plus"></i>
</a>
</li>
<li>
<a href="" onclick="insertbbcode('[fa]move[/fa]', '', 'comments_message');bb_hide_block('12', 'comments_message', 0);return false;" class="bbcode-hover" aria-label="move">
<i class="fa fa-move" aria-hidden="true" title="move"></i>
</a>
</li>
<li>
<a href="" onclick="insertbbcode('[fa]image[/fa]', '', 'comments_message');bb_hide_block('12', 'comments_message', 0);return false;" class="bbcode-hover" aria-label="image">
<i class="fa fa-image" aria-hidden="true" title="image"></i>
</a>
</li>
<li>
<a href="" onclick="insertbbcode('[fa]print[/fa]', '', 'comments_message');bb_hide_block('12', 'comments_message', 0);return false;" class="bbcode-hover" aria-label="print">
<i class="fa fa-print" aria-hidden="true" title="print"></i>
</a>
</li>
<li>
<a href="" onclick="insertbbcode('[fa]profil[/fa]', '', 'comments_message');bb_hide_block('12', 'comments_message', 0);return false;" class="bbcode-hover" aria-label="profil">
<i class="fa fa-profil" aria-hidden="true" title="profil"></i>
</a>
</li>
<li>
<a href="" onclick="insertbbcode('[fa]quote-right[/fa]', '', 'comments_message');bb_hide_block('12', 'comments_message', 0);return false;" class="bbcode-hover" aria-label="quote-right">
<i class="fa fa-quote-right" aria-hidden="true" title="quote-right"></i>
</a>
</li>
<li>
<a href="" onclick="insertbbcode('[fa]refresh[/fa]', '', 'comments_message');bb_hide_block('12', 'comments_message', 0);return false;" class="bbcode-hover" aria-label="refresh">
<i class="fa fa-refresh" aria-hidden="true" title="refresh"></i>
</a>
</li>
<li>
<a href="" onclick="insertbbcode('[fa]save[/fa]', '', 'comments_message');bb_hide_block('12', 'comments_message', 0);return false;" class="bbcode-hover" aria-label="save">
<i class="fa fa-save" aria-hidden="true" title="save"></i>
</a>
</li>
<li>
<a href="" onclick="insertbbcode('[fa]search[/fa]', '', 'comments_message');bb_hide_block('12', 'comments_message', 0);return false;" class="bbcode-hover" aria-label="search">
<i class="fa fa-search" aria-hidden="true" title="search"></i>
</a>
</li>
<li>
<a href="" onclick="insertbbcode('[fa=far]share-square[/fa]', '', 'comments_message');bb_hide_block('12', 'comments_message', 0);return false;" class="bbcode-hover" aria-label="share-square">
<i class="far fa-share-square" aria-hidden="true" title="share-square"></i>
</a>
</li>
<li>
<a href="" onclick="insertbbcode('[fa]sign-in-alt[/fa]', '', 'comments_message');bb_hide_block('12', 'comments_message', 0);return false;" class="bbcode-hover" aria-label="sign-in-alt">
<i class="fa fa-sign-in-alt" aria-hidden="true" title="sign-in-alt"></i>
</a>
</li>
<li>
<a href="" onclick="insertbbcode('[fa]sign-out-alt[/fa]', '', 'comments_message');bb_hide_block('12', 'comments_message', 0);return false;" class="bbcode-hover" aria-label="sign-out-alt">
<i class="fa fa-sign-out-alt" aria-hidden="true" title="sign-out-alt"></i>
</a>
</li>
<li>
<a href="" onclick="insertbbcode('[fa]smile[/fa]', '', 'comments_message');bb_hide_block('12', 'comments_message', 0);return false;" class="bbcode-hover" aria-label="smile">
<i class="fa fa-smile" aria-hidden="true" title="smile"></i>
</a>
</li>
<li>
<a href="" onclick="insertbbcode('[fa]sort[/fa]', '', 'comments_message');bb_hide_block('12', 'comments_message', 0);return false;" class="bbcode-hover" aria-label="sort">
<i class="fa fa-sort" aria-hidden="true" title="sort"></i>
</a>
</li>
<li>
<a href="" onclick="insertbbcode('[fa]sort-alpha-up[/fa]', '', 'comments_message');bb_hide_block('12', 'comments_message', 0);return false;" class="bbcode-hover" aria-label="sort-alpha-up">
<i class="fa fa-sort-alpha-up" aria-hidden="true" title="sort-alpha-up"></i>
</a>
</li>
<li>
<a href="" onclick="insertbbcode('[fa]sort-amount-up[/fa]', '', 'comments_message');bb_hide_block('12', 'comments_message', 0);return false;" class="bbcode-hover" aria-label="sort-amount-up">
<i class="fa fa-sort-amount-up" aria-hidden="true" title="sort-amount-up"></i>
</a>
</li>
<li>
<a href="" onclick="insertbbcode('[fa]sort-amount-down[/fa]', '', 'comments_message');bb_hide_block('12', 'comments_message', 0);return false;" class="bbcode-hover" aria-label="sort-amount-down">
<i class="fa fa-sort-amount-down" aria-hidden="true" title="sort-amount-down"></i>
</a>
</li>
<li>
<a href="" onclick="insertbbcode('[fa]spinner[/fa]', '', 'comments_message');bb_hide_block('12', 'comments_message', 0);return false;" class="bbcode-hover" aria-label="spinner">
<i class="fa fa-spinner" aria-hidden="true" title="spinner"></i>
</a>
</li>
<li>
<a href="" onclick="insertbbcode('[fa]star[/fa]', '', 'comments_message');bb_hide_block('12', 'comments_message', 0);return false;" class="bbcode-hover" aria-label="star">
<i class="fa fa-star" aria-hidden="true" title="star"></i>
</a>
</li>
<li>
<a href="" onclick="insertbbcode('[fa]star-half-empty[/fa]', '', 'comments_message');bb_hide_block('12', 'comments_message', 0);return false;" class="bbcode-hover" aria-label="star-half-empty">
<i class="fa fa-star-half-empty" aria-hidden="true" title="star-half-empty"></i>
</a>
</li>
<li>
<a href="" onclick="insertbbcode('[fa=far]star[/fa]', '', 'comments_message');bb_hide_block('12', 'comments_message', 0);return false;" class="bbcode-hover" aria-label="star">
<i class="far fa-star" aria-hidden="true" title="star"></i>
</a>
</li>
<li>
<a href="" onclick="insertbbcode('[fa]syndication[/fa]', '', 'comments_message');bb_hide_block('12', 'comments_message', 0);return false;" class="bbcode-hover" aria-label="syndication">
<i class="fa fa-syndication" aria-hidden="true" title="syndication"></i>
</a>
</li>
<li>
<a href="" onclick="insertbbcode('[fa]tag[/fa]', '', 'comments_message');bb_hide_block('12', 'comments_message', 0);return false;" class="bbcode-hover" aria-label="tag">
<i class="fa fa-tag" aria-hidden="true" title="tag"></i>
</a>
</li>
<li>
<a href="" onclick="insertbbcode('[fa]tags[/fa]', '', 'comments_message');bb_hide_block('12', 'comments_message', 0);return false;" class="bbcode-hover" aria-label="tags">
<i class="fa fa-tags" aria-hidden="true" title="tags"></i>
</a>
</li>
<li>
<a href="" onclick="insertbbcode('[fa]tasks[/fa]', '', 'comments_message');bb_hide_block('12', 'comments_message', 0);return false;" class="bbcode-hover" aria-label="tasks">
<i class="fa fa-tasks" aria-hidden="true" title="tasks"></i>
</a>
</li>
<li>
<a href="" onclick="insertbbcode('[fa]th[/fa]', '', 'comments_message');bb_hide_block('12', 'comments_message', 0);return false;" class="bbcode-hover" aria-label="th">
<i class="fa fa-th" aria-hidden="true" title="th"></i>
</a>
</li>
<li>
<a href="" onclick="insertbbcode('[fa]ticket-alt[/fa]', '', 'comments_message');bb_hide_block('12', 'comments_message', 0);return false;" class="bbcode-hover" aria-label="ticket-alt">
<i class="fa fa-ticket-alt" aria-hidden="true" title="ticket-alt"></i>
</a>
</li>
<li>
<a href="" onclick="insertbbcode('[fa]undo[/fa]', '', 'comments_message');bb_hide_block('12', 'comments_message', 0);return false;" class="bbcode-hover" aria-label="undo">
<i class="fa fa-undo" aria-hidden="true" title="undo"></i>
</a>
</li>
<li>
<a href="" onclick="insertbbcode('[fa]unlink[/fa]', '', 'comments_message');bb_hide_block('12', 'comments_message', 0);return false;" class="bbcode-hover" aria-label="unlink">
<i class="fa fa-unlink" aria-hidden="true" title="unlink"></i>
</a>
</li>
<li>
<a href="" onclick="insertbbcode('[fa]file[/fa]', '', 'comments_message');bb_hide_block('12', 'comments_message', 0);return false;" class="bbcode-hover" aria-label="file">
<i class="fa fa-file" aria-hidden="true" title="file"></i>
</a>
</li>
<li>
<a href="" onclick="insertbbcode('[fa=far]file[/fa]', '', 'comments_message');bb_hide_block('12', 'comments_message', 0);return false;" class="bbcode-hover" aria-label="file">
<i class="far fa-file" aria-hidden="true" title="file"></i>
</a>
</li>
<li>
<a href="" onclick="insertbbcode('[fa]file-alt[/fa]', '', 'comments_message');bb_hide_block('12', 'comments_message', 0);return false;" class="bbcode-hover" aria-label="file-alt">
<i class="fa fa-file-alt" aria-hidden="true" title="file-alt"></i>
</a>
</li>
<li>
<a href="" onclick="insertbbcode('[fa=far]file-alt[/fa]', '', 'comments_message');bb_hide_block('12', 'comments_message', 0);return false;" class="bbcode-hover" aria-label="file-alt">
<i class="far fa-file-alt" aria-hidden="true" title="file-alt"></i>
</a>
</li>
<li>
<a href="" onclick="insertbbcode('[fa]user[/fa]', '', 'comments_message');bb_hide_block('12', 'comments_message', 0);return false;" class="bbcode-hover" aria-label="user">
<i class="fa fa-user" aria-hidden="true" title="user"></i>
</a>
</li>
<li>
<a href="" onclick="insertbbcode('[fa]users[/fa]', '', 'comments_message');bb_hide_block('12', 'comments_message', 0);return false;" class="bbcode-hover" aria-label="users">
<i class="fa fa-users" aria-hidden="true" title="users"></i>
</a>
</li>
<li>
<a href="" onclick="insertbbcode('[fa]offline[/fa]', '', 'comments_message');bb_hide_block('12', 'comments_message', 0);return false;" class="bbcode-hover" aria-label="offline">
<i class="fa fa-offline" aria-hidden="true" title="offline"></i>
</a>
</li>
<li>
<a href="" onclick="insertbbcode('[fa]online[/fa]', '', 'comments_message');bb_hide_block('12', 'comments_message', 0);return false;" class="bbcode-hover" aria-label="online">
<i class="fa fa-online" aria-hidden="true" title="online"></i>
</a>
</li>
<li>
<a href="" onclick="insertbbcode('[fa]male[/fa]', '', 'comments_message');bb_hide_block('12', 'comments_message', 0);return false;" class="bbcode-hover" aria-label="male">
<i class="fa fa-male" aria-hidden="true" title="male"></i>
</a>
</li>
<li>
<a href="" onclick="insertbbcode('[fa]female[/fa]', '', 'comments_message');bb_hide_block('12', 'comments_message', 0);return false;" class="bbcode-hover" aria-label="female">
<i class="fa fa-female" aria-hidden="true" title="female"></i>
</a>
</li>
<li>
<a href="" onclick="insertbbcode('[fa]volume-up[/fa]', '', 'comments_message');bb_hide_block('12', 'comments_message', 0);return false;" class="bbcode-hover" aria-label="volume-up">
<i class="fa fa-volume-up" aria-hidden="true" title="volume-up"></i>
</a>
</li>
<li>
<a href="" onclick="insertbbcode('[fa]wrench[/fa]', '', 'comments_message');bb_hide_block('12', 'comments_message', 0);return false;" class="bbcode-hover" aria-label="wrench">
<i class="fa fa-wrench" aria-hidden="true" title="wrench"></i>
</a>
</li>
</ul>
</div>
</li>
</ul>
<ul id="bbcode-container-positions" class="bbcode-container bbcode-container-more dlt-color-op20-after">
<li class="bbcode-elements bkgd-color-op20-hover">
<a href="" onclick="bb_display_block('13', 'comments_message');return false;" onmouseover="bb_hide_block('13', 'comments_message', 1);" onmouseout="bb_hide_block('13', 'comments_message', 0);" class="bbcode-hover" aria-label="Alignement">
<i class="fa fa-fw bbcode-icon-left" aria-hidden="true" title="Alignement"></i>
</a>
<div class="bbcode-block-container arrow-submenu-color" style="display: none;" id="bb-block13comments_message">
<ul class="bbcode-block block-submenu-color bbcode-block-list bkgd-color-op20-hover bbcode-block-aligns" onmouseover="bb_hide_block('13', 'comments_message', 1);" onmouseout="bb_hide_block('13', 'comments_message', 0);">
<li><a href="" onclick="insertbbcode('[align=left]', '[/align]', 'comments_message');return false;" title="Aligner à gauche : [align=left]objet à gauche[/align]"> Aligner à gauche </a></li>
<li><a href="" onclick="insertbbcode('[align=center]', '[/align]', 'comments_message');return false;" title="Centrer : [align=center]objet centré[/align]"> Centrer </a></li>
<li><a href="" onclick="insertbbcode('[align=right]', '[/align]', 'comments_message');return false;" title="Aligner à gauche : [align=left]objet à gauche[/align]"> Aligner à droite </a></li>
<li><a href="" onclick="insertbbcode('[align=justify]', '[/align]', 'comments_message');return false;" title="Justifier : [align=justify]objet justifié[/align]"> Justifier </a></li>
</ul>
</div>
</li>
<li class="bbcode-elements bkgd-color-op20-hover">
<a href="" onclick="bb_display_block('14', 'comments_message');return false;" onmouseover="bb_hide_block('14', 'comments_message', 1);" onmouseout="bb_hide_block('14', 'comments_message', 0);" class="bbcode-hover" aria-label="Positionnement">
<i class="fa fa-fw bbcode-icon-indent" aria-hidden="true" title="Positionnement"></i>
</a>
<div class="bbcode-block-container arrow-submenu-color" style="display: none;" id="bb-block14comments_message">
<ul class="bbcode-block block-submenu-color bbcode-block-list bkgd-color-op20-hover bbcode-block-positions" onmouseover="bb_hide_block('14', 'comments_message', 1);" onmouseout="bb_hide_block('14', 'comments_message', 0);">
<li><a href="" onclick="insertbbcode('[float=left]', '[/float]', 'comments_message');return false;" title="Objet flottant à gauche [float=left]texte[/float]" class=""> Flottant à gauche </a></li>
<li><a href="" onclick="insertbbcode('[float=right]', '[/float]', 'comments_message');return false;" title="Objet flottant à droite [float=right]texte[/float]" class=""> Flottant à droite </a></li>
<li><a href="" onclick="insertbbcode('[indent]', '[/indent]', 'comments_message');return false;" title="Indentation [indent]texte[/indent]" class=""> Indentation </a></li>
</ul>
</div>
</li>
<li class="bbcode-elements bkgd-color-op20-hover">
<a href="" onclick="bb_display_block('7', 'comments_message');return false;" onmouseover="bb_hide_block('7', 'comments_message', 1);" class="bbcode-hover" aria-label="Tableau [table][row][col]texte[/col][col]texte2[/col][/row][/table]">
<i class="fa fa-fw bbcode-icon-table" aria-hidden="true" title="Tableau [table][row][col]texte[/col][col]texte2[/col][/row][/table]"></i>
</a>
<div id="bb-block7comments_message" class="bbcode-block-container arrow-submenu-color" style="display: none;">
<div id="bbtablecomments_message" class="bbcode-block block-submenu-color bbcode-block-table" onmouseover="bb_hide_block('7', 'comments_message', 1);" onmouseout="bb_hide_block('7', 'comments_message', 0);">
<div class="form-element">
<label class="smaller" for="bb-linescomments_message">Nombre de lignes</label>
<div class="form-field">
<input type="text" maxlength="2" name="bb-linescomments_message" id="bb-linescomments_message" value="2" class="field-smaller">
</div>
</div>
<div class="form-element">
<label class="smaller" for="bb-colscomments_message">Nombre de colonnes</label>
<div class="form-field">
<input type="text" maxlength="2" name="bb-colscomments_message" id="bb-colscomments_message" value="2" class="field-smaller">
</div>
</div>
<div class="form-element">
<label class="smaller" for="bb-headcomments_message">Ajouter l'entête</label>
<div class="form-field">
<input type="checkbox" name="bb-headcomments_message" id="bb-headcomments_message" class="field-smaller">
</div>
</div>
<div class="bbcode-form-element-text">
<a class="small" href="" onclick="bbcode_table('comments_message', 'Entête');bb_hide_block('7', 'comments_message', 0);return false;">
<i class="fa fa-fw bbcode-icon-table" title="Tableau [table][row][col]texte[/col][col]texte2[/col][/row][/table]"></i> Insérer le tableau
</a>
</div>
</div>
</div>
</li>
</ul>
<ul id="bbcode-container-exp" class="bbcode-container bbcode-container-more dlt-color-op20-after">
<li class="bbcode-elements bkgd-color-op20-hover">
<a href="" onclick="insertbbcode('[sup]', '[/sup]', 'comments_message');return false;" aria-label="Exposant [sup]texte[/sup]">
<i class="fa fa-fw bbcode-icon-sup" aria-hidden="true" title="Exposant [sup]texte[/sup]"></i>
</a>
</li>
<li class="bbcode-elements bkgd-color-op20-hover">
<a href="" onclick="insertbbcode('[sub]', '[/sub]', 'comments_message');return false;" aria-label="Indice [sub]texte[/sub]">
<i class="fa fa-fw bbcode-icon-sub" aria-hidden="true" title="Indice [sub]texte[/sub]"></i>
</a>
</li>
<li class="bbcode-elements bkgd-color-op20-hover">
<a href="" onclick="bbcode_color('15', 'comments_message', 'bgcolor');bb_display_block('15', 'comments_message');return false;" onmouseout="bb_hide_block('15', 'comments_message', 0);" aria-label="Couleur du fond : [bgcolor=X]texte de couleur X[/bgcolor]" class="">
<i class="fa fa-fw bbcode-icon-bgcolor" aria-hidden="true" title="Couleur du fond : [bgcolor=X]texte de couleur X[/bgcolor]"></i>
</a>
<div id="bb-block15comments_message" class="bbcode-block-container arrow-submenu-color color-picker" style="display: none;">
<div id="bb-bgcolorcomments_message" class="bbcode-block" onmouseover="bb_hide_block('15', 'comments_message', 1);" onmouseout="bb_hide_block('5', 'comments_message', 0);">
</div>
</div>
</li>
</ul>
<ul id="bbcode-container-anchor" class="bbcode-container bbcode-container-more dlt-color-op20-after">
<li class="bbcode-elements bkgd-color-op20-hover">
<a href="" onclick="bbcode_anchor('comments_message', 'Nom de l\'ancre (de la forme nom-de-l-ancre) ?');return false;" aria-label="Ancre vers un endroit de la page [anchor=x]texte[/anchor]">
<i class="fa fa-fw bbcode-icon-anchor" aria-hidden="true" title="Ancre vers un endroit de la page [anchor=x]texte[/anchor]"></i>
</a>
</li>
</ul>
<ul id="bbcode-container-movies" class="bbcode-container bbcode-container-more dlt-color-op20-after">
<li class="bbcode-elements bkgd-color-op20-hover">
<a href="" onclick="insertbbcode('[swf=425,344]', '[/swf]', 'comments_message');return false;" aria-label="Insérer du flash [swf=largeur,hauteur]adresse animation[/swf]">
<i class="fa fa-fw bbcode-icon-flash" aria-hidden="true" title="Insérer du flash [swf=largeur,hauteur]adresse animation[/swf]"></i>
</a>
</li>
<li class="bbcode-elements bkgd-color-op20-hover">
<a href="" onclick="insertbbcode('[movie=100,100]', '[/movie]', 'comments_message');return false;" aria-label="Vidéo [movie=largeur,hauteur]adresse du fichier[/movie]">
<i class="fa fa-fw bbcode-icon-movie" aria-hidden="true" title="Vidéo [movie=largeur,hauteur]adresse du fichier[/movie]"></i>
</a>
</li>
<li class="bbcode-elements bkgd-color-op20-hover">
<a href="" onclick="insertbbcode('[youtube]', '[/youtube]', 'comments_message');return false;" aria-label="Ajouter une vidéo youtube : [youtube=largeur,hauteur]url youtube[/youtube]">
<i class="fab fa-fw bbcode-icon-youtube" aria-hidden="true" title="Ajouter une vidéo youtube : [youtube=largeur,hauteur]url youtube[/youtube]"></i>
</a>
</li>
<li class="bbcode-elements bkgd-color-op20-hover">
<a href="" onclick="insertbbcode('[sound]', '[/sound]', 'comments_message');return false;" aria-label="Son [sound]adresse du son[/sound]">
<i class="fa fa-fw bbcode-icon-sound" aria-hidden="true" title="Son [sound]adresse du son[/sound]"></i>
</a>
</li>
</ul>
<ul id="bbcode-container-code" class="bbcode-container bbcode-container-more dlt-color-op20-after">
<li class="bbcode-elements bkgd-color-op20-hover">
<a href="" onclick="bb_display_block('8', 'comments_message');return false;" onmouseout="bb_hide_block('8', 'comments_message', 0);" class="bbcode-hover" aria-label="Insérer du code [code=langage]texte[/code]">
<i class="fa fa-fw bbcode-icon-code" aria-hidden="true" title="Insérer du code [code=langage]texte[/code]"></i>
</a>
<div id="bb-block8comments_message" class="bbcode-block-container arrow-submenu-color" style="display: none;">
<div class="bbcode-block block-submenu-color bbcode-block-list bkgd-color-op20-hover bbcode-block-code" onmouseover="bb_hide_block('8', 'comments_message', 1);" onmouseout="bb_hide_block('8', 'comments_message', 0);">
<ul>
<li class="bbcode-code-title bkgd-color-op40"><span>Texte</span></li>
<li><a href="" onclick="insertbbcode('[code=text]', '[/code]', 'comments_message');bb_hide_block('8', 'comments_message', 0);return false;" title=" text">Text</a></li>
<li><a href="" onclick="insertbbcode('[code=sql]', '[/code]', 'comments_message');bb_hide_block('8', 'comments_message', 0);return false;" title=" sql">SqL</a></li>
<li><a href="" onclick="insertbbcode('[code=xml]', '[/code]', 'comments_message');bb_hide_block('8', 'comments_message', 0);return false;" title=" xml">Xml</a></li>
<li class="bbcode-code-title bkgd-color-op40"><span>PHPBoost</span></li>
<li><a href="" onclick="insertbbcode('[code=bbcode]', '[/code]', 'comments_message');bb_hide_block('8', 'comments_message', 0);return false;" title=" bbcode">BBCode</a></li>
<li><a href="" onclick="insertbbcode('[code=tpl]', '[/code]', 'comments_message');bb_hide_block('8', 'comments_message', 0);return false;" title=" template">Template</a></li>
<li class="bbcode-code-title bkgd-color-op40"><span>Script</span></li>
<li><a href="" onclick="insertbbcode('[code=php]', '[/code]', 'comments_message');bb_hide_block('8', 'comments_message', 0);return false;" title=" php">PHP</a></li>
<li><a href="" onclick="insertbbcode('[code=asp]', '[/code]', 'comments_message');bb_hide_block('8', 'comments_message', 0);return false;" title=" asp">Asp</a></li>
<li><a href="" onclick="insertbbcode('[code=python]', '[/code]', 'comments_message');bb_hide_block('8', 'comments_message', 0);return false;" title=" python">Python</a></li>
<li><a href="" onclick="insertbbcode('[code=pearl]', '[/code]', 'comments_message');bb_hide_block('8', 'comments_message', 0);return false;" title=" text">Pearl</a></li>
<li><a href="" onclick="insertbbcode('[code=ruby]', '[/code]', 'comments_message');bb_hide_block('8', 'comments_message', 0);return false;" title=" ruby">Ruby</a></li>
<li><a href="" onclick="insertbbcode('[code=bash]', '[/code]', 'comments_message');bb_hide_block('8', 'comments_message', 0);return false;" title=" bash">Bash</a></li>
<li class="bbcode-code-title bkgd-color-op40"><span>Web</span></li>
<li><a href="" onclick="insertbbcode('[code=html]', '[/code]', 'comments_message');bb_hide_block('8', 'comments_message', 0);return false;" title=" html">Html</a></li>
<li><a href="" onclick="insertbbcode('[code=css]', '[/code]', 'comments_message');bb_hide_block('8', 'comments_message', 0);return false;" title=" css">Css</a></li>
<li><a href="" onclick="insertbbcode('[code=javascript]', '[/code]', 'comments_message');bb_hide_block('8', 'comments_message', 0);return false;" title=" javascript">Javascript</a></li>
<li class="bbcode-code-title bkgd-color-op40"><span>Programmation</span></li>
<li><a href="" onclick="insertbbcode('[code=c]', '[/code]', 'comments_message');bb_hide_block('8', 'comments_message', 0);return false;" title=" c">C</a></li>
<li><a href="" onclick="insertbbcode('[code=cpp]', '[/code]', 'comments_message');bb_hide_block('8', 'comments_message', 0);return false;" title=" c++">C++</a></li>
<li><a href="" onclick="insertbbcode('[code=c#]', '[/code]', 'comments_message');bb_hide_block('8', 'comments_message', 0);return false;" title=" c#">C#</a></li>
<li><a href="" onclick="insertbbcode('[code=d]', '[/code]', 'comments_message');bb_hide_block('8', 'comments_message', 0);return false;" title=" d">D</a></li>
<li><a href="" onclick="insertbbcode('[code=go]', '[/code]', 'comments_message');bb_hide_block('8', 'comments_message', 0);return false;" title=" go">Go</a></li>
<li><a href="" onclick="insertbbcode('[code=java]', '[/code]', 'comments_message');bb_hide_block('8', 'comments_message', 0);return false;" title=" java">Java</a></li>
<li><a href="" onclick="insertbbcode('[code=pascal]', '[/code]', 'comments_message');bb_hide_block('8', 'comments_message', 0);return false;" title=" pascal">Pascal</a></li>
<li><a href="" onclick="insertbbcode('[code=delphi]', '[/code]', 'comments_message');bb_hide_block('8', 'comments_message', 0);return false;" title=" delphi">Delphi</a></li>
<li><a href="" onclick="insertbbcode('[code=fortran]', '[/code]', 'comments_message');bb_hide_block('8', 'comments_message', 0);return false;" title=" fortran">Fortran</a></li>
<li><a href="" onclick="insertbbcode('[code=vb]', '[/code]', 'comments_message');bb_hide_block('8', 'comments_message', 0);return false;" title=" vb">Vb</a></li>
<li><a href="" onclick="insertbbcode('[code=asm]', '[/code]', 'comments_message');bb_hide_block('8', 'comments_message', 0);return false;" title=" asm">Asm</a></li>
</ul>
</div>
</div>
</li>
<li class="bbcode-elements bkgd-color-op20-hover">
<a href="" onclick="insertbbcode('[math]', '[/math]', 'comments_message');return false;" aria-label="Insérer du code mathématique [math]texte[/math]">
<i class="fab fa-fw bbcode-icon-math" aria-hidden="true" title="Insérer du code mathématique [math]texte[/math]"></i>
</a>
</li>
<li class="bbcode-elements bkgd-color-op20-hover">
<a href="" onclick="insertbbcode('[html]', '[/html]', 'comments_message');return false;" aria-label="Code html [html]code[/html]">
<i class="fab fa-fw bbcode-icon-html" aria-hidden="true" title="Code html [html]code[/html]"></i>
</a>
</li>
</ul>
<ul id="bbcode-container-mail" class="bbcode-container bbcode-container-more dlt-color-op20-after">
<li class="bbcode-elements bkgd-color-op20-hover">
<a href="" onclick="bbcode_mail('comments_message', 'Adresse e-mail ?');return false;" aria-label="e-mail [mail=xxx@yy.zz]text[/mail]">
<i class="fa fa-fw bbcode-icon-mail" aria-hidden="true" title="e-mail [mail=xxx@yy.zz]text[/mail]"></i>
</a>
</li>
</ul>
<ul id="bbcode-container-feed" class="bbcode-container bbcode-container-more dlt-color-op20-after">
<li class="bbcode-elements bkgd-color-op20-hover">
<a href="" onclick="bbcode_feed('comments_message', 'Nom du module');return false;" aria-label="Flux RSS [feed cat=&quot;NumCat&quot; number=&quot;NbFlux&quot;]module[/feed]">
<i class="fa fa-fw bbcode-icon-feed" aria-hidden="true" title="Flux RSS [feed cat=&quot;NumCat&quot; number=&quot;NbFlux&quot;]module[/feed]"></i>
</a>
</li>
</ul>
<ul id="bbcode-container-help" class="bbcode-container bbcode-container-more dlt-color-op20-after">
<li class="bbcode-elements bkgd-color-op20-hover">
<a href="https://www.phpboost.com/wiki/bbcode" aria-label="Aide BBcode Nouvelle fenêtre" target="_blank" rel="noopener">
<i class="fa fa-fw bbcode-icon-help" aria-hidden="true" title="Aide BBcode"></i>
</a>
</li>
</ul>
</div>
<div class="bbcode-elements bkgd-color-op20-hover bbcode-elements-more">
<a href="" aria-label="Afficher/cacher les autres fonctions" title="Afficher/cacher les autres fonctions" onclick="show_bbcode_div('bbcode-container-more');return false;">
<i class="fa fa-fw bbcode-icon-more bbcode-hover"></i>
</a>
</div>
</div>
<div id="onblurContainerResponsecomments_message" class="form-field-textarea picture-status-constraint field-required ">
<textarea id="comments_message" name="comments_message" rows="10" cols="47" class=" " onblur=""></textarea>
<span class="text-status-constraint" style="display: none;" id="onblurMessageResponsecomments_message"></span>
</div>
<div class="center">
<div class="form-element-preview"><button type="button" class="small" onclick="XMLHttpRequest_preview('comments_message');">Prévisualiser</button></div>
</div>
</div>
</div>
</fieldset>
<fieldset id="comments_captcha_fieldset">
<div class="fieldset-inset">
<div id="comments_captcha_field" class="form-element">
<label for="comments_captcha">* Code de vérification </label>
<div class="form-field">
<span>Indiquer les initiales de la phrase : Adrien est administrateur de Linuxtricks</span>
<div class="spacer"></div>
<input type="text" class="field-large" name="comments_captcha" id="comments_captcha" />
<input type="hidden" name="comments_captcha_question_id" value="3" />
</div>
</div>
</div>
</fieldset>
<fieldset id="comments_fbuttons" class="fieldset-submit">
<div class="fieldset-inset">
<button type="submit" id="comments_submit" name="comments_submit" class="submit" onclick="" value="true">Envoyer</button>
<button type="reset" class="" value="true">Défaut</button>
</div>
</fieldset>
<input type="hidden" id="comments_token" name="token" value="3e50b316b8e33a57">
<input type="hidden" id="comments_disabled_fields" name="comments_disabled_fields" value="">
<input type="hidden" id="comments_disabled_fieldsets" name="comments_disabled_fieldsets" value="">
</form>
</div>
<div class="spacer"></div>
<article id="com1306" class="message" itemscope="itemscope" itemtype="http://schema.org/Comment">
<header>
<h2>Commentaire</h2>
</header>
<div class="message-container">
<div class="message-user-infos">
<div class="message-pseudo">
<span itemprop="author">Chen Linux</span>
<div class="message-level">Visiteur</div>
</div>
<img src="/templates/linuxtricks/images/no_avatar.png" alt="Avatar" title="Avatar" class="message-avatar" />
</div>
<div class="message-date">
<span class="actions">
<a itemprop="url" href="#com1306">#1306</a>
</span>
<time itemprop="datePublished" datetime="2020-04-25T12:33:41+02:00">25/04/2020 à 12h33</time>
</div>
<div class="message-message">
<div itemprop="text" class="message-content"><div class="formatter-container formatter-blockquote"><span class="formatter-title title-perso">Adrien D :</span><div class="formatter-content">y a des gens qui utilisent Ubuntu Server ?</div></div><br />
D&#8217;après ce site oui : <a href="https://www.similartech.com/compare/centos-vs-ubuntu">CentOS VS Ubuntu</a> et <a href="https://www.similartech.com/compare/debian-vs-ubuntu">Debian vs Ubuntu</a>.<br />
<br />
Globalement ce que j&#8217;en pense (ça rejoint ton point de vue) : ça peut être un bon remplaçant des PPA pour pouvoir installer des logiciels tiers mais les dépôts officiels d&#8217;Ubuntu doivent rester, et avec la même offre qu&#8217;actuellement en termes de logiciels (plus Chromium qui, étant le deuxième navigateur le plus utilisé sous Linux, devrait rester dans les dépôts d&#8217;Ubuntu). Parce que si on en abuse, on est bien d'accord que ça alourdit et ralentit le système.  <img src="/images/smileys/6.gif" alt=";)" title=";)" class="smiley" /></div>
<!--
<div id="message-rating">
<div class="positive_vote_button">+</div>
<div class="negative_vote_button">-</div>
</div>
 -->
</div>
</div>
<footer></footer>
</article>
<article id="com1307" class="message" itemscope="itemscope" itemtype="http://schema.org/Comment">
<header>
<h2>Commentaire</h2>
</header>
<div class="message-container">
<div class="message-user-infos">
<div class="message-pseudo">
<span itemprop="author">Pascal R.</span>
<div class="message-level">Visiteur</div>
</div>
<img src="/templates/linuxtricks/images/no_avatar.png" alt="Avatar" title="Avatar" class="message-avatar" />
</div>
<div class="message-date">
<span class="actions">
<a itemprop="url" href="#com1307">#1307</a>
</span>
<time itemprop="datePublished" datetime="2020-04-25T14:39:00+02:00">25/04/2020 à 14h39</time>
</div>
<div class="message-message">
<div itemprop="text" class="message-content">Assez d'accord avec ton approche des snaps.<br />
Peux tu me dire où se trouve ta vidéo pour passer les .deb en priorité et les snaps en second plan stp .<br />
<br />
A+</div>
<!--
<div id="message-rating">
<div class="positive_vote_button">+</div>
<div class="negative_vote_button">-</div>
</div>
 -->
</div>
</div>
<footer></footer>
</article>
<article id="com1308" class="message" itemscope="itemscope" itemtype="http://schema.org/Comment">
<header>
<h2>Commentaire</h2>
</header>
<div class="message-container">
<div class="message-user-infos">
<div class="message-pseudo">
<a itemprop="author" href="/user/profile/1" class="admin" >
Adrien.D
</a>
<div class="message-level">Administrateur</div>
</div>
<img src="/images/avatars/myavatar-125-6e442.png" alt="Avatar" title="Avatar" class="message-avatar" />
</div>
<div class="message-date">
<span class="actions">
<a itemprop="url" href="#com1308">#1308</a>
</span>
<time itemprop="datePublished" datetime="2020-04-25T17:13:36+02:00">25/04/2020 à 17h13</time>
</div>
<div class="message-message">
<div itemprop="text" class="message-content">@Pascal : J'ai fait juste une vidéo pour bloquer les snaps (ce qui empêche d'installer chromium) : <a href="/wiki/ubuntu-supprimer-et-bloquer-les-snaps">https://www.linuxtricks.fr/wiki/ubuntu-supprimer-et-bloquer-les-snaps</a><br />
Je n'ai pas fait de vidéo sur le deb de Chromium dans Ubuntu mais l'article est là : <a href="/wiki/ubuntu-installer-chromium-de-debian-au-lieu-du-snap">https://www.linuxtricks.fr/wiki/ubuntu-installer-chromium-de-debian-au-lieu-du-snap</a></div>
<!--
<div id="message-rating">
<div class="positive_vote_button">+</div>
<div class="negative_vote_button">-</div>
</div>
 -->
</div>
</div>
<footer></footer>
</article>
<article id="com1309" class="message" itemscope="itemscope" itemtype="http://schema.org/Comment">
<header>
<h2>Commentaire</h2>
</header>
<div class="message-container">
<div class="message-user-infos">
<div class="message-pseudo">
<span itemprop="author">Stello</span>
<div class="message-level">Visiteur</div>
</div>
<img src="/templates/linuxtricks/images/no_avatar.png" alt="Avatar" title="Avatar" class="message-avatar" />
</div>
<div class="message-date">
<span class="actions">
<a itemprop="url" href="#com1309">#1309</a>
</span>
<time itemprop="datePublished" datetime="2020-04-25T19:55:56+02:00">25/04/2020 à 19h55</time>
</div>
<div class="message-message">
<div itemprop="text" class="message-content">Je suis sous xubuntu 20.04 (pc d'essai (vieux mais je suis riche (au SMIC))).Pour celui de tous les jour sur xubuntu 16.04 et pas 18.04 principalement à  cause des snap!!?.<br />
Dès que j'ai installé Focal Fossa j'ai dégagé les snap, installé synaptic et dégagé gnome sofware.<br />
Pourquoi :<br />
Je suis un utilisateur lambda de PC desktop, et je n'ai pas envie d'avoir mon Gimp avec la dernière version, même si je l'utilise très souvent.<br />
Tout ce que j'ai envie c'est un PC qui soit à jour en sécurité et qui ne me demande pas de cliquer sur MAJ ou mise à niveau ou autres chaque fois que je le met en route.<br />
J'avoue que j'ai un netbook avec Debian 9 xfce et compiz (qui fonctionne très bien) et qu 'en temps que noob j'était près à repasser sous Debian (free) 10 ou 11 Xfce.<br />
Rappelez vous bien que l'utilisateur lamda (HUMAN) a besoin de stabilité mais pas d'une AI qui change tous les mois.<br />
Une LTS suffit, sauf sous Unity.<br />
Faire simple, sans gadgets inutiles, stable : un esclave électronique .|*<br />
<br />
*: Pour les codeur= .| veut dire: point barre.<br />
<br />
à+<br /></div>
<!--
<div id="message-rating">
<div class="positive_vote_button">+</div>
<div class="negative_vote_button">-</div>
</div>
 -->
</div>
</div>
<footer></footer>
</article>
<article id="com1310" class="message" itemscope="itemscope" itemtype="http://schema.org/Comment">
<header>
<h2>Commentaire</h2>
</header>
<div class="message-container">
<div class="message-user-infos">
<div class="message-pseudo">
<span itemprop="author">Nico</span>
<div class="message-level">Visiteur</div>
</div>
<img src="/templates/linuxtricks/images/no_avatar.png" alt="Avatar" title="Avatar" class="message-avatar" />
</div>
<div class="message-date">
<span class="actions">
<a itemprop="url" href="#com1310">#1310</a>
</span>
<time itemprop="datePublished" datetime="2020-04-25T20:22:05+02:00">25/04/2020 à 20h22</time>
</div>
<div class="message-message">
<div itemprop="text" class="message-content">Les problèmes de dépendances sont résolut avec snap/flatpack et autre. Ce genre de projet est complètement aligné avec le comportment coté serveur que l'on recherche avec la conteneurisation. Du coup je comprends que les dev poussent ce genre de techo. A voir qui va gagner la bataille maintenant entre snap/flatpack.</div>
<!--
<div id="message-rating">
<div class="positive_vote_button">+</div>
<div class="negative_vote_button">-</div>
</div>
 -->
</div>
</div>
<footer></footer>
</article>
<article id="com1311" class="message" itemscope="itemscope" itemtype="http://schema.org/Comment">
<header>
<h2>Commentaire</h2>
</header>
<div class="message-container">
<div class="message-user-infos">
<div class="message-pseudo">
<span itemprop="author">Rémy D.</span>
<div class="message-level">Visiteur</div>
</div>
<img src="/templates/linuxtricks/images/no_avatar.png" alt="Avatar" title="Avatar" class="message-avatar" />
</div>
<div class="message-date">
<span class="actions">
<a itemprop="url" href="#com1311">#1311</a>
</span>
<time itemprop="datePublished" datetime="2020-04-25T20:56:34+02:00">25/04/2020 à 20h56</time>
</div>
<div class="message-message">
<div itemprop="text" class="message-content">Je trouve les snap peu réactif et consommateurs d espaces.<br />
Par contre ubuntu impose tellement cet outils que si tu le supprimes et bin tu peux plus installer certains soft.<br />
Ubuntu ne propose pas d alternatives. Je m explique, j ai désinstallé snapd mais si je veux chromium depuis la logithèque ubuntu, il faut que je le réinstalle snapd</div>
<!--
<div id="message-rating">
<div class="positive_vote_button">+</div>
<div class="negative_vote_button">-</div>
</div>
 -->
</div>
</div>
<footer></footer>
</article>
<article id="com1312" class="message" itemscope="itemscope" itemtype="http://schema.org/Comment">
<header>
<h2>Commentaire</h2>
</header>
<div class="message-container">
<div class="message-user-infos">
<div class="message-pseudo">
<span itemprop="author">Goupil74</span>
<div class="message-level">Visiteur</div>
</div>
<img src="/templates/linuxtricks/images/no_avatar.png" alt="Avatar" title="Avatar" class="message-avatar" />
</div>
<div class="message-date">
<span class="actions">
<a itemprop="url" href="#com1312">#1312</a>
</span>
<time itemprop="datePublished" datetime="2020-04-26T08:52:05+02:00">26/04/2020 à 08h52</time>
</div>
<div class="message-message">
<div itemprop="text" class="message-content">Le paquet snap, je le considère comme un progrès pour obtenir des versions plus à jours. Par expérience, jouer avec les dépôts c'est s'exposer à des problèmes de cohérences gênantes, le snap permet de ne pas toucher aux dépôts. Mais les inconvénients ont bien été listés plus haut, et je parle pas de la présentation catastrophique dans Logiciels de Ubuntu (logiciels présentés deux fois version dépôts et snap sans distinction claire, déroutant surtout pour un débutant). Le snap cela reste quand même la facilité pour avoir un logiciel plus à jour, mais si on a les compétences, une installation manuelle sera à privilégier à mon gout pour des questions de performances et d'intégration. Par exemple moi j'utilise Debian, avec Firefox ESR dans les dépôts, au début j'ai voulu passer sur Firefox Release simplement par un snap, j'en suis revenu, performances de démarrages trop longues.... Je me suis retroussé les manches, j'ai fait une installation manuelle et la tout va bien.</div>
<!--
<div id="message-rating">
<div class="positive_vote_button">+</div>
<div class="negative_vote_button">-</div>
</div>
 -->
</div>
</div>
<footer></footer>
</article>
<article id="com1313" class="message" itemscope="itemscope" itemtype="http://schema.org/Comment">
<header>
<h2>Commentaire</h2>
</header>
<div class="message-container">
<div class="message-user-infos">
<div class="message-pseudo">
<span itemprop="author">Goupil74</span>
<div class="message-level">Visiteur</div>
</div>
<img src="/templates/linuxtricks/images/no_avatar.png" alt="Avatar" title="Avatar" class="message-avatar" />
</div>
<div class="message-date">
<span class="actions">
<a itemprop="url" href="#com1313">#1313</a>
</span>
<time itemprop="datePublished" datetime="2020-04-26T09:01:25+02:00">26/04/2020 à 09h01</time>
</div>
<div class="message-message">
<div itemprop="text" class="message-content"><div class="formatter-container formatter-blockquote"><span class="formatter-title title-perso">Adrien D :</span><div class="formatter-content">y a des gens qui utilisent Ubuntu Server ?</div></div><br />
<br />
Oui!!! En entreprise un peu importante il n'y a que trois distributions valables en serveur planplan : CentOS/RHEL, Debian et Ubuntu Server.<br />
<br />
Sans parler de CentOS un peu à part qu'on utilise pour l'exceptionnel durée de support et une meilleure compatibilité applications éditeurs (Oracle, PowerChute etc), il y a deux grands avantages de Ubuntu Server sur Debian, la durée de support plus longue et les logiciels, je pense notamment aux composants lamp qui sont un peu plus à jour que sur Debian et ce sans sacrifice sur la stabilité.</div>
<!--
<div id="message-rating">
<div class="positive_vote_button">+</div>
<div class="negative_vote_button">-</div>
</div>
 -->
</div>
</div>
<footer></footer>
</article>
<article id="com1314" class="message" itemscope="itemscope" itemtype="http://schema.org/Comment">
<header>
<h2>Commentaire</h2>
</header>
<div class="message-container">
<div class="message-user-infos">
<div class="message-pseudo">
<span itemprop="author">math</span>
<div class="message-level">Visiteur</div>
</div>
<img src="/templates/linuxtricks/images/no_avatar.png" alt="Avatar" title="Avatar" class="message-avatar" />
</div>
<div class="message-date">
<span class="actions">
<a itemprop="url" href="#com1314">#1314</a>
</span>
<time itemprop="datePublished" datetime="2020-04-26T09:35:42+02:00">26/04/2020 à 09h35</time>
</div>
<div class="message-message">
<div itemprop="text" class="message-content">Merci pour cet article!<br />
Sans être informaticien, je trouve que ce genre de format d'application est une mauvaise idée pour l'environnement linux en général: cela permet de fournir une application avec ses dépendances obsolètes... Avec un .deb, ou autre, si une mise a jour d'une dépendance X crée un bug sur une application Y, cela se voit et l'information est disponible pour les deux projets. Et c'est la tout l&#8217;intérêt de l'environnement Linux et la principale raison de sa solidité/stabilité, non?<br />
Sauf qu'avec les snap et consort, ben on laissera le vieux paquet périmé dans l'application (ça marche, pourquoi le mettre a jour?), et on aura un paquet bugué dans les dépots... On risque alors de n'avoir plus que des snaps à la .exe, parce que c'est plus facile, où on ne sait pas ce qu'il y a dedans et avec toutes les joyeusetés qui vont avec... (la facilité à court terme finit toujours par gagner quelque soit l'intelligence de l'alternative: les deb et snap vont coexister, puis la version du deb aura du retard vs celle du snap, puis le deb sera négligé, puis carrément abandonné)<br />
Je ne suis donc pas d'accord que "l'imposition" des snap sur .deb soit le problème: car c'est une conséquence inéluctable lié au principe de concurrence !<br />
De mon point de vue il faut prendre garde que les décisions ne portent pas atteinte à l&#8217;écosystème linux, même si elles semblent bien techniquement...</div>
<!--
<div id="message-rating">
<div class="positive_vote_button">+</div>
<div class="negative_vote_button">-</div>
</div>
 -->
</div>
</div>
<footer></footer>
</article>
<article id="com1315" class="message" itemscope="itemscope" itemtype="http://schema.org/Comment">
<header>
<h2>Commentaire</h2>
</header>
<div class="message-container">
<div class="message-user-infos">
<div class="message-pseudo">
<span itemprop="author">JiPi_82</span>
<div class="message-level">Visiteur</div>
</div>
<img src="/templates/linuxtricks/images/no_avatar.png" alt="Avatar" title="Avatar" class="message-avatar" />
</div>
<div class="message-date">
<span class="actions">
<a itemprop="url" href="#com1315">#1315</a>
</span>
<time itemprop="datePublished" datetime="2020-04-26T13:35:22+02:00">26/04/2020 à 13h35</time>
</div>
<div class="message-message">
<div itemprop="text" class="message-content">Bonjour Adrien,<br />
Pour ma part, je n'ai pas de religion sur les snaps. Néanmoins, mis à part le fait que la logithèque impose et que l'utilisateur dispose me fait un peu rager. Nous avions UNITY, c'était pas mal, et puis un jour, hop, dégagé. Pour les deb, même statégie. Ça fait pas rêver, et l'image du monde du libre en prend un coup. En fait, ce n'est pas si libre que ça, alors ?!?<br />
De mon côté, j'ai constaté qu'un certain nombre de deb et de snap ne présentaient pas toutes les options propres à chaque logiciel.<br />
GIMP : Ben, pour la 2.10, c'est en SNAP, mais pas de module RAW. C'est plutôt gênant pour traiter des photos de qualité. A moins de se lancer dans la ligne de commandes pour bidouiller - C'est de l'infographie qu'on veut faire, pas de l'informatique à tout va.<br />
kdenlive 19.12.3 : La fonction "rendu" ne marchait chez moi  - j'ai tout migré sur kde neon pour faire tourner la même version en deb, et là pas de soucis. L'AppImage 20.04 marche aussi.<br />
Qalculate! n'est présent qu'en snap - le dépot n'est pas à jour.<br />
En fait, la version 20.04 d'Ubuntu a fait le bon choix de mettre à disposition qu'une seule logithèque sans autre possibilité, ça évite de trop bidouiller. À moins qu'il s'agisse d'un manque de temps.</div>
<!--
<div id="message-rating">
<div class="positive_vote_button">+</div>
<div class="negative_vote_button">-</div>
</div>
 -->
</div>
</div>
<footer></footer>
</article>
<article id="com1317" class="message" itemscope="itemscope" itemtype="http://schema.org/Comment">
<header>
<h2>Commentaire</h2>
</header>
<div class="message-container">
<div class="message-user-infos">
<div class="message-pseudo">
<span itemprop="author">Visiteur</span>
<div class="message-level">Visiteur</div>
</div>
<img src="/templates/linuxtricks/images/no_avatar.png" alt="Avatar" title="Avatar" class="message-avatar" />
</div>
<div class="message-date">
<span class="actions">
<a itemprop="url" href="#com1317">#1317</a>
</span>
<time itemprop="datePublished" datetime="2020-04-27T10:53:55+02:00">27/04/2020 à 10h53</time>
</div>
<div class="message-message">
<div itemprop="text" class="message-content">J'ajouterais un bug de certains snaps quand la mise à l'échelle de l'affichage est activée : L'interface de certaines apps snap est minuscule, à peine lisible le nez collé à l'écran (20.04 avec l'échelle à 125% dans les paramètres écran).</div>
<!--
<div id="message-rating">
<div class="positive_vote_button">+</div>
<div class="negative_vote_button">-</div>
</div>
 -->
</div>
</div>
<footer></footer>
</article>
<article id="com1318" class="message" itemscope="itemscope" itemtype="http://schema.org/Comment">
<header>
<h2>Commentaire</h2>
</header>
<div class="message-container">
<div class="message-user-infos">
<div class="message-pseudo">
<span itemprop="author">cyp</span>
<div class="message-level">Visiteur</div>
</div>
<img src="/templates/linuxtricks/images/no_avatar.png" alt="Avatar" title="Avatar" class="message-avatar" />
</div>
<div class="message-date">
<span class="actions">
<a itemprop="url" href="#com1318">#1318</a>
</span>
<time itemprop="datePublished" datetime="2020-04-27T11:05:10+02:00">27/04/2020 à 11h05</time>
</div>
<div class="message-message">
<div itemprop="text" class="message-content">Les Snaps (ou les Flatpaks) c'est bien pour dépanner, facile a installer pour les utilisateurs, facile a packager pour les développeur mais tout cette facilité se paye par un manque global d'intégration.<br />
Bref pratique à l'occasion mais pour les logiciels du quotidien l'expérience est tout de même beaucoup plus agréable avec des package natifs et pour Ubuntu LTS par exemple c'est tout de même pas ce qu'il manque Mozilla en fournit pour Firefox/Thunderbird, Libreoffice ou Gimp ont aussi le leur....<br />
Attention aussi à la sécurité pour les Snaps, on retrouve le même souci qu'avec Flatpak ou Docker, il ne sont généralement mis à jour que lorsqu'une nouvelle version du logiciel est disponible mais très rarement lorsqu'une dépendance l'est. Résultat une grosse faille sur une dépendance et le Snap/Flatpak/Focker peux rester vulnérable pendant des mois, la containérisation permet de limiter les risques mais ne rend pas impossible les hacks (ne serait ce que le leak de toutes les infos auquel l'application peux accéder).</div>
<!--
<div id="message-rating">
<div class="positive_vote_button">+</div>
<div class="negative_vote_button">-</div>
</div>
 -->
</div>
</div>
<footer></footer>
</article>
<article id="com1319" class="message" itemscope="itemscope" itemtype="http://schema.org/Comment">
<header>
<h2>Commentaire</h2>
</header>
<div class="message-container">
<div class="message-user-infos">
<div class="message-pseudo">
<span itemprop="author">Visiteur</span>
<div class="message-level">Visiteur</div>
</div>
<img src="/templates/linuxtricks/images/no_avatar.png" alt="Avatar" title="Avatar" class="message-avatar" />
</div>
<div class="message-date">
<span class="actions">
<a itemprop="url" href="#com1319">#1319</a>
</span>
<time itemprop="datePublished" datetime="2020-04-27T11:07:27+02:00">27/04/2020 à 11h07</time>
</div>
<div class="message-message">
<div itemprop="text" class="message-content">La centralisation du dépôt de Snap chez Canonical est pour moi le point le plus problématique. Les mises à jour automatiques sans interaction utilisateur le second soucis.<br />
<br />
Je suis très content de l'utilisation de Flatpak pour l'installation des applications graphiques pour lesquelles j'aime avoir la dernière version, comme Blender, Godot, Riot, Arduino IDE, OBS Studio, Fritzing, PyCharm.<br />
<br />
Sur ce point, Flatpak et Snap répondent à un vrai besoin de permettre la mise à jour d'applications de bureau à une fréquence plus élevée que ce que propose la distribution, tout en maintenant un système stable sans rolling-release.<br /></div>
<!--
<div id="message-rating">
<div class="positive_vote_button">+</div>
<div class="negative_vote_button">-</div>
</div>
 -->
</div>
</div>
<footer></footer>
</article>
<article id="com1320" class="message" itemscope="itemscope" itemtype="http://schema.org/Comment">
<header>
<h2>Commentaire</h2>
</header>
<div class="message-container">
<div class="message-user-infos">
<div class="message-pseudo">
<span itemprop="author">Altery Disroot</span>
<div class="message-level">Visiteur</div>
</div>
<img src="/templates/linuxtricks/images/no_avatar.png" alt="Avatar" title="Avatar" class="message-avatar" />
</div>
<div class="message-date">
<span class="actions">
<a itemprop="url" href="#com1320">#1320</a>
</span>
<time itemprop="datePublished" datetime="2020-04-27T12:40:39+02:00">27/04/2020 à 12h40</time>
</div>
<div class="message-message">
<div itemprop="text" class="message-content">Je citerai Nick de LinuxExperiment qui dit "a package is a package". Bon c'est plus complexe que ça bien sûr, et évidemment sur une machine à faibles ressources, ça va poser des soucis.<br />
J'utilise des snaps, notamment pour les applis non disponibles dans les dépôts, genre Sengi, client Mastodon dispo qu'en Snap (et Appimage peut-être?)<br />
Donc je pense que malgré tous les défauts bien réels de ce système, ça permet d'enrichir sa logithèque : Signal Desktop, Gimp à jour quel que soit le système (oui ça se fait aussi en flatpak), Mattermost, et ça continue de s'enrichir. Finalement je vois le bon côté du truc, rendre de plus en plus de logiciels disponibles.<br />
Je ne suis qu'un utilisateur final avec pas vraiment d'avis technique, ce que je vois de mon côté c'est que ça m'offre plus de possibilités, ensuite je choisis des logiciels libres dans le lot (par contre l'étiquettage des logiciels libres et parfois foireux).<br />
Mais dans cette histoire ce que je trouve, disons le mot, aberrant, ce sont les guerres d'églises entre ceux qui préfèrent flatpak et ceux qui préfèrent snap, ce sont des combats inutiles et l'existence de ces formats universels sont une très bonne chose pour "l'écosystème" GNU/Linux.</div>
<!--
<div id="message-rating">
<div class="positive_vote_button">+</div>
<div class="negative_vote_button">-</div>
</div>
 -->
</div>
</div>
<footer></footer>
</article>
</div>
<footer></footer>
</section>

</aside>
</div>
<footer></footer>
</section>

</div>
</div>
<div class="spacer"></div>
</div>
<footer id="footer">
<div class="footer-infos">
<span>
Boosté par <a href="http://www.phpboost.com" title="PHPBoost">PHPBoost</a> | <a href="/pages/mentions-legales">Mentions légales</a><br>
Linuxtricks est mis à disposition selon les termes : <a href="https://creativecommons.org/licenses/by-sa/2.0/fr/" target="_blank">Licence Creative Commons</a> <img src="/upload/cc_by_sa_petit.png" alt="CC by SA"> <br><br>
</span>
</div>
</footer>
<span id="scroll-to-top" class="scroll-to" aria-label="haut de la page"><i class="fa fa-chevron-up" aria-hidden="true" title="haut de la page"></i></span>


<script>
<!--
//Variables PHPBoost
var PATH_TO_ROOT = "";
var TOKEN        = "3e50b316b8e33a57";
var THEME        = "linuxtricks";
var LANG         = "french";
//Variables BBCode
var L_HIDE_MESSAGE    = 'Ce message est caché, cliquer ici pour afficher son contenu.';
var L_HIDE_HIDEBLOCK  = 'Cliquer ici pour cacher le message.';
var L_COPYTOCLIPBOARD = 'Copier vers le presse-papier';
//Variables CookieBar
-->
</script><script src="/kernel/lib/js/jquery/jquery.js"></script><script src="/kernel/lib/js/global.js"></script><script src="/templates/default/plugins/dndfiles.js"></script><script src="/kernel/lib/js/phpboost/form/validator.js"></script><script src="/kernel/lib/js/phpboost/form/form.js"></script><script src="/BBCode/templates/js/bbcode.js"></script><script src="/kernel/lib/js/lightcase/lightcase.js"></script><script>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</script></body>
</html>